HDMI 4x4 matrix repair help - AVS | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!


Forum Jump: 
 
Thread Tools
post #1 of 3 Old 01-04-2013, 03:04 PM - Thread Starter
Member
 
EpicVegas's Avatar
 
Join Date: Oct 2011
Posts: 81
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have a monoprice 4x4 matrix that got the wrong power cable plugged into it and popped.
I quickly shut it off and waited awhile before I plugged the correct power supply into the unit.
All the lights light up solid blue but no switching our source selections work.
Any advice on what I can do or a repair shop that could fix it?

EpicVegas is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 01-05-2013, 08:32 AM - Thread Starter
Member
 
EpicVegas's Avatar
 
Join Date: Oct 2011
Posts: 81
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Any ideas?
I would hate to just through this unit in the trash...
EpicVegas is offline  
post #3 of 3 Old 01-07-2013, 08:33 AM
AVS Special Member
 
Phil17108's Avatar
 
Join Date: Feb 2012
Location: Orange County California
Posts: 1,030
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 38 Post(s)
Liked: 60
Bet it'l cost far more to fix if you can find some one to try then a new one.
Phil17108 is online now  
Sponsored Links
Advertisement
 
Reply Home A/V Distribution

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off