Russound ABUS KP2 power but no sound - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!

Forum Jump: 
Thread Tools
Old 01-18-2013, 07:53 AM - Thread Starter
ibrettferguson's Avatar
Join Date: Jan 2013
Location: Parkville, MO
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Have a basic single source, 4 room setup. (Hd4 + 4 kp2 keypads). And 3 of the 4 work.

The one that doesn't work has power (via indicator light). Is set to single source. But doesn't appear to power on.

6 year old system in a pre-wired home. Just stopped working for no apparent reason.

Thanks a bunch for your help!
ibrettferguson is offline  
Sponsored Links
Old 01-18-2013, 08:52 AM
AVS Special Member
jautor's Avatar
Join Date: Jun 2001
Location: NW Houston, TX
Posts: 9,176
Mentioned: 17 Post(s)
Tagged: 1 Thread(s)
Quoted: 675 Post(s)
Liked: 518
Swap the keypads or swap the wiring at the hub to see if it's the keypad or the hub. These pieces show up on eBay often...


Rock Creek Theater -- CIH, Panamorph, Martin Logan, SVS PB2000, Carada Masquerade, Grafik Eye, Bar table, Green Glue, JVC RS50 
Theater build photos:
jautor is offline  
Thread Tools

Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off