Anthem Video Processing Upgrade - AVS Forum
Forum Jump: 
 
Thread Tools
Old 09-15-2011, 10:45 PM - Thread Starter
Member
 
SKiTLz's Avatar
 
Join Date: Apr 2004
Location: Canada
Posts: 104
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 11
So I just picked up a new Anthem MRX-500 to Replace my aging Onkyo with Faraouja processing.

I'm far from a Videophile. I'm on the audio side. However the second I hooked this Anthem up I was completely unimpressed with the video processing. The only acceptable picture for me is if I put it in Through mode. With the processing on it seems to make everything blocky, especially blacks.

I'm throwing around the idea of keeping the Anthem, since I like everything else about it, and going with a video processor. Personaly I think it's a bit ridicilous that a $1600 receiver has such bad video processing but hey.

I know nothing about the video world though. Can I get something worth wild for under a grand? I really don't want to spend anymore than that.

Cheers guys.

It takes a big man to cry, but it takes a bigger man to laugh at that man
SKiTLz is offline  
Sponsored Links
Advertisement
 
Old 09-16-2011, 01:00 AM
AVS Club Gold
 
Axatax's Avatar
 
Join Date: Aug 2003
Location: S. Florida, USA
Posts: 1,617
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
SKiTLz,

Make sure you cross-post this to the Audio/SSP forum under the "Anthem D2 tweaking guide" thread. There are some real subject matter experts there on the Anthem units, even if this is not your exact SSP.

You should *not* be seeing these artifacts (macroblocking?) - something is amiss.
Axatax is offline  
Old 09-26-2011, 11:01 AM
AVS Special Member
 
rovingtravler's Avatar
 
Join Date: Nov 2010
Location: Clovis, NM
Posts: 1,262
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 14
Make sure to post on the MRX thread too. there are many settigns and if not set correctly you will get bad results. That is the only bad thing about a higher end AVR so much control that it can take a while to set up correctly. I had similar issues with my AVM50v

David

"You buy a Ferrari when you want to be somebody. You buy a Lamborghini when you are somebody." - Frank Sinatra
rovingtravler is offline  
 
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off