Micca EP950! - AVS Forum
Forum Jump: 
Reply
 
Thread Tools
post #1 of 1654 Old 12-19-2011, 08:10 AM - Thread Starter
AVS Special Member
 
GusGus748s's Avatar
 
Join Date: Mar 2009
Location: Visalia, CA 93291
Posts: 6,309
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
Liked: 592

Please post any reviews, comments, experiences, comparisons with other media player about this player.

 

IT APPEARS SUPPORT FOR THIS MEDIA PLAYER HAS BEEN DISCONTINUED.

 

It appears support for this product is only via email.

 

Micca only has a 30 day return / exchange policy with 1 year limited warranty.  If you get a defective unit, the buyer will have to open an RMA and pay for shipping.  It will be up to Micca to either repair or replace the unit.


Media Server: UnRaid Server: 15TB of storage and growing :).

http://www.avsforum.com/lists/display/view/id/8599

 

Home Theater Set Up:

http://www.avsforum.com/lists/display/view/id/8597

GusGus748s is online now  
Sponsored Links
Advertisement
 
post #2 of 1654 Old 12-20-2011, 07:18 AM
AVS Club Gold
 
Jack@Micca's Avatar
 
Join Date: Apr 2010
Posts: 614
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11

THE ABOVE POST IS GIVING OUT FALSE INFORMATION

 

Current Firmware: 1.0.4.23

- Fixes issue where bookmark feature does not work for videos with external subtitles.
- Fixes issue with boot screen graphics output mode.
- Adds favorites feature for creating shortcuts, including network shares.

 

Current known issues:

- Incorrect output frame rate for 23.976fps 3D videos. Player outputs 24Hz instead of 23.976Hz.

- 16:9 DVD menus are displayed in 4:3 ratio. Main movie plays fine in correct 16:9 video.

- In 2D output mode, the right most edge and bottom edge of the screen is over-scanned by a few pixels. This causes a vertical line to exist at the edge of the screen when the TV is used to convert 2D SBS material into 3D.

 

Known Limitations:

- Gigabit Ethernet throughput is about 120mbps due to player processor limitations.

- No support for forced subtitles.

- No A-B repeat points.

- No slow playback.


Jack@Micca
Micca Support Specialist
Jack@Micca is offline  
post #3 of 1654 Old 12-20-2011, 09:10 AM
Senior Member
 
djc11369's Avatar
 
Join Date: Jan 2009
Location: Upstate NY
Posts: 462
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 20
I know it's come up before in other threads so I'll ask here:

What are the differences between the EP950 and the HiMedia 900B other than the 900B has built in wifi?

Is the wireless adapter listed on Amazon compatible with this player (I'm assuming EP900 is a typo)? http://www.amazon.com/Micca-802-11n-...4400806&sr=1-1
djc11369 is offline  
post #4 of 1654 Old 12-20-2011, 06:45 PM
AVS Club Gold
 
Jack@Micca's Avatar
 
Join Date: Apr 2010
Posts: 614
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by djc11369 View Post

I know it's come up before in other threads so I'll ask here:

What are the differences between the EP950 and the HiMedia 900B other than the 900B has built in wifi?

Is the wireless adapter listed on Amazon compatible with this player (I'm assuming EP900 is a typo)? http://www.amazon.com/Micca-802-11n-...4400806&sr=1-1

The hardware and software are comparable between the two players, other than the difference in Wifi. I think someone in another thread is going to do a direct comparison. I believe it will become pretty clear then.

The Wifi dongle we offer will work with the EP950 as well.

Jack@Micca
Micca Support Specialist
Jack@Micca is offline  
post #5 of 1654 Old 12-22-2011, 11:38 PM
Member
 
wsxcde's Avatar
 
Join Date: Dec 2010
Posts: 40
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
The user manual of the EP950 mentions HiTV online. I just received my unit from Amazon. There is no HiTV in the main menu. Will HiTV be added to a firmware update soon? I bought the Micca E950 over the competitors because of HiTV support. If HiTV will not be supported by the EP950, I will return it.
wsxcde is offline  
post #6 of 1654 Old 12-23-2011, 11:39 AM
Newbie
 
yyy123's Avatar
 
Join Date: Dec 2011
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Have you checked HiTV 2.0 inside IMS along with YouTube, Picasa, and other Internet Media Services? It may not be in main/home screen. I'm interested in HiTV 2.0. EP600 does have HiTV 2.0, why not in EP950?

Do you know if the Android browser supports Adobe Flash based video/movie streaming? I assume EP950 has Android dual boot. Android and Flash support are the selling points.

I hoped it has built-in WiFi...
yyy123 is offline  
post #7 of 1654 Old 12-23-2011, 01:54 PM
Member
 
wsxcde's Avatar
 
Join Date: Dec 2010
Posts: 40
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks for the tips. HiTV 2.0 is called Chinese IMS Online in the Premium Apps folder. I can't get wireless connection to work. I can't tell whether wi-fi is built-in or not. There is no external antenna. I am using wired LAN. I haven't tried the Android apps and browser yet.
wsxcde is offline  
post #8 of 1654 Old 12-23-2011, 04:51 PM
AVS Special Member
 
telemike's Avatar
 
Join Date: Sep 2004
Location: Greensboro NC
Posts: 1,155
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Any kind of yamj jukebox for this?
telemike is offline  
post #9 of 1654 Old 12-23-2011, 04:51 PM
Member
 
f1shtaco's Avatar
 
Join Date: Sep 2011
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
what's in the package?
HD900B:
- Himedia HD900B Networked Media Player w/ Build-in Wi-Fi
- Remote Controller
- Wi-Fi Antenna
- Serial ATA Cable
- HDMI Cable
- AV Cable
- Power Adapter

EP950
- EP950 Player
- IR Remote Control
- Serial ATA Cable
- 110-240V AC Adapter
- AV cables

There is no USB 3.0 cable(which I think is a must-have) with either one. The differences are the built-in Wifi and HDMI cable.
f1shtaco is offline  
post #10 of 1654 Old 12-23-2011, 05:24 PM - Thread Starter
AVS Special Member
 
GusGus748s's Avatar
 
Join Date: Mar 2009
Location: Visalia, CA 93291
Posts: 6,309
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
Liked: 592
Quote:
Originally Posted by telemike View Post

Any kind of yamj jukebox for this?

None yet. They are working on it with an unknown ETA.

Media Server: UnRaid Server: 15TB of storage and growing :).

http://www.avsforum.com/lists/display/view/id/8599

 

Home Theater Set Up:

http://www.avsforum.com/lists/display/view/id/8597

GusGus748s is online now  
post #11 of 1654 Old 12-24-2011, 09:12 AM
Member
 
f1shtaco's Avatar
 
Join Date: Sep 2011
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
hi Jack@micca
Can the EP950 play 3D movies that has two separate files for Left and Right?
f1shtaco is offline  
post #12 of 1654 Old 12-28-2011, 11:10 PM
Member
 
f1shtaco's Avatar
 
Join Date: Sep 2011
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
bug reports:
- "scan and fix" error just like the EP600
- EP950 reboots randomly when navigating in YouTube
- EP950 reboots when items are removed from the library. After reboot, nothing is changed in the library.
- when files are copied from the internal drive to an external usb drive the process
would complete 100% and playback normally from the external usb drive, but when
the external drive is connected to a PC (after being dismounted and removed from
the EP950) there is nothing there. Checking the drive properties, no disk space is
taken/used. It seems files were never copied in the first place. Both the internal and
external drives are NTFS GPT. Also tested with some USB flash drives with same results.
Copying files from an external USB drive to the internal drive works just fine.
f1shtaco is offline  
post #13 of 1654 Old 12-29-2011, 04:41 AM - Thread Starter
AVS Special Member
 
GusGus748s's Avatar
 
Join Date: Mar 2009
Location: Visalia, CA 93291
Posts: 6,309
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
Liked: 592
Quote:
Originally Posted by f1shtaco View Post

bug reports:
- "scan and fix" error just like the EP600
- EP950 reboots randomly when navigating in YouTube
- EP950 reboots when items are removed from the library. After reboot, nothing is changed in the library.
- when files are copied from the internal drive to an external usb drive the process
would complete 100% and playback normally from the external usb drive, but when
the external drive is connected to a PC (after being dismounted and removed from
the EP950) there is nothing there. Checking the drive properties, no disk space is
taken/used. It seems files were never copied in the first place. Both the internal and
external drives are NTFS GPT. Also tested with some USB flash drives with same results.
Copying files from an external USB drive to the internal drive works just fine.

I haven't bought my secondary media player yet. I'm trying to make the decision to either buy Popbox V8 or EP950.

Media Server: UnRaid Server: 15TB of storage and growing :).

http://www.avsforum.com/lists/display/view/id/8599

 

Home Theater Set Up:

http://www.avsforum.com/lists/display/view/id/8597

GusGus748s is online now  
post #14 of 1654 Old 12-29-2011, 07:10 AM
AVS Club Gold
 
Jack@Micca's Avatar
 
Join Date: Apr 2010
Posts: 614
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by f1shtaco View Post

hi Jack@micca
Can the EP950 play 3D movies that has two separate files for Left and Right?

Hi,

I do not think this is possible at the moment.

Jack@Micca
Micca Support Specialist
Jack@Micca is offline  
post #15 of 1654 Old 12-29-2011, 07:11 AM
AVS Club Gold
 
Jack@Micca's Avatar
 
Join Date: Apr 2010
Posts: 614
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by f1shtaco View Post

bug reports:
- "scan and fix" error just like the EP600
- EP950 reboots randomly when navigating in YouTube
- EP950 reboots when items are removed from the library. After reboot, nothing is changed in the library.
- when files are copied from the internal drive to an external usb drive the process
would complete 100% and playback normally from the external usb drive, but when
the external drive is connected to a PC (after being dismounted and removed from
the EP950) there is nothing there. Checking the drive properties, no disk space is
taken/used. It seems files were never copied in the first place. Both the internal and
external drives are NTFS GPT. Also tested with some USB flash drives with same results.
Copying files from an external USB drive to the internal drive works just fine.

Thanks for this information. I've forwarded it to the firmware team. Thanks!

Jack@Micca
Micca Support Specialist
Jack@Micca is offline  
post #16 of 1654 Old 12-30-2011, 09:23 AM
Newbie
 
rac2873's Avatar
 
Join Date: Feb 2011
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Will this player decode DTS Master and True HD and send it to the reciever as raw audio. My current is HDMI but it won't decode HD audio, it only accepts raw audio in PCM format.
rac2873 is offline  
post #17 of 1654 Old 12-30-2011, 11:58 AM
Newbie
 
rac2873's Avatar
 
Join Date: Feb 2011
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
R
rac2873 is offline  
post #18 of 1654 Old 12-31-2011, 06:25 AM
Advanced Member
 
steady teddy's Avatar
 
Join Date: Jun 2003
Location: Macomb, Michigan
Posts: 662
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 16
Does the EP950 have vTuner or a similar internet radio app?
steady teddy is offline  
post #19 of 1654 Old 12-31-2011, 07:34 PM
Senior Member
 
djc11369's Avatar
 
Join Date: Jan 2009
Location: Upstate NY
Posts: 462
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 20
I see that there is an announcement on the Futeko forum that a custom firmware will be available after the new year that provides YAMJ working on the 900B (appears to be identical to the 950 except wifi).

Jack, not that Micca supports this but if an alternate firmware were flashed to the player can it be easily flashed back to the Micca firmware or would it brick it? I see other players are easily flashed back so I'm guessing it's the same?

Since the current firmware isn't yet available on the Micca website I probably wouldn't attempt it yet so if it went wrong it could be flashed back.
djc11369 is offline  
post #20 of 1654 Old 01-02-2012, 11:13 PM
AVS Special Member
 
Richard Adams's Avatar
 
Join Date: Nov 1999
Location: Northern California
Posts: 2,460
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Jack@Micca

Hello,

Please forward this problem to technical support that makes firmware updates for the Micca EP950, thank you.

Problem: No 3D from Sony HDR-TD10 3D camcorder when file is played on Micca EP950

Discussion:
My Sony HDR-TD10 3D camcorder files play okay in 3D on a PC. They also play okay when burned to a bluray disk using the Sony PMB software version 5.8, and then play the disk on the Sony Bluray player model BDP-S480.

These files have the newest frame packed 3D MVC files at 1080i60-3D which is per the AVCHD 2.0 spec from 2011.

The problem is that when this file is played on the Micca EP950, there is no 3D. The file plays in 2D.

This is terrible for a new generation 3D player.

To help your technical support duplicate and test the problem and improve your firmware, I made a small 3D file to test with from the Sony camcorder. This clip is 100mb MVC M2TS and shows 3D depth and gimmick 3D poke out of screen, and has audio 5.1 AC3 English.

Here is the link for fast download to the sample.

http://st7.us/mvc-sample0011.mts

Thank you.

"With Liberty, HDTV and Justice for all."
Richard Adams
Richard Adams is offline  
post #21 of 1654 Old 01-03-2012, 07:18 AM
AVS Club Gold
 
Jack@Micca's Avatar
 
Join Date: Apr 2010
Posts: 614
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by djc11369 View Post

I see that there is an announcement on the Futeko forum that a custom firmware will be available after the new year that provides YAMJ working on the 900B (appears to be identical to the 950 except wifi).

Jack, not that Micca supports this but if an alternate firmware were flashed to the player can it be easily flashed back to the Micca firmware or would it brick it? I see other players are easily flashed back so I'm guessing it's the same?

Since the current firmware isn't yet available on the Micca website I probably wouldn't attempt it yet so if it went wrong it could be flashed back.

Hi,

Feel free to experiment with HiMedia firmware, or other custom firmware. Just be careful not to do anything that would change the original boot code. The boot code is what displays the initial white "Micca" logo on the screen when you first turn the player on. While this is not officially supported, we recognize that there is a significant community interest in cross flashing firmware. As long as the original boot code is intact, you will always be able to restore the firmware back to the ones we supply.

We will be posting the EP950 firmware on our website soon.

Jack@Micca
Micca Support Specialist
Jack@Micca is offline  
post #22 of 1654 Old 01-03-2012, 07:20 AM
AVS Club Gold
 
Jack@Micca's Avatar
 
Join Date: Apr 2010
Posts: 614
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by Richard Adams View Post

Jack@Micca

Hello,

Please forward this problem to technical support that makes firmware updates for the Micca EP950, thank you.

Thanks so much, I will forward this.

Jack@Micca
Micca Support Specialist
Jack@Micca is offline  
post #23 of 1654 Old 01-03-2012, 07:21 AM
AVS Club Gold
 
Jack@Micca's Avatar
 
Join Date: Apr 2010
Posts: 614
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by steady teddy View Post

Does the EP950 have vTuner or a similar internet radio app?

Hi,

The EP950 has a Shoutcast internet radio app that can access the stations under that service.

Jack@Micca
Micca Support Specialist
Jack@Micca is offline  
post #24 of 1654 Old 01-04-2012, 10:12 AM
Newbie
 
dbtebb's Avatar
 
Join Date: Jan 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi jack,
I just got the 950 and the media library crashed and reported "db crashed, please rebuild from setup men" I have checked out the setup menu and see no options. Files will still play when accessed from hard drive but the media library function is broken. I have a 1.5 tb internal hdd installed. I have tried returning the unit to factory settings with no luck.
dbtebb is offline  
post #25 of 1654 Old 01-04-2012, 10:39 AM
AVS Club Gold
 
Jack@Micca's Avatar
 
Join Date: Apr 2010
Posts: 614
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Connect the player to a computer so that the internal hard drive mounts as a drive on the computer. Delete the files and folders that the player has created to store its database.

Then go into the settings menu on the EP950 and clear the library database from there.

After that, you can rebuild the database by doing another scan.

Jack@Micca
Micca Support Specialist
Jack@Micca is offline  
post #26 of 1654 Old 01-05-2012, 09:09 AM
AVS Special Member
 
Richard Adams's Avatar
 
Join Date: Nov 1999
Location: Northern California
Posts: 2,460
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Jack@Micca View Post

Hi,

Feel free to experiment with HiMedia firmware, or other custom firmware. Just be careful not to do anything that would change the original boot code. The boot code is what displays the initial white "Micca" logo on the screen when you first turn the player on. While this is not officially supported, we recognize that there is a significant community interest in cross flashing firmware. As long as the original boot code is intact, you will always be able to restore the firmware back to the ones we supply.

We will be posting the EP950 firmware on our website soon.

How does one ensure that the original boot code remains intact while cross flashing?

"With Liberty, HDTV and Justice for all."
Richard Adams
Richard Adams is offline  
post #27 of 1654 Old 01-05-2012, 07:22 PM
Newbie
 
chkfried's Avatar
 
Join Date: Jun 2006
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Can anyone help with setting up the EP950 with Windows 7? I've started the Samba process on the EP950 settings and enabled media sharing on W7. Should I be able to see the EP950 from "view network computers and devices" or do I need install a Samba client on W7? Or, enter "\\\\EP950\\" from Start -> Run?

Any insight would be appreciated.
chkfried is offline  
post #28 of 1654 Old 01-06-2012, 10:32 AM
AVS Club Gold
 
Jack@Micca's Avatar
 
Join Date: Apr 2010
Posts: 614
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by Richard Adams View Post

How does one ensure that the original boot code remains intact while cross flashing?

There are extra files/steps needed to flash the boot code, so as long as you are just flashing the firmware itself, the boot code will be intact. So there is nothing to worry about for most people.

Jack@Micca
Micca Support Specialist
Jack@Micca is offline  
post #29 of 1654 Old 01-06-2012, 10:33 AM
AVS Club Gold
 
Jack@Micca's Avatar
 
Join Date: Apr 2010
Posts: 614
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by chkfried View Post

Can anyone help with setting up the EP950 with Windows 7? I've started the Samba process on the EP950 settings and enabled media sharing on W7. Should I be able to see the EP950 from "view network computers and devices" or do I need install a Samba client on W7? Or, enter "\\\\EP950\\" from Start -> Run?

Any insight would be appreciated.

Once you turn on SAMBA file sharing and have a drive installed/attached to the EP950, it should show up on your network. In Windows 7, it should show up when you click on Network in file manager.

Jack@Micca
Micca Support Specialist
Jack@Micca is offline  
post #30 of 1654 Old 01-06-2012, 04:29 PM
Senior Member
 
DraZtiK's Avatar
 
Join Date: Jun 2005
Posts: 277
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 15
wasn't the price on this 149?
DraZtiK is offline  
Reply Networking, Media Servers & Content Streaming

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off