Micca MPlay-HD only worked about 12 times - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 08-28-2012, 11:46 AM - Thread Starter
Member
 
manning99's Avatar
 
Join Date: May 2012
Location: Indiana
Posts: 84
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Liked: 10
I bought the mplay-hd two months ago and have only been able to watch 10-12 movies in that time. A few days ago I went to turn it on and all it showed on the screen was "please wait...". This went on for quite a while, so after moving on to something else I came back a few hours later and it still said "please wait...". Has anyone ever seen that? It won't let me go to the menu or even turn it off. After a few hours I had to unplug it to turn it off. That didn't help. I tried everything I could think of before emailing Micca tech support. I now have a new rule for purchases, nothing from any company who doesn't publish a phone number, ever.

Tech support emailed back Sunday evening, asking for more information. I sent the information and they responded that I need to re-flash the firmware and provided the link to the instructions and download. But in order to do that I'd have to be able to navigate through the menu, which I can't do. So I wrote back first thing Monday morning sharing this little tidbit. Since then tech support has gone dark, no response. I also sent jack@micca a pm saturday but haven't heard from him yet. Family members have now ordered three of these after seeing mine and one friend has done the same. I now feel bad knowing there's a good chance they won't last long and won't get timely support (if any, still tbd), so I have recommended that they send them back before Amazon's 30 day return period expires.

If anyone has any advice on how to fix this I would love to hear it. If not, I would love a recommendation for a replacement. What I liked about the mplay was the fact that it can display cover art rather than just a listing of all movies. So I need to find a replacement that will do the same. I don't care about streaming. And the manufacturer must have a phone, and preferably have someone answering that phone at least 5 days a week.
manning99 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 08-29-2012, 05:57 AM - Thread Starter
Member
 
manning99's Avatar
 
Join Date: May 2012
Location: Indiana
Posts: 84
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Liked: 10
Nevermind, I found the recovery re-flash instructions. I wish they had sent those instructions the first time.
manning99 is offline  
Reply Networking, Media Servers & Content Streaming

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off