How to SSH to my freenas? - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
Thread Tools
post #1 of 3 Old 11-05-2013, 11:42 PM - Thread Starter
keytachi626's Avatar
Join Date: Nov 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

So currently I am running a freenas on my laptop for now just to mess around with it and get familiar with it before I go and buy and setup a system for myself. I currently have plex up and running with it. Now the problem is I wanted to do SSH to my freenas from my phone for now as it is the only thing with another wireless wifi (3g/lte). I have enable the service SSH/FTP and Dynamic DNS on the freenas and I also register for a DNS with I have my SSH port to 22 and port forward it already on my router.


The problem is when I go into a SSH app on my phone and enter the DNS to it, it usually say can not connect to [DNSHostname]/@ I usually get this error when I am doing it on my lte. The username on the SSH I am using is root and for the password I put my password that is for the login on freenas.

keytachi626 is offline  
Sponsored Links
post #2 of 3 Old 11-08-2013, 12:51 PM
BlacMagik's Avatar
Join Date: Jan 2013
Location: Apopka, FL
Posts: 89
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 14
What app are you using on your phone? Do you have to append the port # (x.x.x.x:22 or to it? Are you running FreeNAS natively on the laptop or virtual? if Virtual, what about the software firewall on the host OS? Can you ping your DDNS name from outside your home network?

After re-reading your post, you've enabled SSH/FTP, but have you enabled the root account to login remotely via SSH? and you really don't want to allow the root account SSH all. Create another account and give that account SSH/Shell access.
BlacMagik is offline  
post #3 of 3 Old 11-11-2013, 12:12 PM
jimbo75's Avatar
Join Date: Mar 2005
Posts: 119
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Liked: 16
If you have Android, JuiceSSH is a good app.

Can you SSH from inside the house? You should make sure that is working before trying from the outside.

From the outside, you'll setup your app to connect to and then supply your login/pwd. (probably using "admin" for the login account?)

Make sure you have a strong password.

I'd also recommend using port translation on your router if it's supported. Port 22 will be scanned by all of the hackers out there. Changing the port to 10022 would be better. (just make sure you use that port in your SSH app then)
jimbo75 is offline  
Sponsored Links
Reply Networking, Media Servers & Content Streaming

Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off