Roku XS Problems - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!


Forum Jump: 
 
Thread Tools
Old 08-30-2014, 01:26 PM - Thread Starter
Member
 
kpr711's Avatar
 
Join Date: Mar 2004
Location: chicago
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Roku XS Problems

I have a rokus XS, connected via Ethernet (switch to router xfinity)
Recently the connection speed a dramatically dropped off. It does not appear to be the ethernet or network, I can disconnect the ethernet from the roku and connect to Xbox one, I get 28-30 mbs. But on the roku is is dreadfully slow.

Tried trouble shooting with Roku, no avail. Everything points to the Roku. About three months ago I had a lighting strike that blew my av receiver. Could that have caused the issue with the Roku.
Just to be clear, the Roku works, just verrrry sloooooowly.
Thank you all in advance.
kpr711 is offline  
Sponsored Links
Advertisement
 
Old 08-30-2014, 01:37 PM
Advanced Member
 
bac522's Avatar
 
Join Date: Jan 2003
Posts: 970
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 71 Post(s)
Liked: 71
Quote:
Originally Posted by kpr711 View Post
About three months ago I had a lighting strike that blew my av receiver. Could that have caused the issue with the Roku.
Most likely the problem...only thing I would suggest is doing a factory reset on the box and see if that clears it up.
bac522 is offline  
Old 08-30-2014, 02:39 PM - Thread Starter
Member
 
kpr711's Avatar
 
Join Date: Mar 2004
Location: chicago
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Quote:
Originally Posted by bac522 View Post
Most likely the problem...only thing I would suggest is doing a factory reset on the box and see if that clears it up.
Nope, that did not work
kpr711 is offline  
Old 08-31-2014, 05:17 AM
Advanced Member
 
bac522's Avatar
 
Join Date: Jan 2003
Posts: 970
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 71 Post(s)
Liked: 71
Bummer, my guess (and you probably suspect) is that the unit is slowly "giving up the ghost". Only other thing I can suggest is posting this problem on the Roku forum and see if any of the guru's over there can help.
bac522 is offline  
Sponsored Links
Advertisement
 
 
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off