AVS Forum

AVS Forum (http://www.avsforum.com/forum/)
-   Networking, Media Servers & Content Streaming (http://www.avsforum.com/forum/39-networking-media-servers-content-streaming/)
-   -   Iamm NTD36HD by Novatron (http://www.avsforum.com/forum/39-networking-media-servers-content-streaming/763110-iamm-ntd36hd-novatron.html)

Konsti 12-05-2006 06:55 AM

Hello to all European AVSForum members,

I recently purchased from eBay Germany the excellent HD media player by the Korean company "Novatron" called IAMM NTD36HD or IAMM NTD-36 HD and would like to start this thread on issues that you faced and resolved, including comments related to this player *only*.

It appears that a player with similar looks and specifications has hit the US market under the name Eureka LX350HD and some US sites mention also the presence of Ximeta's NDAS support, it seems.

So it would be interesting to hear from european owners of the IAMM as well as any american friend who alread owns the Eureka player.

Your input is welcome!
Konsti

Konsti 12-05-2006 08:20 AM

Latest firmware, as of 28th March 2007:

Version 1.1.152

English manual (~15 MBytes)

Manufacturer's specifications

Ximeta's NDAS driver (Iamm acts as their "NetDisk" product)

artcat 12-05-2006 10:35 AM

you can find the french version off the lx 350hd in this site: rivertech.fr
as you can see we can find this product in different marks...
visit this site: hdd-player.de/phpBB2/viewtopic.php?t=223 for all the firmwares and softwares...
i upgrade my mediaplayer to the 1.1.140 version but i have the same bugs ( when i press the remote buttons MOVIE, MUSIC, PHOTO) they link me to the root of the HDD instead of the directories, have you encountered this bug???

Konsti 12-06-2006 01:10 AM

Hello artcat,

I was under the impression that these menu selections were not meant to point to directories, but simply do a file filtering. That is, if you press e.g. MUSIC, and browse the drive, AVI or MPG etc. files will not be displayed.

I checked the manual and you seem to be right: on page 17, they suggest we do that. I will try this tonight; never really gave any shot because I am mostly using it to browse the network for videos.

artcat 12-06-2006 10:06 AM

Hello konsti,
another problem is the streaming function , when i browse the network sometimes the mediaplayer can see shared folders and the workstations and sometimes it can't see anything
any idea...
concerning the NDAS have you got any solution, cause it can be very useful for downloading the files to the hdd instead of travelling the mediaplayer to the nearest workstation and plugin via the usb wire...

Konsti 12-07-2006 07:07 AM

Hello again,

1. Indeed, proper network discovery can take more than a few seconds. What I do is I select again REFRESH on the menu, and I see both shared drives of mine (they are network drives, like Western Digital's "NetCenter"--I am expecting the Synology DS-106e soon, will write more). This is the same with WIRED or WIRELESS connection. It just takes its time

2. Regarding the NDAS feature: I have installed the driver that came with the CD-ROM, it is the same version as the one found on Ximeta's website (http://www.ximeta.com/) and I was able to "mount" the HDD of the Iamm as a USB device on My Computer. You need to enter the "device-key(s)" (specific for your hardware MAC addresses, found at the bottom of the device) and then the "write-key" in order to connect and transfer data over the network. Did you already try this?

Speed was not something I was ecstatic about, but I guess the 5-port 10/100 D-Link switch I am using is not of great quality... I must check this with a friend's switch (not hub, though) and perhaps a direct, cross-linked ethernet cable (between PC and IAMM) for 100% speed testing!

The drivers can be found here.

Let me know if you need further help.

Konsti 12-08-2006 04:16 AM

I am posting three images from the menus of the Iamm and the latest firmware. These are captures using an LCD Bravia 40 inch set, a tripod and my faithful DSC-717 camera, to be used in an article I am writing for a Greek magazine. The Iamm is connected via component at 720p.

...Just to give a feel to people that consider buying the Iamm!
LL
LL
LL

artcat 12-08-2006 08:31 AM

congratulation for your pictures,
my mediaplayer is exactly the same as yours but from another korean reseller RIVERTECH, but i 'haven't got the NDAS feature, so i upgrade with the novatron firmware revision 1.1.140 and i installed the ndas software, but i need the device id and the write key...
the problem is that the trademark RIVERTECH has no technical support in France, so where i can find this keys...

Konsti 12-11-2006 01:01 AM

So you say you've upgraded your Rivertech to the IAMM firmware and it worked? Amazing. But how are you sure that the NDAS functionality is there? There is no mention on the menu screens. Can you still browse the network?

In order to check if you do have NDAS in your box, you need the device ID and write key. These are related to the MAC address of your device, and usually given by the manufacturer as a "sticker" at the bottom of the device. Mine were there, at least (one for WIRED and one for WIRELESS).

Where did you buy yours? PixMania? What is the exact model number? Do you have WiFi connectivity?

FIRMWARE UPDATE: The IAMM site posted the new firmware, version 1.1.142

It's a shame no-one else seems to bother posting his/her reviews and comments on the IAMM

Konsti 12-12-2006 08:08 AM

I should have known, but I think it's true: the NDAS feature on the Iamm is software-based. I was considering buying the RAPSODY N35 prior to discovering the Iamm, and the N35 features hardware NDAS support, making it even faster.

I thought that the network behaviour of the IAMM was slow, but now it explains it. Moving files TO the Iamm takes quite some time; 3000 KB/sec (maximum achieved) on a 100Mbit network... and I thought it was my ethernet switch!

phil42a 12-22-2006 02:43 PM

Hi,

I just got the same device under the brand Cibox. NDAS functionality is supported and I have already mounted the disk as a remote wireless device on two different machines. Same problems as for some of you :
- Takes some time to detect remote PC shared resources (but finds them in the end)
- Rather low information throughput over 54g (max 5MB/s) sufficient for streaming divx and midres Mpgs in both direction
- Haven't checked the wired connection so far, but from what I read above, looks like a better transmit rate is not to be expected.
I connected My Cibox to my 32" Sharp LCD using a DVI HDMI cable in auto DVI mode (current mode is 1080i), pictures are really brilliant and sharp ! a real pleasure to watch my DVD collection.
- One disappointment concerning still picture display : they rather look blurr with step effects when resolution is above 2Mpix. Did any one check this functionallity using other display modes (720p Yuv, 1366x768 VGA....)

clasami 12-23-2006 07:46 AM

Just consider for a moment if Novatron had decided to implement Upnp so that the IAMM could connect to Twonkymedia and do internet radio, collect video and audio files sorted by genre and other categories. Instead, they embarked on an NDAS project that really is not of any use at the speed that a software solution provides. Unfortunately, the manufacturer (Novatron) is not listening to customers at all, does not even reply to inquiries. That, of course, also means that a better scaler for JPEGs will probably never be introduced, leaving us with a rather pricy toy that plays videos well but really does not live up to expectations otherwise.

Happy Holidays,

Michael

Konsti 12-27-2006 04:55 AM

Hello clasami, phil42a, SEASON GREETINGS!

You are both right. Regarding the IAMM network capabilities, the NDAS feature is just OK for basic needs, and the uPNP could had come in handy. I am facing a problem with the Synology DS-106e file server (NAS) and the IAMM refuses to see the shared folders contents.

I noticed (via the wireless AP) that the IAMM obtains an IP address, but provides no network/workgroup device name! This renders it INVISIBLE on the network, and you can only PING it or connect via NDAS. So my investment on the (supposedly) best NAS server, is a waste. I can't see any files.

And indeed, NOVATRON just ignores my comments, for a third time I wrote an e-mail. I guess if they actually receive those e-mails or if they go to some spam mailbox ;-)

Did anyone else try to setup a file server, except their computer?

And yes, my IAMM is connected via component to my 40" Bravia LCD at 720p and the photos are BLURRY. Amazingly mediocre scaler (software, too).

Konsti

clasami 12-27-2006 12:53 PM

For some reason, the IAMM has no problem to see my NSLU2 NAS with the attached USB drives (5 total). Works like a charm.

Michael

phil42a 12-30-2006 04:19 AM

Season greetings to you all !

I upgraded my Cibox to the latest firmware avalaible on the novatron site (1.1.142). The Cibox logo on the welcome screen is now replaced by novatron (of course...Hope I will not experience problem with the unit, Cibox after sales might not appreciate... ).
Apart from this I can now read original DVD title from an attached USB DVD drive (good feature since I no longer need my previous DVD player which I now intend to sell).
Surprisingly the Wireless throughput seems to be a bit higher (not that much though) I can now expect to downlod a Complete DVD rip in about 3 hours with this firmware revision (the original CIBOX was 1.1.131).

Konsti 01-09-2007 02:46 AM

Guys, some info on using the IAMM with the Synology DS-106e server.

The IAMM can access open/public folders on my MacOS X and Windows as GUEST, i.e. no read restrictions.

However, the latest firmware for the Synology DS-106e that came with the server (namely, version 2.0.1-3.0368 dated 2006/06/29) does not allow the IAMM to access public folders, despite the fact that they are accessed as GUEST for username.

The problem is that the IAMM does not have a network name, and apparently, the Synology NAS doesn't like it (so far).

I sent an e-mail to the guys at Synology and they allowed me to participate in a beta firmware programme. The beta firmware (version 2.01-3.0424) still doesn't solve this problem...

Will post more as I go.

krinderb 01-14-2007 05:41 AM

antivirus,

Sorry if this is a stupid question. what is the full entcrypted firmware and why would i need it.

K

krinderb 01-14-2007 10:10 AM

Great work!

krinderb 01-14-2007 10:28 AM

Hi,

i have a problem with my ntd36hd and was hoping some one could tell me,or tell me why i am getting the problem.

Basically the problem is that i have a 500gb HD in my ntd36hd and whenever i start the ntd36hd the HD is not picked up the HD icon is not active, but if i re-start the ntd36hd right away the HD is picked up and works fine.

I'm thinking that the the ntd36hd boots up and checks for the HD before the HD is ready. i'm probly wrong but it would be interesting to know if anyone else has had this problem or knows why it is occurring

krinderb 01-14-2007 03:12 PM

its set as master i've double and tripple checked i've also tried setting as single device... same problem with both settings

Konsti 01-15-2007 12:25 AM

Good day to all the NTD36-HD fans!

1. I have good news: the Synology DS-106e file server now works perfectly with the IAMM NTD36-HD since they released the new firmware for the DS-160e version 2.0.1-3.0426. Ethernet connections work as expected and shared folders with GUEST permissions now work! Just press REFRESH once more if you don't immediately see the file server (its HDD must be put out of sleep, so a list REFRESH on the IAMM is necessary some times).

I did contact Synology about this, and they told me that the new firmware has improved AFP connection. Indeed, the IAMM does not have a network device name (it's hidden in Network Neighborhood) and previously the Synology did not allow the IAMM to login properly... even as GUEST.

2. I am losing faith in Novatron. They never replied to any of my e-mails. What I liked about DViCO (the TViX products) is that they did reply, even in broken english. Keep pushing the Novatron guys, perhaps they will understand they need to improve their darn customer service.

3. Hey, antivirus good work with the firmware. Although I struggled a little with your english (LOL!) we thank you for your work.

(a) So you actually could OPEN the binary firmware? Could you detect the location of the bitmap fonts for the subtitles? Does that mean we can introduce GREEK (non-latin) bitmaps for the subtitles, too, like in the MTK-chip-based DVD players? (see MTZ firmware site to see what I mean)

(b) how sure can we be that your firmware is properly re-packed after your changes? I do not doubt your skills or your firmware, by any chance, just a security question. Because if by any change my IAMM dies, I am screwed There's no-one to fix it here, in Greece!

Well done.
Konsti

Konsti 01-15-2007 01:42 AM

Antivirus, hello again!

I am not a linux programmer, and I try to understand your hacking steps, so bear with me.

Thank you for the trouble you're getting into. But for the sake of not scaring people, and to use your firmware, let's do it step-by-step and document the changes, because writing the programming steps can be confusing. So:

1. you opened/decrypted the OFFICIAL firmware v1.1.142 with CLinux tools. Correct?

2. you modified the code in order to clear the playlist and jukebox list, correct? Please state what file you've patched/copied/edited/deleted and what line.

3. you added TelnetD service, by modifying the code and you start this service. What file was modified, line number? Also, you added hard-coded username and password, correct?

4. How did you upgrade your player? Via the standard upgrade process, i.e. on the SETUP menu of the player? You mention tFTP, you mean TelnetFTP process?

5. You say "Set JUKEBOX.list and MYVIDEO.list to prevent lookups... not very nice,
but hey the box starts". What do you mean "not very nice", you mean the code that Novatron did or the method YOU are using?

Thanks again, let's do a comprehensive plan to fix few bugs at a time.

Shame I don't know CLinux to help you ;-)
Konsti

Konsti 01-15-2007 04:57 AM

1 Attachment(s)
Antivirus, you are one crazy German alright (maybe Austrian?)
OK, please one-by-one because I am lost again.
Please, don't post so big lines of code, better attach a file in your post.

1. Which firmware did you open/decrypt? I read in /etc/firmware_version that's 1.1.141 and not 1.1.142 that is published on the NOVATRON site. Please confirm.

2. You have a file called anti.zip available in your website. You contain both the original and fixed firmware code? Hmm... on second thought, no, just the opened binaries, not the original code.

3. Let's make a deal--you document which changes you make (file name, code change if small) or put comments in the change // or # and I will try to work for you!

I have noticed that the background images, although "stolen" from MacOS X, they appear 'broken' when displayed at 720p (jagged edges). If I give you the same images but in better resolution, do you think they will work natively? Check this zip file: I changed the backgrounds from blue to green (to denote patched firmware) and resized them to 1280x720 pixels. A final BG can be discussed... this is just for testing.

Subtitle bitmaps--that's another crazy story. How are we going to produce bitmap fonts compatible for this ucLinux firmware? What tools do you have to convert TTF to bitmaps?

You're unlucky since I am not too busy at the office, today!!!

Thanks
Konsti

 

IAMM_BGs.zip 80.841796875k . file

phew 01-15-2007 09:11 AM

Hi Antivirus,

Nice work

Like Konsti, I'm not a linux programmer either but I played a little with the firmware, managing to decompress it and get it mounted in a version of Linux running on my XP box allowing me to at least view it.

I also opened up the rompkg & the curacoa executables in a disassembler with the following:
ARM (little endian)
Load Offset: 0x00
File offset: 0x40

With the above settings the text offsets appear to be in the correct positions.
i.e. in the rompkg executable:
000007F4 84 6E 09 00 off_7F4 DCD aFlash_write ; "flash_write"
000007F8 90 6E 09 00 off_7F8 DCD aFlash_update ; "flash_update"
000007FC A0 6E 09 00 off_7FC DCD aIwconfig ; "iwconfig"

I'm not sure if there would be anything useful that could be modified in either of these programs that would be of any use though!

...later,
phew.

Konsti 01-16-2007 12:34 AM

Antivirus, Phew, you seem to know more than I do, for sure!

I know about programming but not under the Linux environment.

I would like just to keep notes of stuff changed, and make sure the code is minimally changed. Again, personally, I cannot afford to lose my box due to bad "flashing" or firmware, I just bought the thing via eBay and the guy won't support me, I know that....

Can we start by having a nice, even small text of how to upload the firmware via tFTP? Perhaps in the change log, in the beginning, a small paragraph.

I can provide you with more graphical use than programming; if there's anything I can do, let me know, as long as my office work allows it

Konsti 01-16-2007 12:39 AM

Wait a minute--I have the official firmware. There's no telnet or FTP open and running, is there? So how to upload and flash the IAMM with official firmware to the patched firmware? Did I miss something?

Also, antivirus, you crazy programmer, please when you open v1.1.142, please check whether your changes have already been implemented...

And if you know of a tool to convert TTF (e.g. Arial or Tahoma) to bitmap fonts to be used in this ucLinux thingie, let me know....

Danke schoen!

Konsti 01-16-2007 02:39 AM

Please fix your link or remove the spaces (put underscores instead):
h**p://amd.co.at/anti/hd-player/ilam%20ntg36hd/INTERN_LOADER_ROMFS_BIN_TFTP/PATCHED_FIRMWARE/Patching%20the%20Iamm%20-%20How%20to.doc

phew 01-16-2007 06:47 AM

Antivirus,

Given size restrictions of 8meg to hold the OS; would it be possible to use a memory stick inserted into one of the USB sockets that would hold a modified version of the OS?

So that:
When you boot the unit inbuilt OS partly loads

It then tests for an OS on the USB memory stick

If it finds one
...it boots from the memory stick
if it does not find one
...it does a normal boot from the inbuilt OS.

I seem to remember that the guys that altered the Linksys NSLU2 done something similar.

...later,
phew.

krinderb 01-16-2007 10:12 AM

Good idea phew but you on a usb stick why not simply have a folder on the root of the internal drive?

Konsti 01-17-2007 12:10 AM

My guess is that although the USB stick is a better place to write a 'test' firmware, and I prefer it, it may be difficult to implement. Perhaps as krinderb says, it's easier to have a subfolder on the HDD1 since it's already been used for booting up...

We will then need to just have a folder like \\firmare\\ to place updates and tested code.

I don't know at what point of the booting process the USB host is being detected and scanned for devices...


All times are GMT -7. The time now is 02:29 PM.

Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.