HiPix 2.3beta new playback bug - AVS Forum
Forum Jump: 
 
Thread Tools
Old 06-07-2001, 09:12 PM - Thread Starter
PVR
 
PVR's Avatar
 
Join Date: Jun 2001
Posts: 3,761
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I noticed that one of my stored video sequences would crash my
system everytime I play it ever since I upgraded to HiPix software version 2.3beta.

This same sequence would play fine under earlier versions of the HiPix software.

I got a strong confirmation today when I called my friend (who has the same
sequence on his hard disk) and asked him to try it. He still had 2.2beta software
and was able to play the file fine. I then asked him to upgrade to 2.3beta version
and try again... Now it crashes his computer too.

I am running Windows 98SE and he is running Windows 2000 and our hardware
specs are very different, so I don't think it is specific to one installation.
I also tried it on another machine with WinME and it also crashed.

I have played many other files with no problems - it is just this one sequence which
seems to trigger a bug of some sort.

PVR is offline  
Sponsored Links
Advertisement
 
Old 06-07-2001, 09:56 PM
AVS Special Member
 
bpearse's Avatar
 
Join Date: Apr 2000
Location: Saratoga, Ca
Posts: 1,208
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
PVR,

Can you save a copy of the segment that crashes your system, and contact John Kim at Telemann? His email is johnkim@telemann.com. He heads up the development team on the HiPix. He will want to probably get a copy of the segment (perhaps on CD?).

I personally have NEVER had any video material crash my HiPix. And I have been a VERY heavy user since the start. This is very interesting.

Bob
bpearse is offline  
Old 06-07-2001, 10:30 PM - Thread Starter
PVR
 
PVR's Avatar
 
Join Date: Jun 2001
Posts: 3,761
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Yeah I emailed John Kim already and I will be sure to keep the segment.

PVR is offline  
Old 06-08-2001, 12:48 AM
AVS Special Member
 
gridleak's Avatar
 
Join Date: Mar 2001
Location: Newport Beach, CA, USA
Posts: 1,219
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I've NEVER had a video sequence crash my HD1000.

Sorry, I couldn't resist.http://www.avsforum.com/ubb/smile.gif

------------------
- gridleak... biased toward HD

-Roger
gridleak is offline  
Old 06-09-2001, 07:17 PM - Thread Starter
PVR
 
PVR's Avatar
 
Join Date: Jun 2001
Posts: 3,761
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I got a response from Telemann:
=========
The problem you have was solved after releasing 2.3b.
The problem was on the parsing the file index in driver code.
You can play your file with renaming the index from filename.ts.0131 ~ 0134 to filename.ts.0000 ~ 0003.

Thanks for your reporting.
=========

Sure enough - renaming the files as they said fixed the problem.
PVR is offline  
Old 06-11-2001, 12:31 PM - Thread Starter
PVR
 
PVR's Avatar
 
Join Date: Jun 2001
Posts: 3,761
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Additional response:

=========================================================
And the rule of searching for indexed file is describled below.

- V2.3b
1. Searching from xxx.0000 by one by one.
2. Stop searching for next index file if the fail count of opening next index file is over 101.

So in the case of V2.3b, if the file index start over the 101 then stop searching for next file.
That was my mistake and I fixed the first step as below.

1. Searching from xxx.0000 by one by one until the first valid file is detected.

And the purpose of skipping non-existing file is for customer to delete commercial file.

Thanks for your attention.

Steve Lee
=========================================================

So basically the new feature that lets you delete individual minute files and have HiPix skip right over them has a bug when playing files over ts.0100+

So with 2.3b don't make gaps in your .ts files over .ts.0100


PVR is offline  
 
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off