Help needed! Connect Amp to Subwoofer. - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 1 Old 07-29-2014, 11:35 PM - Thread Starter
Newbie
 
derekseto's Avatar
 
Join Date: Feb 2006
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Help needed! Connect Amp to Subwoofer.

Hi everyone,

First off, thanks in advance. I'm an absolutely noob to audio connections, so please bare with me.

I'm struggling to connect an amp unit from an old Denon UDRA-90 mini system to a KEF HKT1005 amp. Since there's no "line out" on the Denon, I am not sure how I can connect the two. Do I use the OUT from "Processor Loop" and connect the red/white couples to the subwoofer's in? However, I would have no source to loop back in? Is that ok? (Please see pictures below)

The speaker connectors are for the 2 front speakers, which have cracked and damaged "surrounds" and not worth repairing. So I'm using 2 fronts from my KHT 1005.1 system. However, since those are only tweeters, I need to connect the sub for bass.

Your comments and help is much appreciated,
Derek
Attached Thumbnails
Click image for larger version

Name:	denon-stereo-receiver-udra-90.jpg
Views:	13
Size:	54.1 KB
ID:	187226   Click image for larger version

Name:	sub.jpg
Views:	7
Size:	37.2 KB
ID:	187234  
derekseto is offline  
Reply Post Testing Area

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off