Phillips 60" rear-projection HDTV problem - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 12 Old 10-24-2008, 03:26 PM - Thread Starter
Member
 
theonlywizdum's Avatar
 
Join Date: Oct 2008
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I recently picked up an older 60" Phillips rear-projection TV for cheap. I do not have the model number because the previous owner lost the entire back panel (no idea how, if there is another place to find the model number, let me know) I'm guessing it's an older generation since it doesn't have HDMI or DVI connectors (only component), and it doesn't have a "Magic Focus" like feature that automatically sets the convergence. It does have a manual convergence option in the menu though.

After trying to align the crosses on the red manual, multi-point convergence menu I ran into a problem. Some of the horizontal red lines near the top and bottom are slanted very badly, and I can't adjust some of them in the up and down directions (left/right still works).

Am I doing something wrong, or is there a more serious hardware problem?

I uploaded some pictures here:

*edit I have uploaded some pictures but I can't post a link since i don't have 3 posts yet.
theonlywizdum is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 10-24-2008, 06:34 PM
AVS Special Member
 
vili's Avatar
 
Join Date: Jan 2007
Location: Martin, TN
Posts: 1,573
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have a 60" Philips...TV model 60pp9202 I got from Sams approximately 3 1/2 years ago. Couple of months ago my convergence ICs went bad and had to be replaced. Don't know for sure if this is your problem as I would need to see pics of your set, but it very well could be. Whenever you are watching TV does the image seem to split into different color images...ie a blue picture a green picture and a red picture?
vili is offline  
post #3 of 12 Old 10-24-2008, 06:46 PM - Thread Starter
Member
 
theonlywizdum's Avatar
 
Join Date: Oct 2008
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thats how it was when I got it (used) the 3 colors could be seen seperated. I was able to correct it with the manual convergence menu, but some of the crosses couldn't be moved up or down to re-align them. certain areas are still off. Where are the ICs located generally? How many are there?
theonlywizdum is offline  
post #4 of 12 Old 10-24-2008, 06:50 PM
AVS Special Member
 
vili's Avatar
 
Join Date: Jan 2007
Location: Martin, TN
Posts: 1,573
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
If you know what a heatsink is they are located on one side of them. There are generally 2 convergence ICs. They are black and look like they are glued to the heatsink (its actually thermal grease). Do you know where he bought the set?
vili is offline  
post #5 of 12 Old 10-24-2008, 07:10 PM - Thread Starter
Member
 
theonlywizdum's Avatar
 
Join Date: Oct 2008
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have absolutely no idea where the original owners got the TV. I looked in the back and theres a lot of heatsinks in there of varying sizes. The Largest one looks like it has two ICs on it, and there is one heatsink and IC on each of color tubes. Then theres a few more that are just scattered around. Is there anything I should be looking for? Like wires come from the tubes to an area near an IC or something? And is that 2 total ICs, or two per color?
theonlywizdum is offline  
post #6 of 12 Old 10-24-2008, 07:11 PM - Thread Starter
Member
 
theonlywizdum's Avatar
 
Join Date: Oct 2008
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I think I have enough posts to post a link to the pictures now.
http://jagged.biz/tv_problem/

Is there anything else I should take a picture of that would help?

Thanks for the help. I have done a bit of work with electronic before (fixed a few busted capacitors on some LCD monitors, among other little projects) but I have never worked on a TV before.
theonlywizdum is offline  
post #7 of 12 Old 10-24-2008, 07:37 PM
AVS Special Member
 
vili's Avatar
 
Join Date: Jan 2007
Location: Martin, TN
Posts: 1,573
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
From the looks of it you have the exact same set that I do...Philips 60pp9202. Here is a step by step guide for that exact model showing you how to change the ICs and where they are located (with pictures) it even gives you the ebay auction to go to in order to purchase decent ICs for a good price. Exact steps I took fixed my set.

http://techghetto.com/tv-repair/
vili is offline  
post #8 of 12 Old 10-24-2008, 07:56 PM - Thread Starter
Member
 
theonlywizdum's Avatar
 
Join Date: Oct 2008
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
WOW, thats it. Thanks dude, I'll reply back here once I get a chance to try this out.
theonlywizdum is offline  
post #9 of 12 Old 10-24-2008, 08:07 PM
AVS Special Member
 
vili's Avatar
 
Join Date: Jan 2007
Location: Martin, TN
Posts: 1,573
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Your welcome, glad I could help. Took my awhile to find that site and figure out what to do hehe.
vili is offline  
post #10 of 12 Old 10-25-2008, 07:12 AM
AVS Special Member
 
hammerdwn's Avatar
 
Join Date: Sep 2000
Location: Northern California
Posts: 4,620
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 55 Post(s)
Liked: 35
DIY http://www.hometheatershack.com/foru...e-repairs.html
Or pay a tech $400 to do it. Only thing is, philips gets crt coolant contamination (it will happen sooner or later), which is another BIG repair.
hammerdwn is online now  
post #11 of 12 Old 11-27-2008, 02:54 PM - Thread Starter
Member
 
theonlywizdum's Avatar
 
Join Date: Oct 2008
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I finally got all the parts I needed to fix this and everything looks good. I had to reset the convergence back to factory settings, then fine tune it with the multi-point convergence menu after replacing the convergence ICs. Thanks for your help.
theonlywizdum is offline  
post #12 of 12 Old 11-27-2008, 06:28 PM
AVS Special Member
 
vili's Avatar
 
Join Date: Jan 2007
Location: Martin, TN
Posts: 1,573
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Excellent, glad it worked for you. My tv is still going strong, will probably upgrade next year just because. It was a pain getting the screws out of the board and that damn black cable organizer wasn't it? I ended up just ripping mine out after about an hour trying to get the last screw out of it heh.
vili is offline  
Reply Rear Projection Units

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off