Samsung DMD board replacement - Page 19 - AVS Forum
Forum Jump: 
Reply
 
Thread Tools
post #541 of 846 Old 02-04-2010, 07:47 AM
AVS Special Member
 
mes444's Avatar
 
Join Date: Aug 2005
Location: N. Texas
Posts: 2,635
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
nozlep, your pic points to a dmd board failure.
mes444 is offline  
Sponsored Links
Advertisement
 
post #542 of 846 Old 02-04-2010, 12:52 PM
Advanced Member
 
PA_MainyYak's Avatar
 
Join Date: Nov 2005
Location: Johnstown, PA
Posts: 512
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
The technician came today and cured my set of its "pixelpox"



Seems Samsung has a significant back order problem with the replacement parts.

ÂOne of the few good things about modern times: If you die horribly on television, you will not have died in vain. You will have entertained us.Â
- Kurt Vonnegut
-0-
PA_MainyYak is offline  
post #543 of 846 Old 02-13-2010, 02:13 AM
Newbie
 
rl67pinoy's Avatar
 
Join Date: Feb 2010
Location: 808
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
anyone has the step by step procedure on how to replace this thing with pictures? i looked through 19 pages of this forum and did not find one.
rl67pinoy is offline  
post #544 of 846 Old 02-13-2010, 02:45 AM
Newbie
 
rl67pinoy's Avatar
 
Join Date: Feb 2010
Location: 808
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
samsung sucks!
LL
rl67pinoy is offline  
post #545 of 846 Old 02-25-2010, 06:41 PM
Newbie
 
cab2140's Avatar
 
Join Date: Aug 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I just replaced the DLP chip (4719-001981) in my HLS5065W to get rid of the white spots on my screen. When I turned on for the first time the screen is out of focus and fuzzy. Does anyone have an idea of what I may have done wrong?

Post #240 from AmitinLA seems like the same issue. Any help would be welcome.

Thanks,
cab2140
cab2140 is offline  
post #546 of 846 Old 03-10-2010, 04:35 PM
Newbie
 
rl67pinoy's Avatar
 
Join Date: Feb 2010
Location: 808
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
3 SCREWS PINK CIRCLE = ADJUSTING SCREW ( DO NOT EVER TOUCH!!!)

"during disassembly i noticed the 4 screws with black arrows have different torque. 2 screws on top are tight. 2 in the bottom are not . i measured the gap and put them back the way they were." not sure if that has anything to do with the alignment. but it wasn't mentioned on the manual to pay attention to that screw. its just weird how they didnt have the same torque.
LL
rl67pinoy is offline  
post #547 of 846 Old 03-10-2010, 04:39 PM
Newbie
 
rl67pinoy's Avatar
 
Join Date: Feb 2010
Location: 808
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by cab2140 View Post

I just replaced the DLP chip (4719-001981) in my HLS5065W to get rid of the white spots on my screen. When I turned on for the first time the screen is out of focus and fuzzy. Does anyone have an idea of what I may have done wrong?

Post #240 from AmitinLA seems like the same issue. Any help would be welcome.

Thanks,
cab2140

did you touch the 3 screws mentioned earlier?
rl67pinoy is offline  
post #548 of 846 Old 03-13-2010, 04:56 AM
Newbie
 
thelostsaint's Avatar
 
Join Date: Mar 2010
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
so i have all these issues with the white dots and all...

thing is that im in the army, and stationed overseas.. so i would assume they have techs here or will they only send techs out if you live in the states? with that being said, then they would have to reimburse me then ?

and untill i have some some of the peoples here, i thought mine was bad but its getting there anyway ... ugh ..

and can someone point me in the direction to get the service menu ? been lookin just havnt found it yet..

thanks
LL
thelostsaint is offline  
post #549 of 846 Old 03-13-2010, 07:10 AM
Newbie
 
thelostsaint's Avatar
 
Join Date: Mar 2010
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
also when i went to the site to see even bout ordering the part, the part number i found on the site says its for the PB01 version and i have the PB02... so someone help me out on the part number for mine?

model # HLS5086WX/XAA
serial# B18E3CELA02260D
version PB02
thelostsaint is offline  
post #550 of 846 Old 03-13-2010, 10:12 PM
Member
 
PezJunkie's Avatar
 
Join Date: Dec 2006
Posts: 110
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by thelostsaint View Post

also when i went to the site to see even bout ordering the part, the part number i found on the site says its for the PB01 version and i have the PB02... so someone help me out on the part number for mine?

model # HLS5086WX/XAA
serial# B18E3CELA02260D
version PB02

If you have a Version PB02 the part # you need is 4719-001981.
If you have a Version PB01 the part # you need is 4719-001968.

Have you tried contacting Samsung? They should fix this for you... but not sure how that works with you being overseas.

Also, in case you haven't found it, the service menu works like this:
With the TV turned *off*, press MUTE, 1, 8, 2 and then Power. You will have the service menu on screen until you turn the TV off again.
PezJunkie is offline  
post #551 of 846 Old 03-14-2010, 06:15 AM
Newbie
 
thelostsaint's Avatar
 
Join Date: Mar 2010
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by PezJunkie View Post

If you have a Version PB02 the part # you need is 4719-001981.
If you have a Version PB01 the part # you need is 4719-001968.

Have you tried contacting Samsung? They should fix this for you... but not sure how that works with you being overseas.

Also, in case you haven't found it, the service menu works like this:
With the TV turned *off*, press MUTE, 1, 8, 2 and then Power. You will have the service menu on screen until you turn the TV off again.

yea so i talked to a few people .... first couple times i was on hold for well over 45 mins .... but then i finally i got someone that was somewhat helpful, and tried explaining to them that all i need it the part and i can fix it. but alas their answer was " well we need a tech to come out there to see and make sure thats the problem"... yea i cause i want to deal with the playing "where is Orion today"... but then i figured i would just say F it and buy it, and turns out... there is over a 4 week delay in that even .... and im suppose to deploy in a couple weeks. so much for being able to watch a little bit of tv ... thanks samsung for helping out the service members!
oh yea, tried the german route, figured that would be good. turns out, none of them speak english ... pfft yea right!

so where do i have to go to get put on this class action ? cause im all bout this now... and after this, i will not buy samsung again... especialy with this problem and then the damn cam i have of theirs too! a $350 cam and pretty much out of box brand new and i have a line from top to bottom on my lcd screen.. and the pics turn out grainy too... and its a 10.1MP!!!! wtf .... never again i say!
thelostsaint is offline  
post #552 of 846 Old 03-14-2010, 02:55 PM
Newbie
 
thelostsaint's Avatar
 
Join Date: Mar 2010
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
oh also thanks pez, it worked... and looks like i got more use out of mine then most cause the most i have seen was bout 4300 or something like that, and today when i checked it was 5407 hours... so not to bad, but also thats with atleast 2 to 300 white dots tho ...
thelostsaint is offline  
post #553 of 846 Old 03-15-2010, 12:22 PM
Member
 
ATPTourFan's Avatar
 
Join Date: Jun 2006
Posts: 174
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 10
Just wanted to post my experience today in calling into Samsung Executive Customer Relations (ECR) Team.

I got my first two white dots this weekend and found this thread. By the time I got to the end I learned Samsung would likely help me out despite being out of warranty for 21 months (HLS5086WX/XAA PB02 was purchased March 9 2007).

So all went well. I got my service order # and they will be paying for parts and labor. I should expect a call from local service center in 24-48 hrs.

I'll update everyone once work is complete and final results.
ATPTourFan is offline  
post #554 of 846 Old 03-15-2010, 12:35 PM
Member
 
ATPTourFan's Avatar
 
Join Date: Jun 2006
Posts: 174
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 10
Quote:
Originally Posted by PezJunkie View Post

If you have a Version PB02 the part # you need is 4719-001981.
If you have a Version PB01 the part # you need is 4719-001968.

Have you tried contacting Samsung? They should fix this for you... but not sure how that works with you being overseas.

Also, in case you haven't found it, the service menu works like this:
With the TV turned *off*, press MUTE, 1, 8, 2 and then Power. You will have the service menu on screen until you turn the TV off again.

Service menu doesn't delete TV settings (like picture/sound/channels) unless you specifically choose RESET DEFAULTs command right?
ATPTourFan is offline  
post #555 of 846 Old 03-21-2010, 09:55 AM
Member
 
rx7gslse's Avatar
 
Join Date: Aug 2005
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
ok guys... Just found this thread.


Have a HLS5686WZ/XAA purchased in Nov 2007, and the 1st white dots showed up about 2 weeks ago. Now we're gaining one new dot about every 3-4 days.

Service menu shows 5912hours (original bulb!)


Per the advice I found here, just got off the phone with 1-800-Samsung.

She took down my model #, and S/N and gave me a transaction #. Will have a local service company call to setup an apt in 1-2 days and "if it is the fault of the board the cost of both Labor and Parts will be covered by Samsung"


While I'm not happy it's occurred, so far I'm happy with their response to the issue.
rx7gslse is offline  
post #556 of 846 Old 03-23-2010, 02:49 AM
Newbie
 
rl67pinoy's Avatar
 
Join Date: Feb 2010
Location: 808
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
kinda blurry. it looks better in person.
LL
rl67pinoy is offline  
post #557 of 846 Old 03-24-2010, 12:23 PM
Member
 
rx7gslse's Avatar
 
Join Date: Aug 2005
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
FYI - Samsung tech came out this morning. Took one look at the TV, flipped it around and took off the back panel. About 5 more minutes of pulling shields off and he swapped out the DLP chip, and put it back together.

15 min later my TV was lookin' nice and new and dude was on his way. Nothing to sign, no charge, no complaints.

Again, not happy it happened, but Samsung certainly stood up for it.


FYI - he stated that Samsung is sending the offending DLP chips back to TI, and that for the time being he didn't have any information to say I shouldn't look forward to this happening again in another 2-3yrs, but he wasn't real sure.
rx7gslse is offline  
post #558 of 846 Old 03-26-2010, 04:14 PM
Member
 
ATPTourFan's Avatar
 
Join Date: Jun 2006
Posts: 174
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 10
Quote:
Originally Posted by ATPTourFan View Post

Just wanted to post my experience today in calling into Samsung Executive Customer Relations (ECR) Team.

I got my first two white dots this weekend and found this thread. By the time I got to the end I learned Samsung would likely help me out despite being out of warranty for 21 months (HLS5086WX/XAA PB02 was purchased March 9 2007).

So all went well. I got my service order # and they will be paying for parts and labor. I should expect a call from local service center in 24-48 hrs.

I'll update everyone once work is complete and final results.

So, over the past few days, I gained a few more dots for a total of 5. My DMD chip was replaced today for free. Looks great. Everything in focus.

Checked original lamp hours: 8337! This TV was purchased exactly 3yrs ago this month. I have been babying the lamp by minimizing on/off cycles, or periods of ON time less than 30/60mins. Also, I never turn the lamp back on until the fan stops cooling it after shutdown, and usually at least 5 mins past that. Of course, I have my trusty APC BR800BLK Back-UPS to ensure that the lamp never gets abruptly powered down without proper cooling down cycle.
ATPTourFan is offline  
post #559 of 846 Old 04-15-2010, 09:09 AM
Newbie
 
vbfun's Avatar
 
Join Date: Apr 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I can not find any links to a pdf file to take apart my 50" Samsung rear projection TV. Yes it does have the white spot sickness.
vbfun is offline  
post #560 of 846 Old 04-15-2010, 10:58 AM
Member
 
PezJunkie's Avatar
 
Join Date: Dec 2006
Posts: 110
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by vbfun View Post

I can not find any links to a pdf file to take apart my 50" Samsung rear projection TV. Yes it does have the white spot sickness.

Samsung is fixing white spots as warranty repairs now... try calling Samsung first.

(btw - all the documentation I have is here: http://drop.io/hls5086w)
PezJunkie is offline  
post #561 of 846 Old 04-27-2010, 12:07 PM
Member
 
pilgrimpete's Avatar
 
Join Date: Feb 2006
Location: Oregon, USA
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 10
Quote:
Originally Posted by PezJunkie View Post

(btw - all the documentation I have is here: http://drop.io/hls5086w)

Thanks you PezJunkie - that's a really useful collection.
pilgrimpete is offline  
post #562 of 846 Old 04-29-2010, 08:46 PM
Newbie
 
melonyhughes's Avatar
 
Join Date: Apr 2010
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
PezJunkie and everyone that contributed, I just wanted to say Thank You soooo much for the helpful info. We bought our TV used about two months ago and now you cannot hardly even watch TV. I have called Samsung several times and they say that my TV is covered under their white dot issue, but then the technicians call and say that it is not, then Samsung informed us that our model was not one of the ones that had a faulty chip (HLT5676S). But abviously it was, otherwise there would not be hundreds of white dots on my TV screen. I give up, so we are going to buy the chip and install it ourselves. Anyway, THANK YOU!!!!
melonyhughes is offline  
post #563 of 846 Old 04-30-2010, 06:47 AM
Advanced Member
 
alanl715's Avatar
 
Join Date: Oct 2007
Location: tejas
Posts: 932
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by melonyhughes View Post

PezJunkie and everyone that contributed, I just wanted to say Thank You soooo much for the helpful info. We bought our TV used about two months ago and now you cannot hardly even watch TV. I have called Samsung several times and they say that my TV is covered under their white dot issue, but then the technicians call and say that it is not, then Samsung informed us that our model was not one of the ones that had a faulty chip (HLT5676S). But abviously it was, otherwise there would not be hundreds of white dots on my TV screen. I give up, so we are going to buy the chip and install it ourselves. Anyway, THANK YOU!!!!

nonono...it is covered...we r Samsung auth.
call Samsung and have the call elevated to their ECR dept.
They will approve it.
R U in So. Texas ?
alan
alanl715 is offline  
post #564 of 846 Old 05-05-2010, 02:16 PM
Newbie
 
tpzinger's Avatar
 
Join Date: May 2010
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Just call 1-800-Samsung and they will send out a service tech to fix it for free.
tpzinger is offline  
post #565 of 846 Old 05-21-2010, 11:53 AM
Newbie
 
Crow 492's Avatar
 
Join Date: May 2010
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I would like to thank PezJunkie BIG TIME

Here is what I had to go threw.

My Tv is a HLS5086WX/XAC

Ontario Canada

After 5 Day's of reading and reading this post I came to the conclusion that I had the same issue as all of you got here. So bad that it looks like bar codes on my Tv screen with over 1000 black dots & 2 white ones with lines running right across the screen left to right every 4 Inches.

I took the DMD chip out to take a look at it and yes what you see on the chip is what you see on the Tv screen dot for dot, clearly a burnt DMD chip.

Now with samsung LOL

Called them the first time and with no go they told me my warranty is up so there is nothing they can do for me so I was determine so I called them the next day with the same answer nothing they can do. I let it go for a few days and had every thing ready this time and sure enough I got someone that said yes that it is a well known problem and that samsung will send a tech over in 24 Hours. The tech just called and a appointment is set cant wait. I will let you know how it turns out from here with that.

Samsung will cover it don't give up he said the new reps are not aware of the issue so that's why they give you the blow off.
Crow 492 is offline  
post #566 of 846 Old 06-17-2010, 02:13 AM
Senior Member
 
Injected Sin's Avatar
 
Join Date: Sep 2008
Posts: 331
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
So my hlt-5075sx galaxy of white dots are doomed. Called 1800samsung spoke to a rep and everything got squared away on my repair order 'for freee'.

Local tech calls me the same afternoon to confirm my address and time he can come over to resolve the 'white dots'. He has the part in stock and knows of the problem.

Wow great response time. We'll see how it goes tomorrow.

XBL GTÂ vFLOODv
Injected Sin is offline  
post #567 of 846 Old 06-17-2010, 10:05 PM
Senior Member
 
Injected Sin's Avatar
 
Join Date: Sep 2008
Posts: 331
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
yes! lakers win and white dots gone tech took only 10 mins to swap out the dlp chip.

XBL GTÂ vFLOODv
Injected Sin is offline  
post #568 of 846 Old 06-19-2010, 03:34 PM
Newbie
 
Surf's Avatar
 
Join Date: Sep 2007
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have the 67" model from Costco Model #HLT6756WX/XAA. I spoke to 2 cust service reps who said the model was not covered for the free fix and that I would need to pay out of pocket for repair and parts. I am guessing that this is because Costco has its own specific Model# and that in the past Costco has often honored replacement outside of warranty period, which is not a common practice anymore. I am checking and awaiting call back from Costco, but it really isn't on them so much as Samsung IMO. Same damn defective chip.

Quote:
Originally Posted by alanl715 View Post

nonono...it is covered...we r Samsung auth.
call Samsung and have the call elevated to their ECR dept.
They will approve it.
R U in So. Texas ?
alan

Tried this on my second phone call to customer service and was connected to a rep in the Executive Customer Relations Dept. I was also told that my set would not be covered and that there was nothing more that could be done and that this is the highest level that I could reach.

Hmmmm really? Well that sucks. Left an email with my complaint and related that if a resolution could not be found for my situation (Same damn defective chip) that I would file a complaint with the BBB, for whatever that's worth and I will not be purchasing any other Samsung products.

Definitely sucks on a TV that was $3K new.

Edit - And yes I just lurk and read and don't post.
Surf is offline  
post #569 of 846 Old 06-20-2010, 03:07 PM
Member
 
PezJunkie's Avatar
 
Join Date: Dec 2006
Posts: 110
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Surf View Post

Same damn defective chip.

Almost, but not exactly. It looks like the DLP for your set is a different part number.

Quote:
Originally Posted by Surf View Post

Left an email with my complaint and related that if a resolution could not be found for my situation (Same damn defective chip) that I would file a complaint with the BBB, for whatever that's worth and I will not be purchasing any other Samsung products.

Complaining to the BBB is good too, but it looks like people have had better results filing a complaint with the NJ state attorney general's office.

Good luck!
PezJunkie is offline  
post #570 of 846 Old 06-27-2010, 07:09 AM
Member
 
naseqp's Avatar
 
Join Date: Dec 2006
Posts: 39
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
very interesting that now over a year later Samsung is fixing these for free.

I paid $200 for a new chip and replaced it myself, glad the later sufferers of white dot disease are getting fixed...but Samsung, you should review your files.
naseqp is offline  
Reply Rear Projection Units

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off