Sammy HLN507WX Power Problem - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!


Forum Jump: 
 
Thread Tools
post #1 of 2 Old 10-04-2009, 10:33 AM - Thread Starter
Newbie
 
miabutreeks's Avatar
 
Join Date: Sep 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
The tv does not turn on. when we hit the power-on button on the remote or the unit it self, no sounds made, No blinking lights. Nothing out of the ordinary happened prior to it not working. has about 11000 hrs on it. bulb looks good. unit was running fine until one morning...nothing. tried different wall outlets with and without surge suppressor. no electrical storms recently. Thoughts?
miabutreeks is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 10-04-2009, 06:56 PM
AVS Special Member
 
hammerdwn's Avatar
 
Join Date: Sep 2000
Location: Northern California
Posts: 4,779
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 113 Post(s)
Liked: 42
Could be Digital board $350. But should have voltages checked on the inside...
hammerdwn is offline  
Sponsored Links
Advertisement
 
Reply Rear Projection Units

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off