Fan will not stop running. Hitachi 50v500 - AVS | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!


Forum Jump: 
 
Thread Tools
Old 12-05-2009, 01:48 PM - Thread Starter
Newbie
 
madphill's Avatar
 
Join Date: Dec 2009
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have a Hitachi 50v500 that we bought in 2004. It had the engine replaced after about a year or so due to the infamous red shift, and I just replaced the entire lamp unit myself the other day.

I have noticed that the fan will not stop running even when the unit is turned off. If I unplug it, it ceases, but starts again as soon as it's plugged in.

I'm pretty irritated. I bought the lamp thinking I was avoiding purchasing a new TV for a while, but I'm full aware of what can happen if this fan goes out. (not to mention it's annoying to hear the fan running all the time even with the device off)

I am looking for advice from people who know or who have had this issue about what to do. I thought of seeking a replacement fan, but the fan works...it's probably a relay issue I'm guessing.

Any help would be appreciated
madphill is offline  
 
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off