Problems with Pioneer Pro 510HD, 610HD, 710HD, SD532HD, 582HD, 642HD - Page 4 - AVS Forum
Forum Jump: 
Reply
 
Thread Tools
post #91 of 92 Old 12-12-2012, 10:53 PM
Advanced Member
 
ScoHo's Avatar
 
Join Date: Nov 2002
Posts: 644
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
mears52, did you see my posts in the 510 thread? http://www.avsforum.com/t/402397/pioneer-elite-pro-510-problem/2850#post_22680072

I've been having a similar issue for months now (the power problem, not the convergence screen problem). Board was re-soldered (by Bob), and I just recently replaced the ICs, but it didn't fix it. Hopefully you have better luck.
ScoHo is offline  
Sponsored Links
Advertisement
 
post #92 of 92 Old 12-12-2012, 11:48 PM - Thread Starter
AVS Special Member
 
Mr Bob's Avatar
 
Join Date: Jan 2000
Location: San Francisco Bay Area/San Lorenzo, CA., USA
Posts: 9,341
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Liked: 46
Quote:
Originally Posted by mears52 View Post

Yes every point on the board has been resoldered even under the white rubber stuff .. had to remove the white rubber stuff to get at the point that needed resoldering . All the fuses check out and every time I go to power up the tv the power board goes into power down mode and I get the red led .. and its the only led that is lit . I have checked all the outer boards and there is no dammage or other led,s lit up . I even pulled the power board out of it today and checked it just to be sure that nothing was missed . I will order new ic,s from mcm and replace the ones in the conv. Amp assy. And hopefully that will do the trick .. should that not be the issue do you have an used deflection board or know where I can get a good used working one ?

Sometimes the convergence board needs the ICs replaced even tho no red LED is lit up on it, so yes I would try replacing them and seeing if that does it. If the deflection board is bad it usually has a red LED lit up on it, but who knows? Yes I have a deflection board if you need it, don't know if you can get them from Pioneer anymore. I hear the PS boards are NLA, good thing they don't usually have problems that require their replacement like the deflection boards do. The PS boards just keep going, and going, and going... In all the time I've been doing this I have only seen one PS board unsalvageable and that was because it had been too badly damaged by the shippers - cracked in just too many places - and could not be saved. Another one had to have IC 204 replaced because it failed the aspect ratio change test and installing a new IC did the trick on that one. This is out of the dozens and dozens per year I have serviced over the years, all of which kept on ticking and are probably still making sweet HD for their owners. Other than that...

b

Robert Jones
Image Perfection
510-278-4247
650-333-4808 cell
bob at imageperfection dot com
www.projectiontvtroubleshootingadvice.com
YouTube channel: mrbobbigscreen

Mr Bob is offline  
Reply Rear Projection Units

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off