Mitsubishi WD-52525 power supply(green blinking light) - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 1 Old 06-14-2011, 05:35 PM - Thread Starter
Newbie
 
Mascari13's Avatar
 
Join Date: Jan 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
So here's my problem, i have a mitsubishi wd 52525 tv and i got the blinking green light problem, where when i plugged in the tv the green led light would just blink forever and not boot up, so i took apart the chassis replace ALL the capacitors, like 11 or so just on the power supply and put it back together and it worked fine. then the power went out and i had to plug back in the tv but instead of the green led flashing forever it would flash for a second then u would hear the fan click on then shut off and then the green led would flash again, stop, then start, then stop repeatedly and each time u could hear the click of the fan on and off. any one know of a fix? I know it has to be with the power supply because i have tested the all the boards in other tvs. is there something else i have to check or replace on the power suppy other than the big main capacitors?

thanks,
Peter
Mascari13 is offline  
Reply Rear Projection Units

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off