Toshiba 72HM196, Possible Light Engine Problem? - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 10-11-2011, 09:40 AM - Thread Starter
Newbie
 
billzilla15's Avatar
 
Join Date: Oct 2011
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
i have a 72HM196 by Toshiba, the top have of the screen displays properly but the bottom half is snowy and it appears to have a double image of what is displayed on the top, i believe it to be the light engine/ dmd board. just wanted a second opinion before i order one for it
LL
billzilla15 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 10-13-2011, 03:42 PM
AVS Addicted Member
 
videobruce's Avatar
 
Join Date: Dec 2002
Location: Buffalo NY
Posts: 15,402
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 298 Post(s)
Liked: 161
Have you looked through the repair sticky at the top of this forum??

.
.
Abundant OTA television is what makes this country different from all others. Lets keep it this way. If you like Wi-Fi so much, OTA fits right in. After all, it is wireless.
videobruce is offline  
post #3 of 3 Old 08-19-2012, 10:19 AM
Newbie
 
frdmll's Avatar
 
Join Date: Mar 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
i saw your post and was wondering did you fix your tv. i have a 72hm196 but my pic is good on right and same lines as yours on left. any ideas would be great
frdmll is offline  
Reply Rear Projection Units

Tags
Toshiba , Projectors



Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off