toshiba 65HX81 red blinking light - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
Old 07-31-2012, 04:35 PM - Thread Starter
AVS Forum Special Member
 
subavision212's Avatar
 
Join Date: Sep 2007
Posts: 1,578
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 62 Post(s)
Liked: 38
So my brother who bought this 2005 display from me called and said he turned on the set and has no picture or sound just a blinking LED. Tried searching but didn't find much, mention of some fuses, convergence IC, IC shutdown circuit and possilbe bad PD0074 power board. Anyone have a definitive answer for what might be the problem and if so, any idea about repair and costs. Can it even still be repaired? They can't afford a new display. Thanks so much for any help.

subavision212 is offline  
Sponsored Links
Advertisement
 
Old 07-31-2012, 07:15 PM
AVS Forum Special Member
 
yadfgp's Avatar
 
Join Date: Oct 2006
Location: Meridian, Idaho
Posts: 2,263
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 66 Post(s)
Liked: 68
yadfgp is offline  
Old 08-01-2012, 07:12 AM - Thread Starter
AVS Forum Special Member
 
subavision212's Avatar
 
Join Date: Sep 2007
Posts: 1,578
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 62 Post(s)
Liked: 38
thanks a lot.

subavision212 is offline  
Sponsored Links
Advertisement
 
 
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off