Time to order a new lamp? - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 08-28-2012, 04:39 AM - Thread Starter
AVS Special Member
 
AnthonyB's Avatar
 
Join Date: Jun 2003
Location: Tampa, FL
Posts: 3,685
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 13
I picked up a very nice WD65733 off craigslist that had a bad dmd chip..

I had it apart to clean the various items of dust and took the lamp out and saw there is some sort of black fragments in there.. Is this the mercury or is it signs of wear?

20120827102921739.jpg
AnthonyB is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 08-29-2012, 12:13 PM - Thread Starter
AVS Special Member
 
AnthonyB's Avatar
 
Join Date: Jun 2003
Location: Tampa, FL
Posts: 3,685
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 13
Sorry about the image... I re-uploaded it..
AnthonyB is offline  
post #3 of 3 Old 08-29-2012, 12:42 PM
Advanced Member
 
ChuckF.'s Avatar
 
Join Date: Feb 2010
Location: Atlanta, GA
Posts: 513
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 21
Quote:
Originally Posted by AnthonyB View Post

I picked up a very nice WD65733 off craigslist that had a bad dmd chip..
I had it apart to clean the various items of dust and took the lamp out and saw there is some sort of black fragments in there.. Is this the mercury or is it signs of wear?

Probably just dirt. That part of the lamp is not sealed, only the little tube inside the lamp, and it's only there where the Mercury is.
ChuckF. is offline  
Reply Rear Projection Units

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off