Samsung HLP-5663w - AVS | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!


Forum Jump: 
 
Thread Tools
Old 09-08-2012, 12:58 AM - Thread Starter
Newbie
 
RickFelt's Avatar
 
Join Date: Sep 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
It appears my colorwheel has died yet again. I've already replaced it once(3 years ago) and the lamp also. It had been making that humming/grinding noise for the past month or 2 and now it doesn't appear to spin at all. The TV turns on, all the fans work. I hear sound but no picture appears and the lamp won't light up. The TV turns off within 15 seconds.

I read that if the C-Wheel is dead the lamp won't fire up, is that true? I believe the ballast is still good because both fans still seem to work at full speed.

Any ideas? I appreciate any input..

Thanks,

Rick

Samsung Model HLP-5663WX/XAA
RickFelt is offline  
Sponsored Links
Advertisement
 
Old 09-18-2012, 04:40 AM
AVS Addicted Member
 
videobruce's Avatar
 
Join Date: Dec 2002
Location: Buffalo NY
Posts: 15,658
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 416 Post(s)
Liked: 199
It's obvious you need to replace it again.

.
.
Abundant OTA television is what makes this country different from all others. Lets keep it this way. If you like Wi-Fi so much, OTA fits right in. After all, it is wireless.
videobruce is offline  
 
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off