My Mitsubishi DLP TV shuts off w/ orange blinking lights - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 4 Old 08-24-2017, 10:19 AM - Thread Starter
Newbie
 
Join Date: Aug 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
My Mitsubishi DLP TV shuts off w/ orange blinking lights

I have a WD73738(or 838), it's about 6.5 years old, I'm on my 3rd lamp (replaced 12 mos ago)... a couple of weeks ago it would shut off (after a loud "pop"), then the green light would flash and some orange. So I waited a few mins, turned it on again and it worked fine... but after a few days it happened again, so I waited a bit and turned it back on, only that time it just stayed on for a few hours before shutting off. After a few more days of the tv being off more than it was on, I did some research, and could not find a solution to the light show it was displaying, so I tried getting some canned air and blew out the vents in the back/sides... well, that seemed to work b/c for 2 weeks, everything was back to normal. 2 days ago the same problem started again.



As far as the error lights, this is what happens: first a rapid green blinking light (30 seconds), then a "click", the blue light flashes (once), then the rapid green flashing light (10 seconds), this repeats 3-4 times, then the rapid green flashing light (30 seconds), which is followed by 2 sets of blinking orange lights (8x each), then the rapid green flashing light (10 seconds), then another 2 sets of blinking orange lights (34x each), then the rapid green flashing light (10 seconds), then another 2 sets of blinking orange lights (24x each). Then after stopping for a few seconds, the whole cycle repeats. The tv will still come on and the picture is good*, it just wont stay on.



* picture is dimming a little and takes a bit to fully "warm up".


Most recent "error code": 2 sets of 12 orange, repeated 3 times with rapid green flashing light between.



Any assistance would be appreciated.
Tom_Sawyer2112 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 09-03-2017, 07:33 PM
Member
 
BCSMan's Avatar
 
Join Date: May 2004
Location: Capac, Michigan
Posts: 141
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Liked: 10
Seems like there are no Mits folks around anymore to help. I have had a couple posts also waiting for any assistance. We are a few years too late it appears....
BCSMan is offline  
post #3 of 4 Old 09-13-2017, 07:50 AM
Senior Member
 
vince48's Avatar
 
Join Date: Feb 2002
Location: Hayward, CA.
Posts: 240
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 115 Post(s)
Liked: 30
try Mr. Bob, he's old throwback for RPTV and has worked on my Pioneer 510 when i had it. look him up.
vince48 is offline  
 
post #4 of 4 Old Yesterday, 06:48 PM
Newbie
 
Join Date: Sep 2015
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 0
Here's a site I found with error codes. No background on these guys so I'd take it with a grain of salt. They do not mention an orange light. Maybe it's actually "red?"

http://www.stereoandvideorepairco.co...eshooting.html
macej is offline  
Sponsored Links
Advertisement
 
Reply Rear Projection Units

Tags
dlp , flashing , light , Mitsubishi , orange

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off