Official Mitsubishi WD XX833 Owners Thread - AVS Forum
Forum Jump: 
Reply
 
Thread Tools
post #1 of 3510 Old 08-30-2007, 05:50 AM - Thread Starter
AVS Special Member
 
lujan's Avatar
 
Join Date: Apr 2004
Posts: 2,618
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 26
I'm starting a new thread for the owners of the XX833 Mitsubishi DLPs. The only other thread out there seems to be specific to the 65833s.

I just received the TV (WD-73833) yesterday (8/29/07). Here are my first impressions:

The picture is outstanding. It is so much brighter than my previous WD-62525.

I'm struggling with the inputs. I have threee HDMI sources connected via an HDMI switch but the TV didn't seem to recognize the Blu-ray player when I switched it over to that devices port. I spent at least a half hour trying to get it to work until I realized that the TV itself has multiple HDMI ports. I then connected it to the second HDMI on the TV and at first it didn't recognize it again. I tried changing the inputs using the "Input" button but it seems the button only has one HDMI selection. I will have to call Mitsubishi this afternoon or tomorrow to find out more unless someone on this forum can chime in. I finally got it to work but I don't know how, I think it eventually recognized it on it's own. The picture was amazing watching the movie in 1080p.

Does the TV automatically recognize a signal on a particular HDMI port by just turning that device on?

Can you have two HDMI sources turned on at the same time? Will the TV get confused if you do?

I will post pictures for those of you interested this weekend. Thanks for any advice.

lujan
691 Blu-ray
19 HD DVD
6 DVD
lujan is offline  
Sponsored Links
Advertisement
 
post #2 of 3510 Old 08-30-2007, 06:27 AM
Member
 
thegentlegiant's Avatar
 
Join Date: Feb 2004
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Great idea starting this thread Lujan. I would love to see the pictures that you post this weekend & hopefully you can give a review after more experience with the set over the next few days. I spent a over an hour reading the thread about the Sony, & it would be great if all owners of the Mitsubishi can chime in here & add their experiences.

I am personally in the market for a TV & have narrowed my choices down to the 65833 & the Sony 603000, but I have only seen the Sony in person. Did you have the opportunity to compare the Mitsu & the Sony before purchasing by chance, or was it not even a consideration b/c you were looking for over 70" in screen size? I can go for the 65" myself, but the 73" would be a little too large based on furniture & screen distance limitations of the room. 60" to 65" are perfect for me.
thegentlegiant is offline  
post #3 of 3510 Old 08-30-2007, 06:54 AM
Advanced Member
 
tlbowerts's Avatar
 
Join Date: May 2007
Posts: 584
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have the 65833 and am very happy with it ,Has great PQ, HD WOW, SD is not bad at all(very watchable), no bowing at all, no loud humming , even on mute can't hear any hummimg, the 120Hz is nice , really makes a different with gaming. I compared the Sony 603000 with this, both are very nice tv's ( the same feature wise) , but in my oponion the 833 has better PQ, and i think it does better in a room with lots of light (like mind) with the anti glare screen. I also like the looks of the 833 better, and the bigger size work best for me,as 5" can make a different. Also mit has 4 HDMI 1.3 hook up's , the more the better , never can have to many .
tlbowerts is offline  
post #4 of 3510 Old 08-30-2007, 07:41 AM
Senior Member
 
akrias's Avatar
 
Join Date: Dec 2006
Posts: 232
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I am extremely interested in seeing these pictures. Do you happen to have a PS3 or 360? I would love to see some pictures of either of these in HD in gaming mode vs the other settings. Very soon I will be picking up my own 73" 833. I had the 65" 831, I'm pretty nervous about 73", but I'm going for it. If at all possible, I'd like to see some pictures of the set in the room, not just display pictures blown up and cropped. This way I can get an idea of the scale of 73" lol. I can't wait!
akrias is offline  
post #5 of 3510 Old 08-30-2007, 08:27 AM
AVS Special Member
 
Hipnotiq's Avatar
 
Join Date: Oct 2006
Posts: 1,160
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by lujan View Post

I spent at least a half hour trying to get it to work until I realized that the TV itself has multiple HDMI ports. I then connected it to the second HDMI on the TV and at first it didn't recognize it again. I tried changing the inputs using the "Input" button but it seems the button only has one HDMI selection. I will have to call Mitsubishi this afternoon or tomorrow to find out more unless someone on this forum can chime in. I finally got it to work but I don't know how, I think it eventually recognized it on it's own. The picture was amazing watching the movie in 1080p.

Does the TV automatically recognize a signal on a particular HDMI port by just turning that device on?

Can you have two HDMI sources turned on at the same time? Will the TV get confused if you do?

I don't have any experience with this model, however I believe it works the same as last years.
When an HDMI power signal is detected on the HDMI connector (1st time on each connector) the TV will prompt you to name the input (or select the input type).
That input would remain as that name/type until you manually change it.
The icon would remain even with the HDMI device powered off or disconnected it. This is a different process than with your componenet input which would disappear if you disconnected it.

Also, I would wait 10-15seconds after connecting it for it to detect.
Hipnotiq is offline  
post #6 of 3510 Old 08-30-2007, 08:33 AM
Member
 
rodeo-96's Avatar
 
Join Date: Aug 2007
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I just ordered my 65833 today. Does anyone know where to buy the stand that the xx833 is matched with on Mitsubushi's website?
rodeo-96 is offline  
post #7 of 3510 Old 08-30-2007, 10:11 AM - Thread Starter
AVS Special Member
 
lujan's Avatar
 
Join Date: Apr 2004
Posts: 2,618
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 26
Quote:
Originally Posted by Hipnotiq View Post

...
When an HDMI power signal is detected on the HDMI connector (1st time on each connector) the TV will prompt you to name the input (or select the input type).
...

It never did prompt me to name the second HDMI input. It's as though it never detected it. Does the connected HDMI device have to be turned on in order for it to detect it?

lujan
691 Blu-ray
19 HD DVD
6 DVD
lujan is offline  
post #8 of 3510 Old 08-30-2007, 10:13 AM - Thread Starter
AVS Special Member
 
lujan's Avatar
 
Join Date: Apr 2004
Posts: 2,618
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 26
Quote:
Originally Posted by rodeo-96 View Post

I just ordered my 65833 today. Does anyone know where to buy the stand that the xx833 is matched with on Mitsubushi's website?

I got mine from Best Buy but it's not the one that Mitsubishi shows on their website.

lujan
691 Blu-ray
19 HD DVD
6 DVD
lujan is offline  
post #9 of 3510 Old 08-30-2007, 10:25 AM
Senior Member
 
stangflyer's Avatar
 
Join Date: Feb 2006
Posts: 208
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I will be getting my 73833 on Sat. (1st) I hope.
stangflyer is offline  
post #10 of 3510 Old 08-30-2007, 12:42 PM
Member
 
eric2001's Avatar
 
Join Date: Jun 2007
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I received my 65833 this morning and am I impressed. All my hdmi components were recognized with no problem. This thing is a beauty. I can't wait to get home from work and play Tiger woods and madden in 1080p on my 360!!!
eric2001 is offline  
post #11 of 3510 Old 08-30-2007, 12:43 PM
Member
 
eric2001's Avatar
 
Join Date: Jun 2007
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by lujan View Post

I got mine from Best Buy but it's not the one that Mitsubishi shows on their website.

What brand is the stand you bought from best buy?
eric2001 is offline  
post #12 of 3510 Old 08-30-2007, 01:13 PM - Thread Starter
AVS Special Member
 
lujan's Avatar
 
Join Date: Apr 2004
Posts: 2,618
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 26
Quote:
Originally Posted by eric2001 View Post

What brand is the stand you bought from best buy?

It's a Bush brand in glossy black just like the TV. It was extremely easy to put together which surprised me because usually other brands are hard to put together or don't come with all the parts. It goes very well with the TV.

lujan
691 Blu-ray
19 HD DVD
6 DVD
lujan is offline  
post #13 of 3510 Old 08-30-2007, 01:15 PM - Thread Starter
AVS Special Member
 
lujan's Avatar
 
Join Date: Apr 2004
Posts: 2,618
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 26
Quote:
Originally Posted by eric2001 View Post

I received my 65833 this morning and am I impressed. All my hdmi components were recognized with no problem. This thing is a beauty. I can't wait to get home from work and play Tiger woods and madden in 1080p on my 360!!!

Did you have the TV on when you hooked up the HDMI components or was the set off when you connected them?

lujan
691 Blu-ray
19 HD DVD
6 DVD
lujan is offline  
post #14 of 3510 Old 08-30-2007, 01:21 PM
Member
 
eric2001's Avatar
 
Join Date: Jun 2007
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by lujan View Post

Did you have the TV on when you hooked up the HDMI components or was the set off when you connected them?

Yes my tv was on.
eric2001 is offline  
post #15 of 3510 Old 08-30-2007, 03:00 PM
AVS Special Member
 
Hipnotiq's Avatar
 
Join Date: Oct 2006
Posts: 1,160
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by lujan View Post

It never did prompt me to name the second HDMI input. It's as though it never detected it. Does the connected HDMI device have to be turned on in order for it to detect it?

Absolutely! You will need power to the HDMI device. Otherwise it will not be able to tell the TV who it is.

My assumption is you have tried all 4 HDMI inputs as well as at least 2 different HDMI cables.
If that assumption is true, then there is most likely a defect with your TV or your DVD player.

1st thing I would try is to press MENU button and then 1 2 3. There will be instructions on resetting the TV. (basically press ENter and then wait for TV to complete reboot)
There is a good chance that would resolve your issue.

After that, you may want to dig into the menu system of your HDMI device and confirm that HDMI output is active.
Hipnotiq is offline  
post #16 of 3510 Old 08-30-2007, 04:54 PM - Thread Starter
AVS Special Member
 
lujan's Avatar
 
Join Date: Apr 2004
Posts: 2,618
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 26
Quote:
Originally Posted by Hipnotiq View Post

Absolutely! You will need power to the HDMI device. Otherwise it will not be able to tell the TV who it is.

My assumption is you have tried all 4 HDMI inputs as well as at least 2 different HDMI cables.
If that assumption is true, then there is most likely a defect with your TV or your DVD player.

1st thing I would try is to press MENU button and then 1 2 3. There will be instructions on resetting the TV. (basically press ENter and then wait for TV to complete reboot)
There is a good chance that would resolve your issue.

After that, you may want to dig into the menu system of your HDMI device and confirm that HDMI output is active.

It is now working correctly detecting all three (3) inputs. There are only 3 right. I don't see 4 HDMI inputs? The only problem I have now is when I turn on both the TV and the Echostar 622 satellite receiver, the TV just shows a blue screen. I have to go to another HDMI input and then back to the original HDMI input. It then works fine. Could that be a E* 622 problem and not the TV?

lujan
691 Blu-ray
19 HD DVD
6 DVD
lujan is offline  
post #17 of 3510 Old 08-30-2007, 05:23 PM
AVS Special Member
 
westa6969's Avatar
 
Join Date: Jan 2005
Location: From Michigan now Retired to Naples, FL
Posts: 6,968
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 201 Post(s)
Liked: 196
Quote:
Originally Posted by lujan View Post

It is now working correctly detecting all three (3) inputs. There are only 3 right. I don't see 4 HDMI inputs? The only problem I have now is when I turn on both the TV and the Echostar 622 satellite receiver, the TV just shows a blue screen. I have to go to another HDMI input and then back to the original HDMI input. It then works fine. Could that be a E* 622 problem and not the TV?

The fourth HDMI should be in the front from a specs sheet I saw at Vann's.

Samsung 65F8000, 60D8000, 40HU6350, Panasonic 50E60 LCD's
westa6969 is online now  
post #18 of 3510 Old 08-30-2007, 06:25 PM
Advanced Member
 
tlbowerts's Avatar
 
Join Date: May 2007
Posts: 584
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
westa6969 is right ,the fourth HDMI is front of tv
tlbowerts is offline  
post #19 of 3510 Old 08-30-2007, 07:27 PM
Member
 
applebonker's Avatar
 
Join Date: Jun 2005
Location: Chicagoland
Posts: 125
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Just went and checked this set out at a somewhat big-box store. I must say the image looked very good (although it's hard to tell when there is only one HD feed and it is split 4 billion ways over component). I just wanted to warn people that the set I saw definitely had a high pitched whine coming from the back (probably the fan and the same issue noted on a fair number of xx734 sets). I have the potential to pick up this tv for a pretty good price along with the stand, so I may be pulling the trigger and hoping to get a set without the fan noise (although I would have 30 days to return it if I were to notice it). Now all I need to do is find a way to sell my mits WD-52725 to offset some of the cost...

Edit: interestingly enough, the 65734 right next to the 833 was silent...
applebonker is offline  
post #20 of 3510 Old 08-30-2007, 07:58 PM
Member
 
jprazak's Avatar
 
Join Date: Apr 2007
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have had my 65833 for two days now. I am very impressed with the picture quality. It recognized my XBox 360 and OPPO DV 980 H. I have an HD indoor antennae and it looks really good. I am waiting for Direct TV to install HD service. There is a high pitched noise that is pretty annoying. I hope that it goes away because it is my only complaint and my wife really notices it. I will break it in this weekend and see if there is any improvement on the noise. The noise stays on for about 1 min after you turn the tv off.

"My wife hates me, so does her boyfriend."
-- The Psychedelic Furs
jprazak is offline  
post #21 of 3510 Old 08-30-2007, 08:19 PM
Member
 
applebonker's Avatar
 
Join Date: Jun 2005
Location: Chicagoland
Posts: 125
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by jprazak View Post

There is a high pitched noise that is pretty annoying. I hope that it goes away because it is my only complaint and my wife really notices it. I will break it in this weekend and see if there is any improvement on the noise. The noise stays on for about 1 min after you turn the tv off.

This is slightly disheartening. Is anyone else having this problem with an 833 set? I think I'm going to order this tv tomorrow which will get it to me on Tuesday. I'm hoping this wont be a mistake.
applebonker is offline  
post #22 of 3510 Old 08-31-2007, 05:17 AM
Member
 
eric2001's Avatar
 
Join Date: Jun 2007
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I unfortunately found a blemish under the protective screen. I think its on the inside of the protective screen, or maybe on the actual screen itself. There were some hand prints from the delivery guys carrying it into my house. I didn't notice it until I got home from work. I thought this blemish was a print as well but I was not able to remove it with my Monster screen cleaner. What do you guys think I should do? It's hard to notice it when watching tv, but when the background is white, or a light color you can definitely tell it is there. I'm thinking about exchanging it. Any feed back is awesome.
eric2001 is offline  
post #23 of 3510 Old 08-31-2007, 06:39 AM
Senior Member
 
usmcss's Avatar
 
Join Date: Oct 2001
Location: ILLINOIS
Posts: 269
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks for starting the thread Lujan; I will be getting my 73833 delivered on the 4th of Sept. I am really sorry to hear that there is an issue with fan or color wheel noise. You would think after all the years of people complaining about this they would have figured a way to fix this problem.

Lujan, do you hear any noise from your set? If it happens on all the sets then it's probably something people have to live with if they want to keep the tv, but if it only happens on some of the sets, then the set it is happening on is faulty.

I guess we also have to take into consideration peoples hearing ability; I have some Freq. lose so I might not even hear it. But the other members of my family would have to put up with it and that's not right.

To the people that are having this issue; do you hear the noise at normal listening levels when watching TV, or is it just when the tv is starting up and shuting down?

I sure hope this can be figured out; I will post what my thoughts are of my TV when I receive it.

Semper Fi,

Bob
usmcss is offline  
post #24 of 3510 Old 08-31-2007, 06:46 AM
Advanced Member
 
tlbowerts's Avatar
 
Join Date: May 2007
Posts: 584
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by eric2001 View Post

I unfortunately found a blemish under the protective screen. I think its on the inside of the protective screen, or maybe on the actual screen itself. There were some hand prints from the delivery guys carrying it into my house. I didn't notice it until I got home from work. I thought this blemish was a print as well but I was not able to remove it with my Monster screen cleaner. What do you guys think I should do? It's hard to notice it when watching tv, but when the background is white, or a light color you can definitely tell it is there. I'm thinking about exchanging it. Any feed back is awesome.

For the money your paying, if your not happy with it ,return it for another, I sure would, no need to put up with it , if you are not happy with it .
tlbowerts is offline  
post #25 of 3510 Old 08-31-2007, 06:54 AM
Advanced Member
 
tlbowerts's Avatar
 
Join Date: May 2007
Posts: 584
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by usmcss View Post

Thanks for starting the thread Lujan; I will be getting my 73833 delivered on the 4th of Sept. I am really sorry to hear that there is an issue with fan or color wheel noise. You would think after all the years of people complaining about this they would have figured a way to fix this problem.

Lujan, do you hear any noise from your set? If it happens on all the sets then it's probably something people have to live with if they want to keep the tv, but if it only happens on some of the sets, then the set it is happening on is faulty.

I guess we also have to take into consideration peoples hearing ability; I have some Freq. lose so I might not even hear it. But the other members of my family would have to put up with it and that's not right.

To the people that are having this issue; do you hear the noise at normal listening levels when watching TV, or is it just when the tv is starting up and shuting down?

I sure hope this can be figured out; I will post what my thoughts are of my TV when I receive it.

It's not on all sets , just some, and on one's that does have it , sometimes it go's away in 2 to 5 days of play, not sure of the % of this, Yes your right! one would think after all these years , they would have very little problems on any of these sets , be it Mit, sony ,etc.
tlbowerts is offline  
post #26 of 3510 Old 08-31-2007, 06:57 AM
Senior Member
 
usmcss's Avatar
 
Join Date: Oct 2001
Location: ILLINOIS
Posts: 269
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by tlbowerts View Post

It's not on all sets , just some, and on one's that does have it , sometimes it go's away in 2 to 5 days of play, not sure of the % of this, Yes your right! one would think after all these years , they would have very little problems on any of these sets , be it Mit, sony ,etc.

That's good to hear tlbowerts; I just started a new thread for people to post whether they are having this issue or not. It will be interesting to see what is posted.

Semper Fi,

Bob
usmcss is offline  
post #27 of 3510 Old 08-31-2007, 09:43 AM
Member
 
applebonker's Avatar
 
Join Date: Jun 2005
Location: Chicagoland
Posts: 125
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
For the record, the set I saw and heard this on was brand spankin' new. It was probably out of the box for about 3 hours by the time I saw it. Not sure if the fan noise will go away after a few days, but I will listen for it tonight when I go in to probably buy my set.

BTW - It sounds like it is the fan as jprazak says the noise continues for about a minute after the set is turned off
applebonker is offline  
post #28 of 3510 Old 08-31-2007, 09:57 AM
Senior Member
 
usmcss's Avatar
 
Join Date: Oct 2001
Location: ILLINOIS
Posts: 269
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by applebonker View Post

For the record, the set I saw and heard this on was brand spankin' new. It was probably out of the box for about 3 hours by the time I saw it. Not sure if the fan noise will go away after a few days, but I will listen for it tonight when I go in to probably buy my set.

BTW - It sounds like it is the fan as jprazak says the noise continues for about a minute after the set is turned off

Be interested to hear what you find out when you go to the store today Applebonker.

Semper Fi,

Bob
usmcss is offline  
post #29 of 3510 Old 08-31-2007, 10:05 AM
Member
 
eric2001's Avatar
 
Join Date: Jun 2007
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
What's the best viewing distance for this set. I'm sitting 10ft, and my wife does not like it.
eric2001 is offline  
post #30 of 3510 Old 08-31-2007, 11:10 AM - Thread Starter
AVS Special Member
 
lujan's Avatar
 
Join Date: Apr 2004
Posts: 2,618
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 26
Quote:
Originally Posted by applebonker View Post

This is slightly disheartening. Is anyone else having this problem with an 833 set? I think I'm going to order this tv tomorrow which will get it to me on Tuesday. I'm hoping this wont be a mistake.

I have noticed the fan but only in a quiet room. It doesn't bother me at all.

lujan
691 Blu-ray
19 HD DVD
6 DVD
lujan is offline  
Reply Rear Projection Units

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off