Older Sony CRT Issue, OSD problem - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 11 Old 08-26-2009, 02:34 AM - Thread Starter
Member
 
Dreamcazman's Avatar
 
Join Date: Jun 2008
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
My mum has one of my hand-me-down TV's that I gave her a few years back, a Sony 59cm KV-XA25M31 and somethings gone funny with it in the last few days, I hope someone here knows what could be wrong and what to fix.

Whenever I try to adjust the volume, enter the menu or anything that involves the OSD, all it shows is the shadow of the text, the solid green lettering is transparent. In fact the menu is even fainter and you can't adjust anything because you can't see what you're doing!

Another thing I noticed also is that when I cycle through the AV inputs, the blue screen is gone (black screen only) and I can't see which input I was on as the text in the top left corner of the screen is not visible.

I hope it's fixable - It's a good TV and she's still quite happy with it, other than the OSD problem, the picture, sound and everything else is perfect.
Dreamcazman is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 09-13-2009, 02:29 AM - Thread Starter
Member
 
Dreamcazman's Avatar
 
Join Date: Jun 2008
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Gee, I must really have a hard fault to fix.

Nearly 200 viewers and no reply.
Dreamcazman is offline  
post #3 of 11 Old 09-14-2009, 08:29 PM
ADU
AVS Special Member
 
ADU's Avatar
 
Join Date: Apr 2003
Posts: 6,368
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 102 Post(s)
Liked: 154
All I can really say is that it sounds like somethin's messed up.

Improperly connected cables can sometimes create weird lookin colors (or no colors) in some cases.

Have you recently connected any new equipment to the TV?

ADU
ADU is offline  
post #4 of 11 Old 09-15-2009, 12:16 AM - Thread Starter
Member
 
Dreamcazman's Avatar
 
Join Date: Jun 2008
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks for a reply ADU, no external devices have been connected to the TV in ages. Thanks for the suggestion on the cables, maybe one of the internal connections isn't making proper contact. I didn't think of that.

I might pull the back off it on the weekend and re-seat all the cables and see how that goes.
Dreamcazman is offline  
post #5 of 11 Old 09-15-2009, 12:21 AM
Advanced Member
 
jdre's Avatar
 
Join Date: Jul 2008
Posts: 614
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I repaired an RCA TV that had a white box where the OSD was, could see faint controls. It was the main IC on that set. I looked up a similar set 24FS120 (yours is australian possibly) and it looks like the OSD is generated there as well.
jdre is offline  
post #6 of 11 Old 09-15-2009, 01:48 PM - Thread Starter
Member
 
Dreamcazman's Avatar
 
Join Date: Jun 2008
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by jdre View Post

I repaired an RCA TV that had a white box where the OSD was, could see faint controls. It was the main IC on that set. I looked up a similar set 24FS120 (yours is australian possibly) and it looks like the OSD is generated there as well.

Yeah it is the Australian model.

Thanks for the tip on the IC, I don't suppose you know the number of the IC in question? Might be worth replacing if it's not too expensive.

btw, anyone know where I can download a free service manual for this TV?
Dreamcazman is offline  
post #7 of 11 Old 09-15-2009, 01:49 PM
ADU
AVS Special Member
 
ADU's Avatar
 
Join Date: Apr 2003
Posts: 6,368
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 102 Post(s)
Liked: 154
Do color bars still look correct on the TV?

ADU
ADU is offline  
post #8 of 11 Old 09-15-2009, 02:08 PM - Thread Starter
Member
 
Dreamcazman's Avatar
 
Join Date: Jun 2008
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by ADU View Post

Do color bars still look correct on the TV?

What do you mean exactly?

TV is still perfect, it's only the 'overlay' if you can call it that of the OSD that's almost invisible. Also the blue back screen doesn't show, it's only black now.
Dreamcazman is offline  
post #9 of 11 Old 09-16-2009, 08:31 PM
ADU
AVS Special Member
 
ADU's Avatar
 
Join Date: Apr 2003
Posts: 6,368
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 102 Post(s)
Liked: 154
ADU is offline  
post #10 of 11 Old 09-16-2009, 10:34 PM
Advanced Member
 
jdre's Avatar
 
Join Date: Jul 2008
Posts: 614
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Here is a free schematic for a Sony 24FS100, might resemble your set enough to get an idea. Also try manualsparadise.com, servicemanuals.net.
jdre is offline  
post #11 of 11 Old 09-16-2009, 11:26 PM - Thread Starter
Member
 
Dreamcazman's Avatar
 
Join Date: Jun 2008
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by ADU View Post

Color bars

I can't get the TV to display the colour bars, it doesn't have the option.

Quote:
Originally Posted by jdre View Post

Here is a free schematic for a Sony 24FS100, might resemble your set enough to get an idea. Also try manualsparadise.com, servicemanuals.net.

Thanks for the link to the manual.

Here are a couple of photos showing what I'm seeing, only really works on a light background otherwise you don't see anything!







The third picture is what's supposed to be the menu. As it is, it's next to impossible to navigate. Very weird.
Dreamcazman is offline  
Reply Direct View (single tube) CRT Displays

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off