Philips 34-inch HDTV--no picture - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 4 Old 12-30-2009, 09:50 AM - Thread Starter
Member
 
Eric's Avatar
 
Join Date: Jul 2000
Location: westlake village, ca
Posts: 159
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have a 34-inch Philips HD tube set; the other day the picture went out. I have audio but literally no picture. The green pilot light does come on; however, clicking on the remote's menu button brings up nothing, so I know the picture is not working.

Also, when I touch the screen I don't feel any static electricity. When I shut the set off, I do NOT see the typical flash of light you get when a set works but you just have the wrong input selected.

I did unplug and replug the set, but nothing changed. Is there anything else I can try short of repair? Is there a way to reset the set itself, to see if that's the problem? The kids were playing with the remote a few days ago and locked me out of the input. When I went to put in the unlock code, I got no picture.

Thanks.
Eric is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 12-30-2009, 05:48 PM
Advanced Member
 
Th3_uN1Qu3's Avatar
 
Join Date: Oct 2008
Location: Bucharest, Romania
Posts: 714
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Flyback or video output transistor is blown. Most likely flyback - if the video output transistor would've failed it usually fails shorted, and the power supply would shut down to protect itself.

Repair shop is your best bet.

Quote:
Originally Posted by Ivan Beaver
The nice thing about standards is that there are so many to choose from.
Th3_uN1Qu3 is offline  
post #3 of 4 Old 12-30-2009, 05:55 PM - Thread Starter
Member
 
Eric's Avatar
 
Join Date: Jul 2000
Location: westlake village, ca
Posts: 159
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks very much for your quick reply. Happy new year from Los Angeles.
Eric is offline  
post #4 of 4 Old 12-30-2009, 08:28 PM
Advanced Member
 
Th3_uN1Qu3's Avatar
 
Join Date: Oct 2008
Location: Bucharest, Romania
Posts: 714
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Happy new year from Bucharest as well.

Quote:
Originally Posted by Ivan Beaver
The nice thing about standards is that there are so many to choose from.
Th3_uN1Qu3 is offline  
Reply Direct View (single tube) CRT Displays

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off