I think i may of just broken my new Sony Wega 27" CRT SDTV..... - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 06-05-2013, 11:17 PM - Thread Starter
AVS Special Member
 
WaveBoy's Avatar
 
Join Date: Aug 2008
Location: Vancouver
Posts: 2,011
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 71 Post(s)
Liked: 39
I'm extremely frustrated right now..... So I got my cousin to pick up a Sony wega 27" CRT off of craigs list for me, when he brang it back he basically sat it down in the hallway and went downstairs. I then rested the TV on a long piece of carpet and slowly dragged the carpet to get the TV in my room....The next thing you know, the TV tips and falls face first/with it's screen right into the ground...

There wasn't any damage to the outside of the screen or anything, but once i hooked it up. The left and right hand of the screen had abnormal lines shooting downwards, looked super blurry combined with a hint of green & yellow....Sigh* everything looks fantastic in the middle area, but the right and left top hand sides are completely messed up. See, i have no idea how the set looked before this but i'm sure it was fine.....Is there ANY way to get this fixed?

I would absolutely hate to have to buy yet another TV Sony wega off of craigs list, let alone the one's that i want are a bit out of my way.... Stupid me for being so careless. Another $40 down the drain. Ugh, i mean this tv has phenomenal picture quality. it's a Sony KV27S100 and is regarded as one of the SD best Sony crt's ever produced....And,i broke it. XP
WaveBoy is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 06-06-2013, 08:15 AM
AVS Special Member
 
Floydage's Avatar
 
Join Date: May 2009
Location: Fort Worth, TX
Posts: 1,472
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 16 Post(s)
Liked: 39
Aside from opening it up and checking connections, especially making sure the board plugged into the back of the picture tube is still fully plugged in, I'd turn it on and off every 10 minutes or so (let degauss circuit cool off between cycles); it may degauss out. Make sure you here the degauss 'boing' as it's possible that coil around the tube broke, or more likely the spring mounting of the coil (which seems like would be an easy fix).
Call me paranoid but I like to open up new arrivals anyway and clean the dust out, and if I'm suspicious of their former environment I let them sit in the garage for several weeks to months (roaches, bedbugs, etc.).

Sorry to hear after all you've been through with the other TV. At least your brother didn't do it.

Floydage is offline  
Reply Direct View (single tube) CRT Displays

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off