Official Epson Home Cinema 3020 Thread - Page 40 - AVS Forum | Home Theater Discussions And Reviews

Forum Jump: 
 7Likes
Reply
 
Thread Tools
post #1171 of 1199 Old 12-03-2015, 10:30 AM
Newbie
 
TimothyPilgrim's Avatar
 
Join Date: Sep 2007
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by klover View Post
$899 today on Amazon.ca
That's where I got mine. Just arrived and am testing it out now!
TimothyPilgrim is offline  
Sponsored Links
Advertisement
 
post #1172 of 1199 Old 12-05-2015, 03:08 PM
Newbie
 
Join Date: Dec 2015
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
in fact after 40 minutes of watching the film began flashing warning light bulb 2:
Lamp and Temp
the last time just shut down - looked the power cord - bad contact
Today, after watching the flashing light bulbs 2
please tell me, who can look?
Perso is offline  
post #1173 of 1199 Old 12-28-2015, 06:09 AM
Newbie
 
vicky007's Avatar
 
Join Date: Dec 2015
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 1
Can anyone tell me the meaning of ... my service menu (long press menu then esc 2 times) showing lamp replacement value is 1...
What does it means....
it a brand new epson projector
vicky007 is offline  
post #1174 of 1199 Old 01-25-2016, 10:02 AM
Newbie
 
Join Date: Jan 2016
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 0
Hi, I just upgraded from my Epson 2030 to a used 3020 this weekend. I was happy with the 2030 for the most part but found it just a little lacking in contrast and excessive in fan noise. Found a decent deal on the 3020 but am wondering about a couple things. For one, I thought the performance with ambient light would be better than with the 2030, but it's actually quite comparable. The other issue is a faint beeping sound that's really only noticeable when the projector is muted... which I do a lot, like whenever a commercial comes on.. and the sound can be annoying. I talked with the PO who said the bulb was aftermarket with 50 to 100 hours on it. So, I'm wondering if this projector would look better than my 2030 with ambient light were I to install a new OEM bulb. Also, I've done a lot of searches on this beeping problem and not much turns up, just enough to suspect it is caused by the aftermarket bulb. Could Epson actually be so sinister to sabotage aftermarket bulbs with this annoying beeping sound, and could this somehow be fixed.. like maybe locating a tiny speaker somewhere and disconnecting it.
Robb2017 is offline  
post #1175 of 1199 Old 01-26-2016, 06:32 PM
Newbie
 
OmiCron07's Avatar
 
Join Date: Jan 2013
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 11
Quote:
Originally Posted by Robb2017 View Post
Hi, I just upgraded from my Epson 2030 to a used 3020 this weekend. I was happy with the 2030 for the most part but found it just a little lacking in contrast and excessive in fan noise. Found a decent deal on the 3020 but am wondering about a couple things. For one, I thought the performance with ambient light would be better than with the 2030, but it's actually quite comparable. The other issue is a faint beeping sound that's really only noticeable when the projector is muted... which I do a lot, like whenever a commercial comes on.. and the sound can be annoying. I talked with the PO who said the bulb was aftermarket with 50 to 100 hours on it. So, I'm wondering if this projector would look better than my 2030 with ambient light were I to install a new OEM bulb. Also, I've done a lot of searches on this beeping problem and not much turns up, just enough to suspect it is caused by the aftermarket bulb. Could Epson actually be so sinister to sabotage aftermarket bulbs with this annoying beeping sound, and could this somehow be fixed.. like maybe locating a tiny speaker somewhere and disconnecting it.
Is it possible you talk about the iris? If yes, you can disable it in the options.
OmiCron07 is offline  
post #1176 of 1199 Old 01-26-2016, 08:16 PM
Newbie
 
Join Date: Jan 2016
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 0
Quote:
Originally Posted by OmiCron07 View Post
Is it possible you talk about the iris? If yes, you can disable it in the options.
No, disabling the iris has no effect on the beeping. It's a faint beeping much like the beeper on heavy equipment when it's put in reverse... but very faint. Just loud enough to be annoying. I ordered an OEM bulb today. I'll report back on whether that fixed the problem. I'm thinking this is the same type of sinister mentality that Epson used by putting chips in their ink cartridges that would make them still read empty if you refilled them yourself. It's called corporate greed.
Robb2017 is offline  
post #1177 of 1199 Old 01-30-2016, 02:04 PM
Newbie
 
Andromidust's Avatar
 
Join Date: Sep 2006
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Robb2017 View Post
No, disabling the iris has no effect on the beeping. It's a faint beeping much like the beeper on heavy equipment when it's put in reverse... but very faint. Just loud enough to be annoying. I ordered an OEM bulb today. I'll report back on whether that fixed the problem. I'm thinking this is the same type of sinister mentality that Epson used by putting chips in their ink cartridges that would make them still read empty if you refilled them yourself. It's called corporate greed.
To address the issue of faint beeping in the Epson 3020, I agree, this is something that doesn't turn up much info on google. I can tell you this: A 3020 I bought used had this issue. When I checked, it had an aftermarket bulb. After changing to an OEM Epson bulb the beeping went away. Yes, I agree with you on your accusations of corporate greed. It certainly looks like Epson intentionally engineered something into this projector that would force you to pay for their outrageously priced bulbs, similar to their underhanded practice of chipping their ink cartridges so they will continue to tell your printer it's low on ink if you refill a cartridge instead of paying for their overpriced OEM cartridge. Sad that they would do both of these things.

Last edited by Andromidust; 01-30-2016 at 02:08 PM.
Andromidust is offline  
post #1178 of 1199 Old 02-18-2016, 08:33 PM
Newbie
 
Join Date: Feb 2016
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
Hey Guys, Love this thread, so i thought i would post my story in here as well -

I had started a thread in the main forum but i will comment in here since this is the official 3020 place to be
I purchased my 3020 PJ December 2014 finished the theater around March 2015 when i started using it. (ceiling mount - 106" screen )
As a 1st time projector user and with nothing really to compare it to the image of this thing blew my mind.
I was more than impressed with the quality and resolution - I hooked up my PS4 to it as well and have 0 lag with any FPS games etc.
After about 10 months 631 hours I noticed a faint blue margin from top to bottom offset from center - reading this forum and others i thought this can only get worse.
I contacted EPSON and they can ONLY provide a refurb at this point since they don't make these new anymore.
My replacement refurb unit showed up the next day as promised but had a dent in the speaker cage which my OCD would not tolerate.
So back in the box it went and on the phone again i went.

This time it got escalated to the 'Advanced Customer Relations' and the person there ensured me that the next unit that is coming will be inspected inside out and quality assurance met, and with a letter included indicating so.

Fingers crossed should be showing up tomorrow or Monday - ( Going on replacement unit # 2 )

Cheers!
Attached Thumbnails
Click image for larger version

Name:	20160217_170051.jpg
Views:	108
Size:	234.7 KB
ID:	1263721  
Angelo L is offline  
post #1179 of 1199 Old 02-22-2016, 02:09 PM
Newbie
 
Join Date: Feb 2016
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
Quote:
Originally Posted by Angelo L View Post
Hey Guys, Love this thread, so i thought i would post my story in here as well -

I had started a thread in the main forum but i will comment in here since this is the official 3020 place to be
I purchased my 3020 PJ December 2014 finished the theater around March 2015 when i started using it. (ceiling mount - 106" screen )
As a 1st time projector user and with nothing really to compare it to the image of this thing blew my mind.
I was more than impressed with the quality and resolution - I hooked up my PS4 to it as well and have 0 lag with any FPS games etc.
After about 10 months 631 hours I noticed a faint blue margin from top to bottom offset from center - reading this forum and others i thought this can only get worse.
I contacted EPSON and they can ONLY provide a refurb at this point since they don't make these new anymore.
My replacement refurb unit showed up the next day as promised but had a dent in the speaker cage which my OCD would not tolerate.
So back in the box it went and on the phone again i went.

This time it got escalated to the 'Advanced Customer Relations' and the person there ensured me that the next unit that is coming will be inspected inside out and quality assurance met, and with a letter included indicating so.

Fingers crossed should be showing up tomorrow or Monday - ( Going on replacement unit # 2 )

Cheers!
Second replacement unit showed up today.

Another issue, this time with the picture.

Called Epson back again, now sending a NEW unit?? thought they didn't make them new anymore ?

well see in a couple days.
Attached Thumbnails
Click image for larger version

Name:	20160222_151450.jpg
Views:	134
Size:	65.8 KB
ID:	1271737  
Angelo L is offline  
post #1180 of 1199 Old 02-26-2016, 11:44 AM
Newbie
 
Join Date: Feb 2016
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
Hey guys,
Just following up ,

Happy to say that they sent me a Brand New Unit ! Original box and all! (thought they didn't make them anymore)
Although they did open the box to remove the 3d glasses.....

Oh well, new PJ is up and working with no issues - Fingers crossed !

Cheers All!
Angelo L is offline  
post #1181 of 1199 Old 08-03-2016, 05:21 PM
Newbie
 
Join Date: Aug 2016
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
Hey Guys new here

Hey, I am having some issues with my 3020. I need to replace the lamp, so I reset lamp hours put in the new lamp, and off I go. Next day I turn it on and it runs for 5 minutes and sounds like an old 80's computer, then lamp flashes. So I repeat procedure and 330 minutes later it running again, so I'm happy. Day 3 press power, runs for 5 and then lamp light flashes. And nothing seems to fix the issue now.

All vents clean and upkept, filter clean, no obstruction, nothing. What happened?

Any help would be greatly appreciated.
Aaron gRIF is offline  
post #1182 of 1199 Old 08-05-2016, 05:00 PM
Advanced Member
 
Nutdotnet's Avatar
 
Join Date: Jan 2004
Posts: 736
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 107 Post(s)
Liked: 41
Quote:
Originally Posted by Aaron gRIF View Post
Hey, I am having some issues with my 3020. I need to replace the lamp, so I reset lamp hours put in the new lamp, and off I go. Next day I turn it on and it runs for 5 minutes and sounds like an old 80's computer, then lamp flashes. So I repeat procedure and 330 minutes later it running again, so I'm happy. Day 3 press power, runs for 5 and then lamp light flashes. And nothing seems to fix the issue now.

All vents clean and upkept, filter clean, no obstruction, nothing. What happened?

Any help would be greatly appreciated.
Issue with the new lamp?
Nutdotnet is offline  
post #1183 of 1199 Old 09-08-2016, 12:24 AM
Senior Member
 
Hagfish's Avatar
 
Join Date: Jul 2003
Location: Dallas, TX
Posts: 410
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 11
Hi all- so I picked up a 3020 last week because it seemed to be a really good deal for a new unit ($799) to replace an aging Epson 7500UB that I inherited from the previous homeowners. The 7500 looked great and served me well for the last couple of years, but the 2nd bulb was starting to dim, and it was also pretty loud. So I thought I'd go for the 3020 as it was one of the best price points for a longer throw (ceiling mounted 15ft onto 100" screen). When I installed the 3020 onto the existing mount and powered it up for the first time, I realized I might be in trouble as the image was not centered on the screen at all. Upon further inspection I realized that the home theater installation company that installed the old 7500 had mounted it about a foot or so offset to the left of the screen. I'm sure they must have had good reason to do this and knew that it wouldn't be a problem since they were installing a projector with lens shift (the 7500).. So, I did some tinkering with the screws on the mount and was able to aim the 3020 a bit to the right, I also had to tilt it down a bit. I thought things were all good until I switched to a station with a bottom scroll (like espn or nfl network) and realized that there was a pretty noticeable left to right slant on the bottom scroll. I've messed around with trying to move the projector a bit on it's axis to fix this, but all that did was fix the bottom slant, and add one to the top of the screen. I played around a bit with the keystone slider, as well as in the settings, I'm not done with tinkering there yet, but I've read that if at all possible not to mess with any of that. I'm just surprised that having to angle the projector just a bit (1 foot) from off center has made things so wacky. Am I missing anything in the settings besides keystone that allows for adjustments? Given that I don't want to redrill a new mount and patch up the old drywall, is this not the projector for me and I should go with one that has lens shift? Maybe keep trying combinations of keystone adjustments? Any cheap-ish mount options to slide the projector back to the right a bit without redrilling? Thanks for any suggestions, I can post pics if it helps with any advice.

Last edited by Hagfish; 09-08-2016 at 12:29 AM.
Hagfish is offline  
post #1184 of 1199 Old 09-08-2016, 06:47 AM
Member
 
Join Date: Feb 2015
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 16 Post(s)
Liked: 1
Calibration

HI All! I have had the Epson 3020 for about a year now and it is absolutely great. I have messed around a bit with calibration after finding various sources of recommended settings online and am now a bit confused as I may have been changing the RGB settings when I should have etc. I would ideally look to reset all of the factory settings and start from scratch. Does anyone have a full calibration setting of their Cinema mode and Dynamic mode. I use Cinema mode for movies and am most concerned with contrast / black levels / accuracy and dynamic mode for games/fights (the biggest concern is colour accuracy). Thanks in advance!
Gazzer55 is offline  
post #1185 of 1199 Old 09-09-2016, 06:41 AM
Senior Member
 
hiperco's Avatar
 
Join Date: Jan 2004
Location: "Greater Binghamton Area"
Posts: 493
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 16
Quote:
Originally Posted by Hagfish View Post
Hi all- so I picked up a 3020 last week because it seemed to be a really good deal for a new unit ($799) to replace an aging Epson 7500UB that I inherited from the previous homeowners. The 7500 looked great and served me well for the last couple of years, but the 2nd bulb was starting to dim, and it was also pretty loud. So I thought I'd go for the 3020 as it was one of the best price points for a longer throw (ceiling mounted 15ft onto 100" screen). When I installed the 3020 onto the existing mount and powered it up for the first time, I realized I might be in trouble as the image was not centered on the screen at all. Upon further inspection I realized that the home theater installation company that installed the old 7500 had mounted it about a foot or so offset to the left of the screen. I'm sure they must have had good reason to do this and knew that it wouldn't be a problem since they were installing a projector with lens shift (the 7500).. So, I did some tinkering with the screws on the mount and was able to aim the 3020 a bit to the right, I also had to tilt it down a bit. I thought things were all good until I switched to a station with a bottom scroll (like espn or nfl network) and realized that there was a pretty noticeable left to right slant on the bottom scroll. I've messed around with trying to move the projector a bit on it's axis to fix this, but all that did was fix the bottom slant, and add one to the top of the screen. I played around a bit with the keystone slider, as well as in the settings, I'm not done with tinkering there yet, but I've read that if at all possible not to mess with any of that. I'm just surprised that having to angle the projector just a bit (1 foot) from off center has made things so wacky. Am I missing anything in the settings besides keystone that allows for adjustments? Given that I don't want to redrill a new mount and patch up the old drywall, is this not the projector for me and I should go with one that has lens shift? Maybe keep trying combinations of keystone adjustments? Any cheap-ish mount options to slide the projector back to the right a bit without redrilling? Thanks for any suggestions, I can post pics if it helps with any advice.
Post pics of your setup. Is moving the screen an option?

Sent from my SAMSUNG-SGH-I337 using Tapatalk
hiperco is offline  
post #1186 of 1199 Old 09-13-2016, 01:20 PM
Senior Member
 
Hagfish's Avatar
 
Join Date: Jul 2003
Location: Dallas, TX
Posts: 410
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 11
Quote:
Originally Posted by hiperco View Post
Post pics of your setup. Is moving the screen an option?

Sent from my SAMSUNG-SGH-I337 using Tapatalk
I'll snap some pics later- but moving the screen is not an option unfortunately as it snugs up right next to the left & right in-wall speakers. Really want to make this thing work but will need to figure something out- as the slanted image will always bug me (although I bet most guests wouldn't even notice). Pics to come later.
Hagfish is offline  
post #1187 of 1199 Old 09-13-2016, 01:30 PM
Member
 
saikatbiswas82's Avatar
 
Join Date: Sep 2012
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 1
Quote:
Originally Posted by Gazzer55 View Post
HI All! I have had the Epson 3020 for about a year now and it is absolutely great. I have messed around a bit with calibration after finding various sources of recommended settings online and am now a bit confused as I may have been changing the RGB settings when I should have etc. I would ideally look to reset all of the factory settings and start from scratch. Does anyone have a full calibration setting of their Cinema mode and Dynamic mode. I use Cinema mode for movies and am most concerned with contrast / black levels / accuracy and dynamic mode for games/fights (the biggest concern is colour accuracy). Thanks in advance!
Don't know whether this would be helpful. You could give it a try.

https://www.avforums.com/index.php?threads/1768486/

Sent from a handheld device. Some typos might creep in.
saikatbiswas82 is online now  
post #1188 of 1199 Old 09-16-2016, 01:24 PM
Senior Member
 
Hagfish's Avatar
 
Join Date: Jul 2003
Location: Dallas, TX
Posts: 410
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 11
Ok- here some shots of the media room. You can see the slant to the right on the bottom of the scroll, and a little bit in the guide pic as well. Do you think this effect is more that I'm having to tilt the projector a bit to the side, or that it's tilted down? Or more than likely, a combination of both? It's hard to tell on the close up of the Epson, but it's mounted on a downslope ceiling. As you can see, the mount is nice and tidy- and I'd really like to not have to redo it. Any suggestions? Please chime in if you do, as the 15 day return period has snuck up on me, and I have to decide if I'm going to return it by tomorrow!

Pano pic of room on dropbox.. too big for AVS attachments..

https://dl.dropboxusercontent.com/u/...3/IMG_0496.JPG
Attached Thumbnails
Click image for larger version

Name:	IMG_0491.jpg
Views:	62
Size:	155.9 KB
ID:	1664545   Click image for larger version

Name:	IMG_0492.jpg
Views:	60
Size:	148.6 KB
ID:	1664553   Click image for larger version

Name:	IMG_0497.jpg
Views:	58
Size:	134.1 KB
ID:	1664561  
Hagfish is offline  
post #1189 of 1199 Old 09-17-2016, 06:51 AM
Senior Member
 
hiperco's Avatar
 
Join Date: Jan 2004
Location: "Greater Binghamton Area"
Posts: 493
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 16
Quote:
Originally Posted by Hagfish View Post
Ok- here some shots of the media room. You can see the slant to the right on the bottom of the scroll, and a little bit in the guide pic as well. Do you think this effect is more that I'm having to tilt the projector a bit to the side, or that it's tilted down? Or more than likely, a combination of both? It's hard to tell on the close up of the Epson, but it's mounted on a downslope ceiling. As you can see, the mount is nice and tidy- and I'd really like to not have to redo it. Any suggestions? Please chime in if you do, as the 15 day return period has snuck up on me, and I have to decide if I'm going to return it by tomorrow!

Pano pic of room on dropbox.. too big for AVS attachments..

https://dl.dropboxusercontent.com/u/...3/IMG_0496.JPG
I really can't see the issue you are referring to. But it seems your choice is to move the mount, or return the unit and get one with lense shift. Lense shift is so liberating

Sent from my SAMSUNG-SGH-I337 using Tapatalk
hiperco is offline  
post #1190 of 1199 Old 09-27-2016, 08:42 PM
Senior Member
 
Hagfish's Avatar
 
Join Date: Jul 2003
Location: Dallas, TX
Posts: 410
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 11
Quote:
Originally Posted by hiperco View Post
I really can't see the issue you are referring to. But it seems your choice is to move the mount, or return the unit and get one with lense shift. Lense shift is so liberating

Sent from my SAMSUNG-SGH-I337 using Tapatalk
Well- it was my lucky day I guess.. I'm sure the 3020 is a great projector- unfortunately it just didn't work with my existing setup unless I would have been willing to go through with some significant mount changes.. Anyways- I saw in one of my daily deals alerts today, that the epson 3500 was on sale at BB today for the same price I got the 3020 ($799).. I called the BB customer service line, and although nice, she pretty much told me I was screwed as I was past the 15 day return policy. I decided to take in the 3020 to my local BB store. They hooked me up with store credit and used it to place an order for the 3500 with lens shift! So, I will be making my way over to that thread- it seems like it will be a really nice projector also. Thanks for the replies!
Hagfish is offline  
post #1191 of 1199 Old 09-27-2016, 09:58 PM
Member
 
saikatbiswas82's Avatar
 
Join Date: Sep 2012
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 1
I'd like to share my experience as well. It's kind of similar to what Hagfish said already.
My brother picked up one 3020 for me 3 weeks back. Due to his credit score, he had 30 day return policy. He was able to exchange the 3020 with 3500 at same price ($799). I'm feeling lucky!
Thanks everyone.

Sent from a handheld device. Some typos might creep in.
saikatbiswas82 is online now  
post #1192 of 1199 Old 10-03-2016, 06:24 AM
Newbie
 
Join Date: Oct 2016
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 0
Exclamation HELP-Epson 3020 Error- Blinking Power Light

I have an epson 3020 off warranty, with 2800 hrs on it.
Recently I started having troubles with it.. sometimes. (not always) I will power up, and the blue power light will blink as normal.. then the bulb DOES NOT light up.. the cooling fan in front runs at MAX speed (noisy) and the unit locks up... after 3-4 min it shuts down.. all the while the blue power light (and no others) was blinking.

I tried replacing the bulb with a KR25 (yeah.. I ordered an osram and they shipped me a clone)
I tried replacing with a Osram bulb same deal

So .. sometimes it will work for a few days.. then it does not light up.. and I unplug it.. let it sit.. .cross my fingers.. and eventually it starts up.

the problem started with the original bulb.. and happens with any bulb I install.

Could it be the ballast? Power supply? Any comments.. Suggestions?
dudinsky is offline  
post #1193 of 1199 Old 10-04-2016, 01:05 AM
Member
 
jopereira's Avatar
 
Join Date: Apr 2008
Posts: 49
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 11
Quote:
Originally Posted by dudinsky View Post
I have an epson 3020 off warranty, with 2800 hrs on it.
Recently I started having troubles with it.. sometimes. (not always) I will power up, and the blue power light will blink as normal.. then the bulb DOES NOT light up.. the cooling fan in front runs at MAX speed (noisy) and the unit locks up... after 3-4 min it shuts down.. all the while the blue power light (and no others) was blinking.

I tried replacing the bulb with a KR25 (yeah.. I ordered an osram and they shipped me a clone)
I tried replacing with a Osram bulb same deal

So .. sometimes it will work for a few days.. then it does not light up.. and I unplug it.. let it sit.. .cross my fingers.. and eventually it starts up.

the problem started with the original bulb.. and happens with any bulb I install.

Could it be the ballast? Power supply? Any comments.. Suggestions?
Seems like temperature control is kicking in. Perhaps a bad contact out circuit fault?
(electrolytics are many times the culprit)

JP
Lisbon, PORTUGAL
jopereira is offline  
post #1194 of 1199 Old 10-09-2016, 11:23 AM
Newbie
 
Join Date: Oct 2016
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 0
Quote:
Originally Posted by jopereira View Post
Seems like temperature control is kicking in. Perhaps a bad contact out circuit fault?
(electrolytics are many times the culprit)
Hmmm.. not surprised. Repaired all sorts of stuff that had bad caps from China..etc.etc.

The over temp light DOES NOT come on... just the blue power light.
I emailed Epson support Canada several times on their website.. guess what.. no reply..

If its the P/S anyone ever change one.. is it accessible.. or burred under everything?

Now it seldom boots up... I have to unplug it over and over.. sometimes 20-30 times.. to get it to boot.

Has anyone ever had this problem? I cannot find a single thing online about this.
Maybe I am the lucky person to get a bad board..
Heck.. only 2700 hours!!! Bought 2 bulbs.. I cannot ditch the unit, as I have almost $1000 in bulbs!!!
(that wont fit much else)

dudinsky is offline  
post #1195 of 1199 Old 10-09-2016, 11:23 AM
Newbie
 
Join Date: Oct 2016
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 0
Quote:
Originally Posted by jopereira View Post
Seems like temperature control is kicking in. Perhaps a bad contact out circuit fault?
(electrolytics are many times the culprit)
Hmmm.. not surprised. Repaired all sorts of stuff that had bad caps from China..etc.etc.

The over temp light DOES NOT come on... just the blue power light.
I emailed Epson support Canada several times on their website.. guess what.. no reply..

If its the P/S anyone ever change one.. is it accessible.. or burred under everything?

Now it seldom boots up... I have to unplug it over and over.. sometimes 20-30 times.. to get it to boot.

Has anyone ever had this problem? I cannot find a single thing online about this.
Maybe I am the lucky person to get a bad board..
Heck.. only 2700 hours!!! Bought 2 bulbs.. I cannot ditch the unit, as I have almost $1000 in bulbs!!!
(that wont fit much else)

dudinsky is offline  
post #1196 of 1199 Old 10-10-2016, 06:55 AM
Senior Member
 
hiperco's Avatar
 
Join Date: Jan 2004
Location: "Greater Binghamton Area"
Posts: 493
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 16
Quote:
Originally Posted by dudinsky View Post
I have an epson 3020 off warranty, with 2800 hrs on it.
Recently I started having troubles with it.. sometimes. (not always) I will power up, and the blue power light will blink as normal.. then the bulb DOES NOT light up.. the cooling fan in front runs at MAX speed (noisy) and the unit locks up... after 3-4 min it shuts down.. all the while the blue power light (and no others) was blinking.

I tried replacing the bulb with a KR25 (yeah.. I ordered an osram and they shipped me a clone)
I tried replacing with a Osram bulb same deal

So .. sometimes it will work for a few days.. then it does not light up.. and I unplug it.. let it sit.. .cross my fingers.. and eventually it starts up.

the problem started with the original bulb.. and happens with any bulb I install.

Could it be the ballast? Power supply? Any comments.. Suggestions?
Sounds like a bad ballast to me. Instead of emailing Epson, try giving them a call. (2800 hours is a lot of hours!)

Sent from my SAMSUNG-SGH-I337 using Tapatalk
hiperco is offline  
post #1197 of 1199 Old 10-10-2016, 07:23 AM
Newbie
 
Join Date: Oct 2016
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 0
Quote:
Originally Posted by hiperco View Post
Sounds like a bad ballast to me. Instead of emailing Epson, try giving them a call. (2800 hours is a lot of hours!)

Sent from my SAMSUNG-SGH-I337 using Tapatalk
Will do..
Q: does the 3020 have a separate ballast? or is it on the main P/S board.
dudinsky is offline  
post #1198 of 1199 Old 10-10-2016, 09:29 AM
Senior Member
 
hiperco's Avatar
 
Join Date: Jan 2004
Location: "Greater Binghamton Area"
Posts: 493
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 16
Quote:
Originally Posted by dudinsky View Post
Will do..
Q: does the 3020 have a separate ballast? or is it on the main P/S board.
I can't say, I've never had mine apart
hiperco is offline  
post #1199 of 1199 Old 11-11-2016, 12:07 PM
exm
AVS Special Member
 
exm's Avatar
 
Join Date: Aug 2001
Location: NYY
Posts: 1,434
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 85 Post(s)
Liked: 79
I sold my 3020 projector. Received a message that there's a pink/red bar on top. Lamp is a genuine Epson lamp with 4,000+ hours. Would a new lamp solve this, or is there another issue?

exm is offline  
Sponsored Links
Advertisement
 
Reply Digital Projectors - Under $3,000 USD MSRP

Tags
Epson , Epson Projector , Epson V11h501020 Powerlite Home Cinema 3020 2d And 3d Home Theater Projector , Epson V11h502020 Powerlite Home Cinema 3020e 2d And 3d 1080p Wireless Home Theater Projector
Gear in this thread



Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off