BenQ W1070 : DLP Full HD, 3D Ready with lens-shift for 1000$ - Page 388 - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!



Forum Jump: 
 375Likes
 
Thread Tools
Old 12-01-2015, 01:33 PM
Member
 
Join Date: May 2015
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Liked: 3
Quote:
Originally Posted by draco159 View Post
No problem! Yeah, you could go into the attic, attach one small piece of wood to fill between the joists at your mounting location, then just mount the rpm to ceiling directly with screws going into that piece of wood.

The mount comes with a universal flat plate thing that you bolt to the projector. It's around an inch thick I believe, but I will take a picture when I get home this evening with a ruler so you can see.
Good idea, I have to get in the attic anyway to run a hdmi cable. A pic would be awesome. Thanks.
hawk4 is offline  
Sponsored Links
Advertisement
 
Old 12-01-2015, 01:35 PM
Member
 
wayne picard's Avatar
 
Join Date: Jun 2002
Location: canada
Posts: 124
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 10
Over the last 10 years I have purchased two lamps from Projector Lamp Source. Most recently it was for my 1070 which I got on sale about a year ago. Both lamps have been great. I would suggest installing it when received so you use it during the warranty period and saving the old lamp as a spare for emergencies. The first lamp was for a rear projection TV which is used daily and it is still going strong.
wayne picard is offline  
Old 12-01-2015, 01:48 PM
AVS Special Member
 
Rew452's Avatar
 
Join Date: Feb 2003
Posts: 1,072
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 93 Post(s)
Liked: 57
Quote:
Originally Posted by chmcke01 View Post
Thanks, I will do some looking this time and order one that seems legit (probably the one you got). I want to order ASAP since AliExpress says it takes a couple weeks for delivery and I will just hope I don't get screwed on the one I am sending back. That's what I get for ordering at 1am! I saw that 5500 hours and sort of freaked out that it wouldn't make it until the new bulb came even though it has been fine so far.
This the one I used: http://www.aliexpress.com/item/Origi...i5ern&af=73669

Cheers
gonzo90017 likes this.

Rew
Vizio P75-C1 | BenQ HT2050 |Lumagen RadianceXS-3D |Panasonic BDT460 | Samsung UBD-K8500
Denon AVR-x5200w | Nvidia Shield Android TV | C =Axiom VP150 |FL/FR =Axiom M60 |SL/SR =Axiom QS4 |TFL/TFR =Bose 161 | TRL/TRR =Bose 161 |Sub =Reaction Audio S-15 500W SEALED SUBWOOFER
Rew452 is online now  
Old 12-01-2015, 03:44 PM
Senior Member
 
bigcat's Avatar
 
Join Date: Dec 2004
Location: Columbus, Ohio
Posts: 404
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 86 Post(s)
Liked: 26
Thanks. So what's the link to order the full assembly (original genuine recommended benq oem), not just the lamp?

BenQ W1070/Silver Ticket 120"/Denon X4200W/Infinity Primus | Vizio 80" 3D LED M801D-A3 w/ Denon X3200W/Infinity Primus | Sony Bravia XBR-60LX900 w/ Sony HTCT550W 3D Sound Bar | Sony SXRD KDS-R70XBR2 w/ Onkyo HT-S770 | Sony PS3 (Slim) | DIRECTV Genie HR44-500, C41s | Harmony 700
bigcat is offline  
Old 12-01-2015, 03:58 PM
AVS Special Member
 
Rew452's Avatar
 
Join Date: Feb 2003
Posts: 1,072
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 93 Post(s)
Liked: 57
Yes, it is the Lamp, not a lamp assembly. Using your current assembly and remove old lamp; then install the new one.

Rew
Vizio P75-C1 | BenQ HT2050 |Lumagen RadianceXS-3D |Panasonic BDT460 | Samsung UBD-K8500
Denon AVR-x5200w | Nvidia Shield Android TV | C =Axiom VP150 |FL/FR =Axiom M60 |SL/SR =Axiom QS4 |TFL/TFR =Bose 161 | TRL/TRR =Bose 161 |Sub =Reaction Audio S-15 500W SEALED SUBWOOFER
Rew452 is online now  
Old 12-03-2015, 06:47 AM
Member
 
chmcke01's Avatar
 
Join Date: Jun 2012
Posts: 111
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 31 Post(s)
Liked: 15
Hopefully

I ended up getting this one:

http://www.aliexpress.com/item/Free-...825057615.html

One of the people on the bare bulb replacement thread said thats the one they got and they were happy with it, it had good reviews, SAID it was an OEM bulb, and some of the reviews specifically said that it looked identical to the one they were replacing...so I gave it a shot. I guess I will find out in 2-3 weeks when it arrives from China, lol.
chmcke01 is offline  
Old 12-03-2015, 05:34 PM
Senior Member
 
wyattroa's Avatar
 
Join Date: Jan 2007
Location: Lombard, IL
Posts: 471
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 162 Post(s)
Liked: 115
On the projectorcentral site I am showing an FL of 26. Is this on the highest lamp setting, would putting it down to eco make this better? My room will have ambient light, but will this be too strong for my and my wifes eyes. The throw would be 12ft, sitting 11ft back from a 110in screen.

Sub build http://www.avsforum.com/forum/155-di...et-r-done.html
Center - JBL LC2
Mains - JBL L820
Surrounds - JBL L820
Sub - Dual UXL'18 enclosures,iNuke6000dsp
wyattroa is offline  
Old 12-04-2015, 06:32 AM
AVS Special Member
 
kreeturez's Avatar
 
Join Date: Apr 2013
Posts: 1,243
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 448 Post(s)
Liked: 340
Quote:
Originally Posted by wyattroa View Post
On the projectorcentral site I am showing an FL of 26. Is this on the highest lamp setting, would putting it down to eco make this better? My room will have ambient light, but will this be too strong for my and my wifes eyes. The throw would be 12ft, sitting 11ft back from a 110in screen.

Those listings aren't that accurate... But indeed, that's at full power. Eco will drop it by 30%; turning off BrilliantColor will drop it by a further 10% or so.

I ran in Eco on a neutral-gain white screen (at the same size as you) for a good while and brightness was comfortable. For a bit of ambient light, the extra lumens in SmartEco lamp mode (or Normal - they're the same level of brightness) will probably be useful to you.

BenQ HT2050 Projector; Kodi (on Ubuntu, OpenELEC & S802) via Sony STR-DH540 AVR with Boston Acoustics SoundWare XS SE 5.1 Audio + Jamo 210 Sub. Emby for Mobile Streaming.

Helpful post? Click the 'Like' button!
kreeturez is offline  
Old 12-04-2015, 08:30 PM
Newbie
 
Join Date: Dec 2015
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
My w1070 case exhaust fan is starting to seize. Will replace it soon.

My lamp blower was 50% clogged and I thnk theres an input case fan temp sensor that was completely covered in dust.

The I/P, lamp blower and lamp exhaust all spin smooth.

I still have the whir rattle sound.
at0mx is offline  
Old 12-09-2015, 02:45 PM
Member
 
Join Date: Oct 2015
Posts: 159
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 88 Post(s)
Liked: 10
I just installed my Benq 1070 and I am projecting to a 110" 16x9 screen.

What Aspect ratio should I be using? I have it on Anamorphic now, is that right?

Secondly, once I have it on the right input, will it stay on this input when I am watching movies, tv, and gaming or will I have to change it depending on what I am watching?
BleedingBlue is offline  
Old 12-10-2015, 11:59 AM
AVS Special Member
 
kreeturez's Avatar
 
Join Date: Apr 2013
Posts: 1,243
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 448 Post(s)
Liked: 340
BenQ W1070 : DLP Full HD, 3D Ready with lens-shift for 1000$

Quote:
Originally Posted by BleedingBlue View Post
I just installed my Benq 1070 and I am projecting to a 110" 16x9 screen.

What Aspect ratio should I be using? I have it on Anamorphic now, is that right?

Depending on what the input resolution is, it'll look the same: but generally stick to 'Auto' on a regular 16x9 screen. Or 'real'. Both will prevent unwanted rescaling of the image.
BleedingBlue likes this.

BenQ HT2050 Projector; Kodi (on Ubuntu, OpenELEC & S802) via Sony STR-DH540 AVR with Boston Acoustics SoundWare XS SE 5.1 Audio + Jamo 210 Sub. Emby for Mobile Streaming.

Helpful post? Click the 'Like' button!
kreeturez is offline  
Old 12-10-2015, 03:37 PM
Member
 
Join Date: Oct 2015
Posts: 159
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 88 Post(s)
Liked: 10
Quote:
Originally Posted by kreeturez View Post
Depending on what the input resolution is, it'll look the same: but generally stick to 'Auto' on a regular 16x9 screen. Or 'real'. Both will prevent unwanted rescaling of the image.

Thanks!


Sent from my iPhone using Tapatalk
BleedingBlue is offline  
Old 12-10-2015, 03:38 PM
Member
 
Join Date: Oct 2015
Posts: 159
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 88 Post(s)
Liked: 10
New question: Does anyone have any calibration settings for the 1070?


Sent from my iPhone using Tapatalk
BleedingBlue is offline  
Old 12-11-2015, 07:52 AM
Senior Member
 
ocZZZZ's Avatar
 
Join Date: Feb 2006
Location: East
Posts: 226
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 11
I need to do a hard factory reset from the service menu but not able to find where to do this on the w1070. Is anyone able to post instructions on doing a hard reset?

..

ocZZZZ is offline  
Old 12-11-2015, 09:13 AM
Member
 
Renron's Avatar
 
Join Date: Jan 2007
Posts: 108
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 25 Post(s)
Liked: 30
Quote:
Originally Posted by BleedingBlue View Post
I just installed my Benq 1070 and I am projecting to a 110" 16x9 screen.

What Aspect ratio should I be using? I have it on Anamorphic now, is that right?

Secondly, once I have it on the right input, will it stay on this input when I am watching movies, tv, and gaming or will I have to change it depending on what I am watching?

I have the same size screen and I use the "Real" setting. It always stay on that one when changing inputs. I change inputs on my receiver which outputs to ONE HDMI cable to the projector. Easy to switch between devices that way. Automatically detects 3D as well.
Ron

"New Member" since 2007....
Renron is offline  
Old 12-13-2015, 06:50 AM
Senior Member
 
Join Date: Feb 2015
Posts: 219
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 137 Post(s)
Liked: 9
i own a benq ht1085st, pretty much a short throw version of the w1070, and i couldn't be happier with my purchase, it's a fantastic budget projector.... the thing is it takes a while for the projected image to reach its full beauty, which i believe is normal for projectors, they take a bit of time to warm up... my question is, can projectors be warmed up with "eco blank" (or the like) engaged, can they be warmed up with the projected image "masked"? intuitively i'd say the answer is no, projectors need to shoot out light and color during the warm-up period, "eco blank won't do the trick, but i'm wondering if just giving the bulb a chance to warm up, with eco blank engaged, would suffice? bottom line, i would like to start a movie in its full glory, without having to stream in lesser quality until the projector reaches its full potential...
aeneas01 is offline  
Old 12-13-2015, 09:26 AM
Senior Member
 
wyattroa's Avatar
 
Join Date: Jan 2007
Location: Lombard, IL
Posts: 471
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 162 Post(s)
Liked: 115
is there any reason to get the 1075 over the 1070?

Sub build http://www.avsforum.com/forum/155-di...et-r-done.html
Center - JBL LC2
Mains - JBL L820
Surrounds - JBL L820
Sub - Dual UXL'18 enclosures,iNuke6000dsp
wyattroa is offline  
Old 12-13-2015, 11:35 AM
Member
 
Join Date: Oct 2015
Posts: 159
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 88 Post(s)
Liked: 10
Quote:
Originally Posted by wyattroa View Post
is there any reason to get the 1075 over the 1070?
The major difference in my research was the ability to have wireless HDMI. I ended up getting the 1070.
BleedingBlue is offline  
Old 12-13-2015, 11:37 AM
Member
 
Join Date: Oct 2015
Posts: 159
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 88 Post(s)
Liked: 10
Does the 1070 have picture in picture? There is a button on the remote, but it does nothing when I press it. I also couldn't find anything in the user manual regarding pip either.

Thanks!
BleedingBlue is offline  
Old 12-14-2015, 07:47 AM
AVS Special Member
 
kreeturez's Avatar
 
Join Date: Apr 2013
Posts: 1,243
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 448 Post(s)
Liked: 340
Quote:
Originally Posted by BleedingBlue View Post
Does the 1070 have picture in picture? There is a button on the remote, but it does nothing when I press it. I also couldn't find anything in the user manual regarding pip either.

Thanks!
I don't believe so. PIP isn't often implemented on inexpensive displays (and when it is, it's often limited to analog sources).

The button is on the remote because that's not the original remote: BenQ started shipping their higher-end remotes with the unit (the one that's nice and back-lit) rather than the cheap ugly one it launched with (which looked like the one in this review.) Much better!

BenQ HT2050 Projector; Kodi (on Ubuntu, OpenELEC & S802) via Sony STR-DH540 AVR with Boston Acoustics SoundWare XS SE 5.1 Audio + Jamo 210 Sub. Emby for Mobile Streaming.

Helpful post? Click the 'Like' button!
kreeturez is offline  
Old 12-14-2015, 08:05 PM
Member
 
los3088's Avatar
 
Join Date: Dec 2006
Posts: 78
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 19 Post(s)
Liked: 13
Hmm. I thought the PIP feature could be engaged when you have at least two sources connected directly to the pj. The 1070 has multiple inputs along with two hdmi inputs.

Perhaps not..?

___________________________________________

"Believe none of what you hear and half of what you see" –Tony Soprano

Last edited by los3088; 12-14-2015 at 08:08 PM.
los3088 is offline  
Old 12-15-2015, 06:04 PM
Member
 
Join Date: Mar 2015
Posts: 95
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 42 Post(s)
Liked: 2
I am not sure if any of you guys experienced this, I have this weird black and yellow line on the picture (seems like something is stuck inside the lens maybe). I have attached the picture, any idea what is wrong? Thanks in advance.


Top right part of the screen


achohan is offline  
Old 12-18-2015, 09:55 PM
Senior Member
 
wyattroa's Avatar
 
Join Date: Jan 2007
Location: Lombard, IL
Posts: 471
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 162 Post(s)
Liked: 115
how is the 3d on these?

Sub build http://www.avsforum.com/forum/155-di...et-r-done.html
Center - JBL LC2
Mains - JBL L820
Surrounds - JBL L820
Sub - Dual UXL'18 enclosures,iNuke6000dsp
wyattroa is offline  
Old 12-18-2015, 10:08 PM
AVS Special Member
 
petetherock's Avatar
 
Join Date: Jun 2006
Location: Down Under
Posts: 2,495
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 946 Post(s)
Liked: 386
I finally switched on my 1070, watched Star Wars I - the one with Anakin, and my oh my, am I pleased
I know some have knocked it's blacks, but it's pretty fine by me, and I have two Pioneer plasmas!
For $560 (sale), it was a good price and even on my cheesy manual pull-down screen, it was mighty impressive!


Now it's a long thread, but can anyone point me to some easy to input settings that I can employ please?

Thanks!
petetherock is online now  
Old 12-19-2015, 01:37 AM
AVS Special Member
 
dreamer's Avatar
 
Join Date: May 2000
Location: Walnut, CA, USA
Posts: 2,861
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 851 Post(s)
Liked: 217
Quote:
Originally Posted by petetherock View Post
I finally switched on my 1070, watched Star Wars I - the one with Anakin, and my oh my, am I pleased
I know some have knocked it's blacks, but it's pretty fine by me, and I have two Pioneer plasmas!
For $560 (sale), it was a good price and even on my cheesy manual pull-down screen, it was mighty impressive!


Now it's a long thread, but can anyone point me to some easy to input settings that I can employ please?

Thanks!
My own original W1070 settings
petetherock likes this.

*********************
Kirk Ellis
BenQ W1070 VuTec 122" Screen
Harmon Kardon AVR 247 Parasound L&R Amp
Psycoustic Mark III L&R Towers, Boston Center
Energy Take 5 Surrounds, HSU Research Sub
dreamer is offline  
Old 12-19-2015, 10:28 AM
AVS Special Member
 
kreeturez's Avatar
 
Join Date: Apr 2013
Posts: 1,243
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 448 Post(s)
Liked: 340
Quote:
Originally Posted by petetherock View Post
I finally switched on my 1070, watched Star Wars I - the one with Anakin, and my oh my, am I pleased
I know some have knocked it's blacks, but it's pretty fine by me, and I have two Pioneer plasmas!
Good you're enjoying... You can't get a combination of better black levels at these brightness levels than you can with RGB-DLP projectors (such as this one) - without spending about 2-3x what you did.

Not that I wouldn't mind even better... Just not ready to pay for it quite yet


Quote:
Originally Posted by petetherock View Post
For $560 (sale), it was a good price and even on my cheesy manual pull-down screen, it was mighty impressive!

Good price. Where was this sale from?


Remember to switch your lamp to either SmartEco (if you want the same brightness as Normal mode) or Eco (if you want less brightness) to maximize lamp life.

BenQ HT2050 Projector; Kodi (on Ubuntu, OpenELEC & S802) via Sony STR-DH540 AVR with Boston Acoustics SoundWare XS SE 5.1 Audio + Jamo 210 Sub. Emby for Mobile Streaming.

Helpful post? Click the 'Like' button!
kreeturez is offline  
Old 12-19-2015, 02:12 PM
AVS Special Member
 
petetherock's Avatar
 
Join Date: Jun 2006
Location: Down Under
Posts: 2,495
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 946 Post(s)
Liked: 386
Quote:
Originally Posted by kreeturez View Post



Good price. Where was this sale from?


Remember to switch your lamp to either SmartEco (if you want the same brightness as Normal mode) or Eco (if you want less brightness) to maximize lamp life.
Thanks, there was some almost new unit on Amazon, that I snapped up - including tax, it was around that price.
petetherock is online now  
Old 12-22-2015, 09:23 AM
Senior Member
 
ATAD IO's Avatar
 
Join Date: Jun 2005
Location: Kentucky
Posts: 217
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Hi:


My W1070 seems to be overheating, I have been using high altitude mode to get buy but the issue needs fixed. I have inspected the fans and they all turn but they would be my first suspect for causing the issue. Inside the unit have very little dust and the unit has 2400 hours on it. With lower fan speed setting the colors get messed up and such. I have tested everything up to the projector and determined it was overheating somewhere.


Thanks,

May I have some more Snake OIL Please?
ATAD IO is offline  
Old 12-22-2015, 10:17 AM
AVS Special Member
 
garciab's Avatar
 
Join Date: Aug 2001
Location: Princeton, TX - USA
Posts: 1,256
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 103 Post(s)
Liked: 48
I've read here that there is a hidden fan...maybe it has failed and is causing your problem? I believe it's the one that cools the lamp, and is a squirrel-cage type.

bg
garciab is offline  
Old 12-22-2015, 11:56 AM
Senior Member
 
ATAD IO's Avatar
 
Join Date: Jun 2005
Location: Kentucky
Posts: 217
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Quote:
Originally Posted by garciab View Post
I've read here that there is a hidden fan...maybe it has failed and is causing your problem? I believe it's the one that cools the lamp, and is a squirrel-cage type.


thanks, I found 3 when I was in there (one larger one-front and two-sides) and they were ok. I greased the front fan. Never thought about 4 fans though.

May I have some more Snake OIL Please?
ATAD IO is offline  
Sponsored Links
Advertisement
 
 

Tags
Benq W1070 1080p 3d Projector
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off