Epson 5020UB Owners Thread... - Page 53 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 35Likes
Reply
 
Thread Tools
post #1561 of 1590 Old 07-18-2016, 06:30 AM
Senior Member
 
Gates's Avatar
 
Join Date: May 2003
Posts: 471
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 193 Post(s)
Liked: 74
My bulb has 4857 hours on it and I ordered one of those OEM, so I will let you guys know how it goes.

JVC DLA-400RS, Elunevision 120" 2:35 Cinemascope AT screen, Marantz AV8802a Pre/Pro, Samsung UBD-K8500 UHD player, OPPO UDP-203, NAD M25 amp, Anthem PVA-4, 4x Paradigm CI Elite E80-R ceiling speakers, Paradigm Studio 60 v5, Paradigm Studio 20 v5, Paradigm Prestige 15B, Paradigm Studio CC-690 v5, Paradigm Studio Sub12 X 2, Richard Gray 1200c Custom power conditioner.
Gates is offline  
Sponsored Links
Advertisement
 
post #1562 of 1590 Old 07-20-2016, 06:17 AM
AVS Forum Special Member
 
Kadath's Avatar
 
Join Date: Oct 2005
Posts: 1,435
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 389 Post(s)
Liked: 271
Quote:
Originally Posted by Kadath View Post
I'd get a refund. This issue has really soured me on Epson, I cannot in good faith recommend any Epson PJs after this...
And now mine is fully and truly dead, double red blinking lights. I'm having the authorized service center who 'fixed' mine last time take a look at it again but I don't have high hopes for a positive resolution. Stay tuned.

Buncha savages in this town....

Sam Posten
Kadath is offline  
post #1563 of 1590 Old 07-23-2016, 05:38 PM
Member
 
Join Date: Jun 2016
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 4
Thanks.
Flapirate is offline  
 
post #1564 of 1590 Old 07-26-2016, 11:14 AM
Senior Member
 
Gates's Avatar
 
Join Date: May 2003
Posts: 471
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 193 Post(s)
Liked: 74
I got one of those OEM bulbs and so far so good!

JVC DLA-400RS, Elunevision 120" 2:35 Cinemascope AT screen, Marantz AV8802a Pre/Pro, Samsung UBD-K8500 UHD player, OPPO UDP-203, NAD M25 amp, Anthem PVA-4, 4x Paradigm CI Elite E80-R ceiling speakers, Paradigm Studio 60 v5, Paradigm Studio 20 v5, Paradigm Prestige 15B, Paradigm Studio CC-690 v5, Paradigm Studio Sub12 X 2, Richard Gray 1200c Custom power conditioner.
Gates is offline  
post #1565 of 1590 Old 07-26-2016, 11:30 AM
Senior Member
 
Gabre's Avatar
 
Join Date: Jul 2008
Posts: 240
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 162 Post(s)
Liked: 24
How to measure light luminance output of the bulb? And I have this strange problem of half of the screen having bluis tint, and other side pinkish/warm tint? With each bulb diferent, all oem.
Gabre is offline  
post #1566 of 1590 Old 08-01-2016, 08:48 PM
Senior Member
 
Gabre's Avatar
 
Join Date: Jul 2008
Posts: 240
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 162 Post(s)
Liked: 24
Me again, I cant understand whats going on here, why is there such a huge difference in color temperature from left and right side of the image.
Imagw attached
Gabre is offline  
post #1567 of 1590 Old 08-01-2016, 09:52 PM
DTI
Member
 
DTI's Avatar
 
Join Date: Jul 2008
Location: Vancouver BC
Posts: 114
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 25 Post(s)
Liked: 20
Gabre I don't think that has anything to do with your bulb maybe your panels ,just a thought

DIY dust box / hush box / ceiling light... http://imagizer.imageshack.us/v2/640...633/7qBblE.jpg
DTI is offline  
post #1568 of 1590 Old 11-07-2016, 05:20 PM
Member
 
Bob Benson's Avatar
 
Join Date: Jan 2004
Location: Parsippany, NJ
Posts: 136
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 23 Post(s)
Liked: 20
I'm moving my setup to a slightly more dedicated space sometime soon hopefully.

Currently I am using a rear shelf mount. For the new setup I am probably going with a ceiling mount. Can anyone recommend a good generic that fits well? The official one seems way over priced.

XBL Gamertag - PVT Hicks
Bob Benson is offline  
post #1569 of 1590 Old 11-08-2016, 07:16 AM
AVS Forum Special Member
 
PM-Performance's Avatar
 
Join Date: Oct 2008
Posts: 1,143
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 255 Post(s)
Liked: 146
Quote:
Originally Posted by Bob Benson View Post
I'm moving my setup to a slightly more dedicated space sometime soon hopefully.

Currently I am using a rear shelf mount. For the new setup I am probably going with a ceiling mount. Can anyone recommend a good generic that fits well? The official one seems way over priced.
I am using a cheap Mustang Mount from Amazon. I think it was $25 maybe. Supports mine fine.

Klipsch RF-82|RC-62|RS-52|RB-51, 2 Ultimax 18's in Marty Cabs Powered by Inuke 6000DSP|
Denon AVR-X4000|Oppo BDP-103|Epson 5020UB with Elite SableFrame 110"|
4 Aura Bass Shakers powered by Dayton PSA-250|4 Seatcraft 5131 seats
PM-Performance is offline  
post #1570 of 1590 Old 11-27-2016, 05:53 PM
Senior Member
 
Modicen's Avatar
 
Join Date: Jan 2010
Location: R.I.
Posts: 317
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 94 Post(s)
Liked: 43
Well after 2 1/2 years and 1052 hours my 5020 got the double blinking redlights. I bought it refurb from visual apex. I tried switching out the bulb with a new one but still no go. Anybody got any ideas what it might be? Is it worth taking to a authorized service center for repair? Any help would be appreciated.
Modicen is online now  
post #1571 of 1590 Old 12-01-2016, 09:33 PM
Senior Member
 
Gabre's Avatar
 
Join Date: Jul 2008
Posts: 240
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 162 Post(s)
Liked: 24
God damnit, mine just died with two red blinking lights.

And it was just 2 months ago that I had it serviced for dead power supply fan, and new bulb.. $750

And now this. What a piece of junk.

Im so upset
Modicen likes this.
Gabre is offline  
post #1572 of 1590 Old 12-02-2016, 04:10 AM
Senior Member
 
Modicen's Avatar
 
Join Date: Jan 2010
Location: R.I.
Posts: 317
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 94 Post(s)
Liked: 43
My crapped out with just over 1000 hrs. I will not by Epson again.
Modicen is online now  
post #1573 of 1590 Old 12-02-2016, 02:53 PM
Senior Member
 
Dr. Crash's Avatar
 
Join Date: Oct 2009
Posts: 262
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
Liked: 13
Hi,

I have a new-to-me refurbished Epson 5020UB I got about a month ago. Today, while my daughter was watching a show, the projector stopped displaying anything. You could see some very dim light from the bulb, but it wouldn't display its source, and it would also not respond to me hitting MENU on the remote.

Is that something that is known/has been seen? Should I call Epson and see if they have another unit under their warranty? If they don't, what do they do warranty-wise?
Dr. Crash is offline  
post #1574 of 1590 Old 12-02-2016, 03:23 PM
Senior Member
 
Gabre's Avatar
 
Join Date: Jul 2008
Posts: 240
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 162 Post(s)
Liked: 24
Ur lucky you have warranty.

Allthough, mine started working again after I unplugged it for couple minutes

Well see tonight what happens

Last edited by Gabre; 12-02-2016 at 04:04 PM.
Gabre is offline  
post #1575 of 1590 Old 12-02-2016, 05:15 PM
Senior Member
 
Dr. Crash's Avatar
 
Join Date: Oct 2009
Posts: 262
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
Liked: 13
After some more troubleshooting, it looks like it might be the HDMI 2 input on my receiver that is failing. Good thing I have many inputs.

RE: the warranty, yes, though while everybody says how good Epson "we'll ship you a projector" warranty is, the warranty actually says exchange or repair at their option, and repairs puts shipping costs to a repair center on you both ways (easily $60-$80). And given that I have a refurb of a unit made four years ago, there may not be any exchange possibility, really... We'll see if I need to use it.
Dr. Crash is offline  
post #1576 of 1590 Old 12-02-2016, 05:33 PM
Senior Member
 
Gabre's Avatar
 
Join Date: Jul 2008
Posts: 240
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 162 Post(s)
Liked: 24
They are so expensive, and have such a big failure rate. How is the new 5040, is there anything substantially doferent in picture quality, i dont care about new features
alamez likes this.
Gabre is offline  
post #1577 of 1590 Old 12-03-2016, 11:21 AM
Senior Member
 
Dr. Crash's Avatar
 
Join Date: Oct 2009
Posts: 262
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
Liked: 13
They do fail. My first one failed just a bit after 3 years and only 1500 hours. The 5020UB refurb was $1100 which was cheaper than repairing the 3020 (for basically what I had paid originally). I bought this one with a card that adds two years of warranty. I am willing to pay $275/year for a 100 inches screen and not having a TV in my living room.
Dr. Crash is offline  
post #1578 of 1590 Old 12-20-2016, 08:53 AM
Senior Member
 
Gabre's Avatar
 
Join Date: Jul 2008
Posts: 240
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 162 Post(s)
Liked: 24
Its still in service, they cant make it to fail again, allthough they its showing six errors, 4 fan errors and two motherboard errors.
Im hoping that its one of the fans, so motherboard is accting up, otherwise, its not worth fixing because of the cost of mbo.
Son of a ....

Whats out there worth looking at, from budget projectors, as I cant spend $3500 CAD on ANOTHER epson.

Sent from my Pixel XL
Gabre is offline  
post #1579 of 1590 Old 02-13-2017, 04:42 PM
Advanced Member
 
jtenn's Avatar
 
Join Date: Dec 2005
Posts: 707
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
Liked: 17
Quote:
Originally Posted by Kadath View Post
And now mine is fully and truly dead, double red blinking lights. I'm having the authorized service center who 'fixed' mine last time take a look at it again but I don't have high hopes for a positive resolution. Stay tuned.
What did you ever find out? Mine worked fine last night and now today I've got the 2 red blinking lights.

jtenn is offline  
post #1580 of 1590 Old 02-18-2017, 06:58 PM
AVS Forum Special Member
 
Kadath's Avatar
 
Join Date: Oct 2005
Posts: 1,435
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 389 Post(s)
Liked: 271
Quote:
Originally Posted by jtenn View Post
What did you ever find out? Mine worked fine last night and now today I've got the 2 red blinking lights.
I paid $400 or so to have it fixed by an authorized repair place. Working fine now.

Buncha savages in this town....

Sam Posten
Kadath is offline  
post #1581 of 1590 Old 02-20-2017, 01:19 PM
Advanced Member
 
jtenn's Avatar
 
Join Date: Dec 2005
Posts: 707
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
Liked: 17
Quote:
Originally Posted by Kadath View Post
I paid $400 or so to have it fixed by an authorized repair place. Working fine now.
What did they do to fix it?

jtenn is offline  
post #1582 of 1590 Old 02-20-2017, 03:19 PM
Senior Member
 
Modicen's Avatar
 
Join Date: Jan 2010
Location: R.I.
Posts: 317
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 94 Post(s)
Liked: 43
Quote:
Originally Posted by jtenn View Post
What did they do to fix it?
Quote:
Originally Posted by Kadath View Post
I paid $400 or so to have it fixed by an authorized repair place. Working fine now.
Where did you have it fixed?
Modicen is online now  
post #1583 of 1590 Old 02-21-2017, 12:23 PM
Senior Member
 
Gabre's Avatar
 
Join Date: Jul 2008
Posts: 240
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 162 Post(s)
Liked: 24
I would guess they replaced one of the fans.
Gabre is offline  
post #1584 of 1590 Old 02-21-2017, 04:46 PM
AVS Forum Special Member
 
Kadath's Avatar
 
Join Date: Oct 2005
Posts: 1,435
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 389 Post(s)
Liked: 271
Quote:
Originally Posted by Modicen View Post
Where did you have it fixed?
Epson's authorized repair guy in Baltimore / Aberdeen MD
410 247 7000. Tell em Sam recommended em.

They replaced a gear set or logic board, maybe both.

Buncha savages in this town....

Sam Posten
Kadath is offline  
post #1585 of 1590 Old 06-07-2017, 07:01 AM
Senior Member
 
ohcello's Avatar
 
Join Date: Jan 2005
Posts: 412
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 42 Post(s)
Liked: 14
I know this thread has been dormant for a while, but just in case any 5020ub owners want to chime in. I just bought a 5020ub refurb and I'm trying to see how much color uniformity issues I should consider "acceptable" as I know most LCDs have them. Here is the photo of what I see on a white background.... it's not overly annoying, but in white scenes, it's noticable. Do you think I can get a better copy with a return/exchange?




**fixing image attachment**

Last edited by ohcello; 06-07-2017 at 08:44 AM.
ohcello is offline  
post #1586 of 1590 Old 06-11-2017, 08:48 PM
Senior Member
 
Gabre's Avatar
 
Join Date: Jul 2008
Posts: 240
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 162 Post(s)
Liked: 24
This pink and greenish tint? Mine is similar, only noticable on white scenes,like file explorer in windows and static images
Gabre is offline  
post #1587 of 1590 Old 06-15-2017, 10:10 AM
Senior Member
 
ohcello's Avatar
 
Join Date: Jan 2005
Posts: 412
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 42 Post(s)
Liked: 14
Quote:
Originally Posted by Gabre View Post
This pink and greenish tint? Mine is similar, only noticable on white scenes,like file explorer in windows and static images
Yes, the pink and green.... I have been through 2 replacements over the past week... both of which had less pink/green issues than this one... but they both had other issues... replacement #3 on it's way!.
ohcello is offline  
post #1588 of 1590 Old 06-16-2017, 11:18 AM
Senior Member
 
Gabre's Avatar
 
Join Date: Jul 2008
Posts: 240
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 162 Post(s)
Liked: 24
For that reason I will not buy an Epson again. Or it must have 5 years of warranty.
Mine is out of warranty and I just hope it doesnt get worse.
Allready had a failed powerfan, which toook nice 400$ out of my pocket..
Had random shutdowns, but thats been quietfor a while, fingers crossed.
Gabre is offline  
post #1589 of 1590 Old 08-10-2017, 07:00 PM
Newbie
 
Join Date: Feb 2016
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 1
So my HDMI 1 port failed after one and half years on 5020UB. Still under warranty though which I feel ok about. I feel reason is 30ft HDMI cable somehow is my gig feeling. Both 30ft cables are fine and I checked them and they worked with HDMI 2.

Also tried HDMI 1 with 3ft cable and didn't work. Any suggestions ? Might just call them and swap it. Maybe should wait for couple more months.

Also one of my buddy has Epson HC3500 and both his HDMI inputs failed and reason seems to be the same as long HDMI cables.
aasandsas is offline  
post #1590 of 1590 Old 08-12-2017, 08:11 AM
Senior Member
 
Join Date: Mar 2016
Posts: 249
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 147 Post(s)
Liked: 72
Quote:
Originally Posted by aasandsas View Post
So my HDMI 1 port failed after one and half years on 5020UB. Still under warranty though which I feel ok about. I feel reason is 30ft HDMI cable somehow is my gig feeling. Both 30ft cables are fine and I checked them and they worked with HDMI 2.

Also tried HDMI 1 with 3ft cable and didn't work. Any suggestions ? Might just call them and swap it. Maybe should wait for couple more months.

Also one of my buddy has Epson HC3500 and both his HDMI inputs failed and reason seems to be the same as long HDMI cables.
Try an hdmi splitter, I had to do that with mine, it appears that the hdcp handshake was failing, the splitter eliminates that issue, I bought mine off amazon for around $25.

Sent from my STV100-2 using Tapatalk
Mrjmc99 is offline  
Sponsored Links
Advertisement
 
Reply Digital Projectors - Under $3,000 USD MSRP

Tags
Samsung Ssg 4100gb 3d Active Glasses 2012 Model , Epson 5020ub Powerlite Home Cinema 3d Front Projector

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off