5020UB Blinking Red Lights of Death - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 6 Old 05-31-2013, 08:06 AM - Thread Starter
Member
 
dougc11's Avatar
 
Join Date: Aug 2004
Location: MASS
Posts: 45
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Well,
I've had my Epson 5020UB since Dec 2012. Basically love the unit. Beautiful color. I keep it on THX. Pixel alignment was a little off, made some minor alignment changes. No problem. Movies look fantastic!

I usually watch about an hour each night (more on weekends). I have a dedicated projector room that I built and all that stuff.

Anyways, I go to turn the system on last night and the projector wouldn't fire up. Thought the harmony remote might have missed the signal. Nope. I get closer to the unit (ceiling mounted) and see two Blinking red lights on the unit near the blue power button. So, I go to Epson.com, quickly download the manual, look for troubleshooting and find that basically, if it does not restart after pulling out / putting in the main power cord and then restarting, it needs to be replaced. I checked the filter and it was perfectly clean.

I called Epson using a direct line listed in the manual, got to service quickly and ultimately determined within a few minutes that YES, it will need to be replaced.

Should be in on Monday (damn, will miss Bruins / Penguins on the Epson Sat. Night!!!). Got a temporary charge for 2400+ on my card (need to return the old unit within 7 days) that I don't want but that's understandable as a policy. No issue there.


Anybody else have this issue?
How was the replacement unit for anybody who had to return there's?
Any idea if it was new or a refurb?

Damn. Fingers crossed.
dougc11 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 05-31-2013, 02:42 PM
AVS Special Member
 
42Plasmaman's Avatar
 
Join Date: Feb 2006
Location: Seattle, WA
Posts: 5,049
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 19 Post(s)
Liked: 37
They will most likely send you a refurb.
Check it thoroughly before sending back your unit.

2014
42Plasmaman is offline  
post #3 of 6 Old 07-05-2013, 10:59 AM - Thread Starter
Member
 
dougc11's Avatar
 
Join Date: Aug 2004
Location: MASS
Posts: 45
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Well,
I am on my 3rd unit. My original died with the two blinking lights. The refurb they sent me had two blue blobs during very dark scenes. CAlled them up and returned that unit right after NHL playoffs were done (only noticeable in vary dark scenes). The Third unit seemed fine. LCD alignment looked very good and the picture was great as alway.

BUT, I go to fire it up on Wednesday night and it would not light up. It would power on, door would open, then go to high fan speed a few seconds later. Then after about 30 seconds the door would close, the red lamp light would start blinking and it just shut down. Called EPSON, luckily they were still open since I was EST and they are PST. Walked through troubleshooting with the tech guy. Pulled out the lamp, put it back in, fired it back up. Same Result.

So, they are now sending me a replacement lamp. Who knows.

If this works, great. The other potential issue I have with this unit is the handshake with HDMI. It seems to lose it sometimes. Hopefully the lamp is the issue or I will be sending this one back as well.

Wow.
dougc11 is offline  
post #4 of 6 Old 07-06-2013, 03:32 AM
Member
 
KTM250's Avatar
 
Join Date: May 2008
Posts: 195
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 14
I'm on my second one. The first one I sent back for bad light flickering with the auto iris on. The one I have now is probably going back due to the same issue, not as bad as the first but still there. Oh and they told me that I was suppose to be getting a new unit the first time due to the fact that it was only in service for two weeks. Well guess what they sent me a used one. Not impressed with the projector or epson.
KTM250 is offline  
post #5 of 6 Old 07-06-2013, 03:28 PM
AVS Special Member
 
TrickMcKaha's Avatar
 
Join Date: Jun 2004
Posts: 1,016
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 13
This stuff sounds not so great, but try to return or exchange any other manufacturer's projector. See how long you stay on hold, whether they agree to send another unit on your first call, and how many expletives you end up using. Epson's customer service is better even than its projectors. That may seem a backhanded compliment, but once you get the Epson right, it is a thing of beauty.
TrickMcKaha is offline  
post #6 of 6 Old 10-23-2013, 08:36 PM
Member
 
ezelkow1's Avatar
 
Join Date: Aug 2006
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Anyone have any updates on this? I just got hit with the 2 blinking red lights of death. Unfortunately Im going out of town for a week tomorrow so cant even start the process to get a new one. Anyone find out what it is? what causes it? any other experiences with new units?
ezelkow1 is offline  
Reply Digital Projectors - Under $3,000 USD MSRP

Tags
Epson 5020ub Powerlite Home Cinema 3d Front Projector
Gear in this thread - 5020ub by PriceGrabber.com

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off