New color wheel is very loud - AVS Forum
Forum Jump: 
 
Thread Tools
Old 07-27-2013, 05:41 PM - Thread Starter
Member
 
BHDavis's Avatar
 
Join Date: Jul 2013
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
After replacing my broken Benq W9000 projector I decided to see if I could get it working again. Not sure what I'm going to do with it but its fun to try and fix.

I was told it needed a color wheel, lamp ballast and motherboard. I was skeptical because it sure seemed like the symptoms were all broken color wheel related......image on screen but not in color plus a loud hum with projector vibration. Taking out the old color wheel confirmed this as it was shattered.

I ordered a new color wheel on Ebay and it came the other day. I put it in this afternoon and low and behold we had a picture on the screen again.

Only thing is the new color wheel is LOUD. Not humming computer fan loud but small electric drill loud.

Is this a defective color wheel or are new wheels loud and get quiet with use? I've never done this before so have no idea what to expect.

Thanks for the help.

BH
BHDavis is offline  
Sponsored Links
Advertisement
 
Old 07-28-2013, 10:39 AM
AVS Special Member
 
AV_Integrated's Avatar
 
Join Date: Jun 2005
Location: Northern, VA - Washington, DC
Posts: 3,502
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 340 Post(s)
Liked: 378
A color wheel should be nearly dead silent and be about as loud as any of the fans inside the projector. I would return it... and complain. It may be defective.

AV Integrated - Theater, whole house audio, and technology installation in the Washington DC metro area.
AV_Integrated is offline  
Old 07-28-2013, 11:09 AM
AVS Special Member
 
Seegs108's Avatar
 
Join Date: Jul 2007
Location: Schenectady, New York
Posts: 4,541
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 608 Post(s)
Liked: 315
I agree, it shouldn't be that loud. Is this a genuine replacement color wheel? From the sounds of it, it isn't. Unless you're comfortable with the noise, I'd return it for another one.
Seegs108 is offline  
Old 07-28-2013, 01:09 PM - Thread Starter
Member
 
BHDavis's Avatar
 
Join Date: Jul 2013
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
No....not OEM. I called Benq and was told they no longer have parts for the W9000. Seemed strange because earlier I had been told I could send it in for repair.

The color wheel hub had been drilled for balancing. A poor looking job though so I suspect it is slightly out of balance.

I have contacted the Ebay seller by email and await their reply. China ya know !

BH
BHDavis is offline  
Old 07-28-2013, 07:02 PM
AVS Special Member
 
Tinman's Avatar
 
Join Date: Jan 2002
Location: Los Angeles
Posts: 4,013
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 29
Yep, sounds like another fine product from China. It's defective. Like stated before, color wheels are virtually silent. They use the same fluid dynamic bearings as hard drives now.

BTW, congratulations for NOT listening to a repair quote and doing it yourself!

Welcome to the darkside.....
Tinman is offline  
Old 07-31-2013, 01:03 PM - Thread Starter
Member
 
BHDavis's Avatar
 
Join Date: Jul 2013
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I pulled the color wheel out to return it to the seller. This is what I found.

http://curvedmouldings.com/downloads/DSCN1574.JPG

BH
BHDavis is offline  
Old 07-31-2013, 03:45 PM
AVS Special Member
 
Tinman's Avatar
 
Join Date: Jan 2002
Location: Los Angeles
Posts: 4,013
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 29
THAT will do it!

Well, even a new part can just fail. As long as you get a warranty replacement it's all good.

Welcome to the darkside.....
Tinman is offline  
 
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off