Epson 5020 TEch problem - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 5 Old 10-26-2013, 07:35 AM - Thread Starter
Member
 
nadav1983's Avatar
 
Join Date: Dec 2012
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hey guys,

I bought the epson 5020 not long ago, and watched about 6 or 7 movies on it.
Then I havent watched it for about 2 or 3 weeks and when i tried watching a movie today it turned off and the lamp and temp lights went red.
the filter is clean so that is not the case. any ideas what might happen and what should i do?
the thing is I bought the projector from the US and I live in israel so if I can spare shipping it back it would be great but...you know better.
waiting for you guys to help.

Thanks.
nadav1983 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 10-26-2013, 02:09 PM
AVS Club Gold
 
programmergeek's Avatar
 
Join Date: Jul 2001
Location: summit, nj
Posts: 1,047
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 14
I would unplug it for a bit plug it back in and see if it happens again. Once in a while a reset clears up some issues.

Jason
Note: Any posts are of my personal opinions and not to reflect upon any business.

Jason@programmergeek.com

908 578-6466

programmergeek is offline  
post #3 of 5 Old 10-26-2013, 07:22 PM
AVS Special Member
 
42Plasmaman's Avatar
 
Join Date: Feb 2006
Location: Seattle, WA
Posts: 5,041
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Liked: 36
2 things you can do.

1. Take the lamp out and then reseat it.
2. If this happens again, let it power off by itself. May take 10 minutes then turn the main power switch off on the rear.
Wait a minute and turn back on.

*These 2 items are what Epson support will recommend if you call/request support.
If that doesn't work, then request a bulb replacement if possible because that's the next step.

This issue has plauged the 50xx line since the release. I've had no issues since having the bulb replaced under warranty over a year ago.
Prior to that, this issue would happen about every 5th to 10th power up.

2014
42Plasmaman is offline  
post #4 of 5 Old 10-26-2013, 11:37 PM - Thread Starter
Member
 
nadav1983's Avatar
 
Join Date: Dec 2012
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Well first thing thank you very very much for the quick reply. you guys are amazing.
secondly when you say reset its via the menu bar? or is there a reset button on the device?
also I understand this happend to a lot of people? is it something I did wrong or is it a common prob?

Thanks again guys.
nadav1983 is offline  
post #5 of 5 Old 10-27-2013, 02:36 PM
AVS Special Member
 
42Plasmaman's Avatar
 
Join Date: Feb 2006
Location: Seattle, WA
Posts: 5,041
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Liked: 36
The power switch on the rear of the projector.
It cuts power to the projector,

2014
42Plasmaman is offline  
Reply Digital Projectors - Under $3,000 USD MSRP

Tags
Epson 5020ube Powerlite Home Cinema 3d Wireless Front Projector , Epson 5020ub Powerlite Home Cinema 3d Front Projector
Gear in this thread

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off