Jerkiness on video playback - Ubuntu/nVidia/Samsung - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 8 Old 04-04-2012, 04:38 AM - Thread Starter
Newbie
 
Eddles's Avatar
 
Join Date: Apr 2010
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hello all,

I've recently brought a new Samsung TV, model number D6530. I have a HTPC running Ubuntu 11.04 with the nVidia proprietary drivers which is version 270.41.06. The HTPC has a Pentium Dual Core E5300 2.6GHz CPU with 2GB DDR2 RAM and a GeForce 8400GS video card. The video card is connected to the TV's HDMI/DVI input using a HDMI cable with a DVI/HDMI adapter. The TV's native resolution is 1920x1080 but the computer is set up to use 1280x720 as 1920x1080 doesn't look exactly right. Sync to VBlank is enabled.

Before getting the TV, the computer was connected to a Panasonic AX200E 720p projector. There was slight jerkiness before, but I got used to it, though was still noticeable. Now with the TV, the jerkiness is much worse. As the TV is a Smart TV, I was able to try out YouTube and videos streamed to the TV and the jerkiness is completely non-existent. However, the same video played on the computer - whatever kind, YouTube videos, VLC, etc, is extremely jerky to the point it's a big distraction. It doesn't matter what resolution the video is at - whether it's 1080p or CIF, it's jerky. Everything else is smooth, including 3D games. I just test played Tuxracer and it's silk smooth.

How do I fix this jerkiness please? I would really appreciate any advice!
Eddles is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 04-04-2012, 07:44 AM
Rgb
AVS Special Member
 
Rgb's Avatar
 
Join Date: Apr 2000
Location: SE Michigan
Posts: 6,891
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 18
Try turning off Sync to Vblank in the Nvidia control panel and in any media player.

Also, be sure to use the latest Flash 11.2.x


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Rgb is offline  
post #3 of 8 Old 04-04-2012, 09:12 AM
AVS Special Member
 
tux99's Avatar
 
Join Date: Jan 2005
Location: Europe
Posts: 1,523
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
You need to make sure you are using a EIA/CEA compatible modeline.

I'm using the following with my Optoma 720p projector and the playback is absolutely smooth (these might need adapting for different displays):
Code:
    # native Optoma modeline CEA format 19 (50.000 Hz vsync, 37.5 kHz hsync, ratio 16/9)
    ModeLine "1280x720_50.000" 74.250 1280 1720 1760 1980 720 725 730 750 +hsync +vsync

    # native Optoma modeline CEA-861B Format 4 (59.94/60 Hz)
    ModeLine "1280x720_60.000" 74.180 1280 1390 1430 1650 720 725 730 750 +hsync +vsync

    ModeLine "1280x720_47.952" 71.928 1280 1720 1760 2000 720 725 730 750 +hsync +vsync
I also use the following config options:
Option "ExactModeTimingsDVI" "True"
Option "UseEDID" "False"

Obviously you need to make sure that your playback software switches to the right video mode depending on video source frame rate.
"1280x720_50.000" for PAL 50Hz material, "1280x720_60.000" for NTSC 59.94Hz material and "1280x720_47.952" for 23.976Hz cinema material.

My Linux news / reviews / tips+tricks / downloads web site:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
tux99 is offline  
post #4 of 8 Old 04-04-2012, 12:30 PM
Senior Member
 
djb61230's Avatar
 
Join Date: Dec 2004
Location: Johnstown, NY
Posts: 450
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 11
It's hard to envision exactly what you are seeing with the jerkiness but perhaps it may be because of compositing. I usually disable it in the /etc/X11/xorg.conf file.

Compositing is needed for desktop effects and generally doesn't mix well with the nvidia driver which I'm assuming you are using since you have a 8400gs.
djb61230 is offline  
post #5 of 8 Old 04-04-2012, 02:46 PM
AVS Special Member
 
waterhead's Avatar
 
Join Date: May 2007
Posts: 1,264
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 12
Yes, disable composting AKA: Compiz.

It makes for a pretty desktop, but is otherwise useless. You may need to logout, and at the login screen change to a 2D desktop.
waterhead is offline  
post #6 of 8 Old 04-04-2012, 03:38 PM
Rgb
AVS Special Member
 
Rgb's Avatar
 
Join Date: Apr 2000
Location: SE Michigan
Posts: 6,891
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 18
Quote:
Originally Posted by waterhead View Post

Yes, disable composting AKA: Compiz.

It makes for a pretty desktop, but is otherwise useless. You may need to logout, and at the login screen change to a 2D desktop.

Yes- rookie mistake. I usually suggest turning off compositing first


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Rgb is offline  
post #7 of 8 Old 04-05-2012, 04:12 AM - Thread Starter
Newbie
 
Eddles's Avatar
 
Join Date: Apr 2010
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hello everyone,

I've disabled compositing and now I'm getting a completely different problem - in videos the bottom 1/4 or 1/3 of the screen tears badly when the camera pans, and when I try to run Tuxracer, my TV shows "Mode not supported, please use a different resolution". Also, strange artifacts appears at the bottom of the screen when I scroll up or down when using any app such as scrolling down a webpage in a web browser..

I've tried tux99's suggestion of enabling the ExactModeTimingsDVI option but it doesn't change anything. I have not yet tried out tux99's modeline suggestion yet though. Would like to hear your thoughts first before exploring this option.

Many thanks for all of your time!
Eddles is offline  
post #8 of 8 Old 04-05-2012, 01:47 PM
AVS Special Member
 
Mac The Knife's Avatar
 
Join Date: Oct 2003
Location: Phoenix, AZ
Posts: 4,903
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 23
Quote:
Originally Posted by Eddles View Post

Hello everyone,

... and when I try to run Tuxracer, my TV shows "Mode not supported, please use a different resolution".... !

IIRC, there's a setting in the Tuxracer configuration screens that sets the resolution. But I doubt that there are any CEA TV mode resolutions. I think they are all computer monitor resolutions like 1280x1024.

Oh, just remembered, I think there's a setting to play Tuxracer in a window instead of full-screen. That's what you'll probably have to do to play in on the TV.

But I guess you're going to have to hook it up to a regular old computer monitor first so that you can get into the settings screens and change the defaults. Or look at the configuration file and hope it's obvious how to edit it to switch from full-screen to windowed.
Mac The Knife is offline  
Reply HTPC - Linux Chat

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off