Upgrade advice for linux HTPC - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 19 Old 09-29-2012, 12:26 PM - Thread Starter
Senior Member
 
Daravon's Avatar
 
Join Date: Mar 2006
Posts: 307
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I recently got my 2006-era HTPC out of storage and realized it's just not cutting it any more. I installed Precise Pangolin and it won't smoothly play DVDs at 1920x1080 using XBMC. Everything else about the software stack is making me pretty happy, except my CPU runs at 70%, and memory similarly used up. I had to create a swap file (something I haven't done in years) to prevent running out of memory!

This is what I have:
8400GS passive video card
AMD single-core 2.2GHz 90W
1.5GB DDR 400 ram
OCZ SSD

I'm running the system with a single 120mm fan and it seems to be doing ok heat-wise. I don't do gaming, but I do have high standards for video.

My question is, what should I upgrade? Does it make sense to buy a new video card, or should I bite the bullet and upgrade the mobo-processor-memory?

If I upgrade to Sandy Bridge or Ivy Bridge I get Intel graphics. Are these going to be better than my 8400GS? If not, it doesn't bother me to use my 8400GS...I won't feel like I'm 'wasting' the Intel graphics.

If I go with AMD Llano or Trinity or whatever, I get ATI graphics. I swore off ATI for Linux a long time ago, so I would be using my 8400GS no matter what if I buy AMD. Will my current video card cut it?

Any suggestions welcome. I also don't now what kind of ram or how much, I should be getting.
Daravon is offline  
Sponsored Links
Advertisement
 
post #2 of 19 Old 09-29-2012, 11:15 PM
AVS Special Member
 
tux99's Avatar
 
Join Date: Jan 2005
Location: Europe
Posts: 1,523
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
I don't see why that PC shouldn't be able to play back 1080p smoothly (1080i will only work with simple deinterlacers), so I think you more likely have a software configuration issue rather than a hardware issue. But if you want you could replace the graphics card with a passively cooled Nvidia GT 520 (which is about 3 times more powerful than your 8400).

After all if a AMD C60 1.0GHz cpu is fine (see this recent thread: http://www.avsforum.com/t/1417727/uneducated-mythtv-frontend-question ) then your 2.2GHz AMD cpu should be fine too.

Maybe you could get some second-hand RAM off ebay for a few dollars to upgrade to 2GB (or even 3 GB if the mobo can take it), but I don't think it's absolutely necessary.

Software wise why don't you install XBMC Live rather than a full fat Ubuntu install? Or switch the Ubuntu desktop to something more lightweight like LXDE.

Else try out Openelec which is supposed to be very light:
http://openelec.tv/

My HTPC is still a first gen 1.6GHz Atom 330 with first gen Nvidia ION (which is basically a 8400 integrated into the chipset) and 2GB RAM, so it's comparable to yours with regards to cpu and gpu power and I don't have any playback issues.

My Linux news / reviews / tips+tricks / downloads web site:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
tux99 is offline  
post #3 of 19 Old 09-29-2012, 11:39 PM
Member
 
minivanman's Avatar
 
Join Date: Jul 2007
Location: Lockport, IL
Posts: 102
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 19
The 8400 might struggle with HD content.

Do you have VDPAU installed and enabled? VDPAU is Nvidia's gpu acceleration software.

I'd try that first.

Go to a lighter distro like Xubuntu or Lubuntu.

Upgrade to a GT 520, they're cheap.
minivanman is offline  
post #4 of 19 Old 09-29-2012, 11:52 PM
AVS Special Member
 
tux99's Avatar
 
Join Date: Jan 2005
Location: Europe
Posts: 1,523
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by minivanman View Post

The 8400 might struggle with HD content.
Do you have VDPAU installed and enabled? VDPAU is Nvidia's gpu acceleration software.

Actually providing VDPAU is enabled (which is a must with that cpu) the 8400 is perfectly capable of playing back 1080p smoothly. A 8400 is not ideal for interlaced 1080 material as it can only cope with simple deinterlacers but as long as you use a simple deinterlacer it can even play back 1080i smoothly.

I think the OP might not have an optimized xorg.conf (composite not disabled?).

Daravon, for smooth VDPAU playback you need to add the following to your xorg.conf:
Code:
Section "Extensions"
    Option "Composite" "Disable"
EndSection

My Linux news / reviews / tips+tricks / downloads web site:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
tux99 is offline  
post #5 of 19 Old 09-30-2012, 07:47 AM - Thread Starter
Senior Member
 
Daravon's Avatar
 
Join Date: Mar 2006
Posts: 307
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I tried loading a gnome classic desktop with no effects, and and my CPU dropped significantly and memory usage dropped too. However, I still have choppy video. I have the latest NVIDIA driver and I have 'use VDPAU' checked in XBMC, but I'm not sure how to check if it's being used.

I should mention that I'm trying to directly play dvd .iso files. I don't know if that makes a difference. I have tried a h264 encoded movie and it was ok. I should try other file types.

I tried playing files locally from the SSD to rule out network problems, but there is no difference.

One thing I've been fighting is that every time I reboot, my desktop is back to 1280x720 or something. I have to open up nvidia-settings every time and turn it up to 1920x1080. This is really annoying. I tell it to 'save to X configuration file' but it doesn't make a difference. The xorg.conf even says '1920x1080'.
Code:
Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Panasonic-TV"
    HorizSync       15.0 - 68.0
    VertRefresh     23.0 - 61.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8400 GS"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "1920x1080 +0+0; nvidia-auto-select +0+0; 1920x10
80_60 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Daravon is offline  
post #6 of 19 Old 09-30-2012, 09:04 AM
AVS Special Member
 
tux99's Avatar
 
Join Date: Jan 2005
Location: Europe
Posts: 1,523
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Make sure this:
Code:
Option         "metamodes" "1920x1080 +0+0; nvidia-auto-select +0+0; 1920x10
80_60 +0+0"
is all on one line otherwise it won't work.

Also you need to add the 'Composite Disable' snippet that I mentioned earlier, otherwise vidoe playback will be choppy!

My Linux news / reviews / tips+tricks / downloads web site:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
tux99 is offline  
post #7 of 19 Old 09-30-2012, 12:04 PM - Thread Starter
Senior Member
 
Daravon's Avatar
 
Join Date: Mar 2006
Posts: 307
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Code:
Make sure this: is all on one line otherwise it won't work.

It looks like it is; I just checked.

Earlier I had no luck playing DVD ISOs with the mplayer packaged by Ubuntu, so I followed some blogger's guide on compiling it.

I added the 'composite video' section to the beginning of my xorg.conf.
Code:
Section "Extensions"
    Option "Composite" "Disable"
EndSection

Then I rebooted. My system went back to 1280x720 again, so that issue is still out there. XBMC was still equally choppy when playing DVDs. But I managed to get mplayer to work:
Code:
mplayer -fs -dvd-device /media/video/incredibles.iso dvd://1

And video is perfectly fine with mplayer. So I think I have an XBMC problem rather than a hardware problem. I could just use mplayer, but I wanted XBMC so my wife could handle the HTPC (she doesn't do bash). Any suggestions?
Daravon is offline  
post #8 of 19 Old 09-30-2012, 12:34 PM
AVS Special Member
 
tux99's Avatar
 
Join Date: Jan 2005
Location: Europe
Posts: 1,523
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by Daravon View Post

I rebooted. My system went back to 1280x720 again, so that issue is still out there.

Change this line:
Code:
Option         "metamodes" "1920x1080 +0+0; nvidia-auto-select +0+0; 1920x1080_60 +0+0"
To this:
Code:
Option         "metamodes" "DFP-0: 1920x1080 +0+0"

Then reboot and see if it still goes to 1280x720 or not.

If that still doesn't help then try adding:
Code:
Modes                "1920x1080"
inside the SubSection Display.

Can't help you with XBMC as I haven't used it in a long while, maybe ask on the XBMC forum if nobody else here has any suggestions (most people here use Mythtv and I use my own homebrew HTPC software).

My Linux news / reviews / tips+tricks / downloads web site:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
tux99 is offline  
post #9 of 19 Old 09-30-2012, 01:19 PM
AVS Special Member
 
waterhead's Avatar
 
Join Date: May 2007
Posts: 1,264
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 12
If you want the changes you make in the nvidia GUI to persist between boots, you have to do the changes using root privileges:
Code:
sudo nvidia-settings
waterhead is offline  
post #10 of 19 Old 09-30-2012, 02:54 PM
Member
 
minivanman's Avatar
 
Join Date: Jul 2007
Location: Lockport, IL
Posts: 102
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 19
Not an optimal solution, but you can always tie MPlayer into your XBMC menu. Getting the native player to work in XBMC would be the more seamless solution, but there's a way around everything if necessary. It's why I love Linux.

That's what I did with MythTV. I prefer VLC over the native player in MythTV, so I just configured the menu to open VLC instead. It's not as seamless as using the native player, but it keeps my wife from having to jump around menus and GUIs and frontends while satisfying my need to have just one player for video files, DVDs, Blurays (when they work), etc.
minivanman is offline  
post #11 of 19 Old 09-30-2012, 07:08 PM
AVS Special Member
 
newlinux's Avatar
 
Join Date: Oct 2006
Location: Parts unknown
Posts: 1,553
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 15
What other video settings do you have in XBMC related to refresh rate and audio video sync? Depending on how those are set they could be causing the choppiness. Try turning some of those off. I had a similar problem with my machines


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
newlinux is online now  
post #12 of 19 Old 09-30-2012, 07:52 PM - Thread Starter
Senior Member
 
Daravon's Avatar
 
Join Date: Mar 2006
Posts: 307
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I tried toggling the A/v sync and frame rate settings, but ddin't hit on a combo that helped any.
Daravon is offline  
post #13 of 19 Old 10-01-2012, 08:10 AM
Advanced Member
 
blackoper's Avatar
 
Join Date: Sep 2006
Location: Louisville, KY
Posts: 567
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 25
I'd try xbmc buntu (I think that is what they are calling xbmc live now) before you go the route of upgrading. It sounds like all you are using this for is XBMC so why not try the specific distribution that gets rid of all the fluff and see what happens.
blackoper is offline  
post #14 of 19 Old 10-01-2012, 01:53 PM
AVS Special Member
 
newlinux's Avatar
 
Join Date: Oct 2006
Location: Parts unknown
Posts: 1,553
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 15
Yes, your machine should be able to play back smoothly, and mplayer proves it. One of my HTPCs is an atom 330 with ION and have no problems with playback anymore in XBMC, myth, or mplayer for 720p/1080i/p content. I did have stuttering on all but the XBMC A/V sync was causing. I am running full ubuntu on the machine that runs XBMC. I agree with the earlier post about trying the XBMC forums. Good luck.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
newlinux is online now  
post #15 of 19 Old 10-02-2012, 06:56 AM
Member
 
Turtleggjp's Avatar
 
Join Date: Nov 2005
Posts: 98
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Daravon View Post

I should mention that I'm trying to directly play dvd .iso files. I don't know if that makes a difference. I have tried a h264 encoded movie and it was ok. I should try other file types.

I just checked Wikipedia and I noticed that they list the 8400 GS card twice. It seems that some older versions of the card only have support for VDPAU feature set A, which only provides full acceleration for H.264 videos, hence why you said you were able to play them. If that is the case, your card cannot accelerate MPEG2 video which is why that is giving you trouble. You would therefore benefit from an upgrade to a new GT 520 card as was suggested. Wikipedia lists the GT 520 as VDPAU feature set D, which means you may even get 4k video decoding!

Matt
Turtleggjp is offline  
post #16 of 19 Old 10-03-2012, 10:19 AM
AVS Special Member
 
newlinux's Avatar
 
Join Date: Oct 2006
Location: Parts unknown
Posts: 1,553
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 15
Quote:
Originally Posted by Turtleggjp View Post

I just checked Wikipedia and I noticed that they list the 8400 GS card twice. It seems that some older versions of the card only have support for VDPAU feature set A, which only provides full acceleration for H.264 videos, hence why you said you were able to play them. If that is the case, your card cannot accelerate MPEG2 video which is why that is giving you trouble. You would therefore benefit from an upgrade to a new GT 520 card as was suggested. Wikipedia lists the GT 520 as VDPAU feature set D, which means you may even get 4k video decoding!
Matt

But he can play DVDs fine with mplayer (and with that CPU shouldn't even need acceleration to play DVDs). It still seems like an XBMC issue not a hardware issue.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
newlinux is online now  
post #17 of 19 Old 10-03-2012, 11:43 AM
Member
 
Turtleggjp's Avatar
 
Join Date: Nov 2005
Posts: 98
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Daravon View Post

I installed Precise Pangolin and it won't smoothly play DVDs at 1920x1080 using XBMC.

I'm not exactly sure what he means by this. DVDs are 720x480, not 1920x080. If he is playing DVDs and upscaling them to his 1920x1080 display, then this would involve decoding MPEG2 which may not be supported by his card, as I said in my previous post. If he's playing Blu Rays (or rips) which usually are 1920x1080 (and people often refer to them as DVDs even though they aren't), they are often H.264 which should work on his card regardless of which version it is. He did say an H.264 encoded movie played fine, question is what resolution was that movie?

Matt
Turtleggjp is offline  
post #18 of 19 Old 10-03-2012, 02:04 PM
AVS Special Member
 
newlinux's Avatar
 
Join Date: Oct 2006
Location: Parts unknown
Posts: 1,553
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 15
Quote:
Originally Posted by Daravon View Post

Code:
Make sure this: is all on one line otherwise it won't work.
It looks like it is; I just checked.
Earlier I had no luck playing DVD ISOs with the mplayer packaged by Ubuntu, so I followed some blogger's guide on compiling it.
I added the 'composite video' section to the beginning of my xorg.conf.
Code:
Section "Extensions"
    Option "Composite" "Disable"
EndSection
Then I rebooted. My system went back to 1280x720 again, so that issue is still out there. XBMC was still equally choppy when playing DVDs. But I managed to get mplayer to work:
Code:
mplayer -fs -dvd-device /media/video/incredibles.iso dvd://1
And video is perfectly fine with mplayer. So I think I have an XBMC problem rather than a hardware problem. I could just use mplayer, but I wanted XBMC so my wife could handle the HTPC (she doesn't do bash). Any suggestions?

I think it is clear here based on his mplayer line that he can play a dvd fine with mplayer, and it isn't a bluray that he is having trouble with. Upscaling resolution is much less processor intensive than than decoding it and for his processor/GPU that wouldn't be an issue either, as evidenced by it working with mplayer. I'm fairly certain it's not a hardware/processing power issue. His processor should have no problem decoding Mpeg2 720x480 content in software.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
newlinux is online now  
post #19 of 19 Old 10-04-2012, 06:20 PM - Thread Starter
Senior Member
 
Daravon's Avatar
 
Join Date: Mar 2006
Posts: 307
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I don't have any blu-rays. My library is mostly in dvd .iso files.

I'm outputting 1920x1080 because that's my TV resolution and I've been told that it's better to do the scaling on the GPU than on the display. I'm a bit annoyed, but I can just use mplayer for the time being. I really like the XBMC 'experience', but oh well. As people have pointed out, dvd-resolution mpeg-2 shouldn't be a challenge, but I guess that's that.
Daravon is offline  
Reply HTPC - Linux Chat

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off