setting up IR remote for DVD playback - AVS Forum
Forum Jump: 
Reply
 
Thread Tools
post #1 of 60 Old 10-14-2012, 04:33 PM - Thread Starter
Senior Member
 
dkap's Avatar
 
Join Date: Aug 2002
Location: in the dark
Posts: 200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I picked up a MSI remote/receiver combo (that comes with the Theatre 550 Pro card, I'm told), as described here:

http://www.pcstats.com/articleview.cfm?articleid=1827 (pgs 2 and 3)

I have LIRC installed on Ubuntu 12.04 and it sort of works, but not quite good enough. I've tried following the tutorials on trying different lirc.conf.* files, including making my own, and including them in lircd.conf (running "sudo /etc/init.d/lirc start" each time), but that has had absolutely no effect. Same output from the remote each time. Here are the instructions I was primarily following:

http://flavor8.com/index.php/2010/02/25/how-to-configure-any-remote-control-with-lirc/

Here is what I mapped via irw's button confirmation and in parenthesis, what each button actually does in VLC. (I also tried with SMPlayer.)

OK = enter (works)
chapter back = p (seems to work)
chapter forward = n (seems to work)
play/pause = ^P or space (alternates with every other key press, bringing up the preferences menu every other time)
stop = s (works)
volume + = + (faster speed play)
volume - = - (slower speed play)
home = ^H (toggles player controls)
back = inverts cursor (doesn't work)
Last Ch = context menu? (doesn't work)
Rew = b (audio track selection?)
Fwd = f (full screen toggle)
mute = z (zoom)
record = r (nothing)
#'s 1-9,0 = #'s 1-9,0 (nothing)
DVD menu = enter (nothing)
repeat = ^R, enter (nothing
close = close terminal (nothing)
Music = ^[[17~
TV/DVR = ^[OR
Pictures = ^[[19~
FM = ^[[18~
Video = ^[OS
DVD/VCD = ^[[15~

The multi-directional mouse wheel works perfectly.

I tried my Marantz DVD remote and it gets no response in irw, so I'm thinking my lircd.conf changes aren't actually taking effect... The MSI remote works with the default, generic MSE setting, so it would make sense that the Marantz remote wouldn't be detected if LIRC is indeed staying with that setting.

My hope is to be able to use my Home Theater Master MX-500 remote to control DVD playback in VLC or whatever other player I end up using. To do so, I need to get a clean mapping of button functionality first. Have I missed anything obvious?

Dan
dkap is offline  
Sponsored Links
Advertisement
 
post #2 of 60 Old 10-14-2012, 10:44 PM - Thread Starter
Senior Member
 
dkap's Avatar
 
Join Date: Aug 2002
Location: in the dark
Posts: 200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Two other things I noticed that don't make a whole lot of sense:

1) All of the above irw commands/output from the previous post behave exactly the same at the command line prompt, i.e., without irw running. For that to be the correct behavior, it would seemingly make irw pointless.

2) I tried programming (learning) the working buttons over to the MX-500 remote and none of them are registered by the computer, even though the MX-500 shows that it learned them all successfully and the IR receiver lights up at each button press.

Dan
dkap is offline  
post #3 of 60 Old 10-15-2012, 03:21 AM
AVS Special Member
 
waterhead's Avatar
 
Join Date: May 2007
Posts: 1,264
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 12
LIRC is no longer the default way to run ir remotes in Linux. There are now kernel modules (drivers) that are automatically loaded when the device is detected. There is the package "ir-keytable" that you can install. This will make it easier to modify the existing keymaps. It should install a /etc/rc_maps.cfg file. This has a list of the drivers used for remotes. Once that is installed, you can read the manual using this command:
Code:
man ir-keytable

To see the existing kernal modules, and hopefully find which one is loading for your remote, run this command:
Code:
lsmod
waterhead is offline  
post #4 of 60 Old 10-15-2012, 08:52 AM - Thread Starter
Senior Member
 
dkap's Avatar
 
Join Date: Aug 2002
Location: in the dark
Posts: 200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
LIRC is no longer the default way to run ir remotes in Linux.

That's the first I've heard of that, thanks. But ir-keytable is proving even less workable. I removed LIRC and installed ir-keytable, but I'm getting nothing but "/sys/class/rc/: No such file or directory" messages with everything I try. I followed a suggestion to reboot following the LIRC uninstall, but still no luck. However, the remote's basic buttons still work in VLC same as under LIRC. I just don't see how I can get to the remapping steps with the above problem.

Most of the ir-keytable info I've found is a year old ... does that make a difference?

Dan
dkap is offline  
post #5 of 60 Old 10-16-2012, 03:37 AM
AVS Special Member
 
waterhead's Avatar
 
Join Date: May 2007
Posts: 1,264
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 12
i struggled setting up my MCE remote earlier this year. I eventually made a completely new keymap file. The default keymap files should be found in the /lib/udev/rc-keymaps/ directory. That was on Fedora, so things were a little different, and I really don't remember everything that I did. The documentation is very sparse for this, but that is actually normal for Linux. That is why help forums like these thrive on Linux!
The reason VLC still works the same is because it wasn't using lirc.

You need to run ir-keytable with root permissions (sudo):
Code:
sudo ir-keytable
Another way to get info on a Linux command is to use the --help option:
Code:
ir-keytable --help
Which outputs this:
Code:
paul@HP-Elite:~$ ir-keytable --help
Usage: ir-keytable [OPTION...] --device [/dev/input/event* device]
  or:  ir-keytable [OPTION...] --sysdev [ir class (f. ex. rc0)]
  or:  ir-keytable [OPTION...] [for using the rc0 sysdev]

Allows get/set IR keycode/scancode tables
You need to have read permissions on /dev/input for the program to work

On the options bellow, the arguments are:
  DEV      - the /dev/input/event* device to control
  SYSDEV   - the ir class as found at /sys/class/rc
  TABLE    - a file wit a set of scancode=keycode value pairs
  SCANKEY  - a set of scancode1=keycode1,scancode2=keycode2.. value pairs
  PROTOCOL - protocol name (nec, rc-5, rc-6, other) to be enabled
  DELAY    - Delay before repeating a keystroke
  PERIOD   - Period to repeat a keystroke
  CFGFILE  - configuration file that associates a driver/table name with a
keymap file

Options can be combined together.

  -a, --auto-load=CFGFILE    Auto-load a table, based on a configuration file.
                             Only works with sysdev.
  -c, --clear                clears the old table
  -d, --device=DEV           ir device to control
  -D, --delay=DELAY          Sets the delay before repeating a keystroke
  -k, --set-key=SCANKEY      Change scan/key pairs
  -p, --protocol=PROTOCOL    Protocol to enable (the other ones will be
                             disabled). To enable more than one, use the option
                             more than one time
  -P, --period=PERIOD        Sets the period to repeat a keystroke
  -r, --read                 reads the current scancode/keycode table
  -s, --sysdev=SYSDEV        ir class device to control
  -t, --test                 test if IR is generating events
  -v, --verbose              enables debug messages
  -w, --write=TABLE          write (adds) the scancodes to the device
                             scancode/keycode table from an specified file
  -?, --help                 Give this help list
      --usage                Give a short usage message
  -V, --version              Print program version

Mandatory or optional arguments to long options are also mandatory or optional
for any corresponding short options.

Report bugs to Mauro Carvalho Chehab <mchehab@redhat.com>.
It sounds like it isn't finding your ir dongle in the default location. You need to find where it is, and then use the available options to tell ir-keytable. Before pluging the ir into the PC, take note of the entries in the /dev/input /event* directory, you can use this command:
Code:
ls -l /dev/input/
Now, plug in the ir device and run the command again. any new entry should be the ir. Then use that event number to tell ir-keytable what device to use.
Code:
sudo ir-keytable -d /dev/input/event11
I suppose you could use the same method to find the device in the /sys/class/rc/ directory.
waterhead is offline  
post #6 of 60 Old 10-16-2012, 07:08 AM - Thread Starter
Senior Member
 
dkap's Avatar
 
Join Date: Aug 2002
Location: in the dark
Posts: 200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
I suppose you could use the same method to find the device in the /sys/class/rc/ directory.

Could you expand on that? I ran "ls -l /dev/input/" and found that it adds event12 and mouse1 entries ... the latter presumably because the remote's wheel functions as a mouse.

However, on a totally clean reinstall, switching from Ubuntu to Mint, I'm still getting the "/sys/class/rc/: No such file or directory" response to "sudo ir-keytable". Browsing the folders, there indeed does not appear to be a folder by that name, and I haven't found anything yet on what that signifies. Should ir-keytable be setting it up and populating it? Can I add it myself just to satisfy ir-keytable's need for something to be there?

Dan
dkap is offline  
post #7 of 60 Old 10-16-2012, 07:52 AM - Thread Starter
Senior Member
 
dkap's Avatar
 
Join Date: Aug 2002
Location: in the dark
Posts: 200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Small bit of progress... I found this thread (and the thread it references) -- http://ubuntuforums.org/showthread.php?t=2000773 -- and added "modprobe ir-kbd-i2c" to /etc/rc.local. After rebooting, running "sudo ir-keytable" now results in "Couldn't find any node at /sys/class/rc/rc*." At least the /sys/class/rc/ directory is there now! Nothing is in it, though.

From what I've read, that seems to suggest that the IR receiver isn't being recognized as a device upon booting, but that doesn't make any sense because it works fine. confused.gif

Dan
dkap is offline  
post #8 of 60 Old 10-16-2012, 08:13 AM - Thread Starter
Senior Member
 
dkap's Avatar
 
Join Date: Aug 2002
Location: in the dark
Posts: 200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I wonder if this has something to do with it?

http://forum.linhes.org/viewtopic.php?f=23&t=22504&start=15
Quote:
If you have nothing in /sys/class/rc then I expect this is not viewed as a "remote class" and hence it is viewed as a standard keyboard ... If you are getting scan codes through input then a driver does exist ... it looks like there may be something you need to do in Xorg to ensure the device is properly discovered.

Is it possible for the IR receiver to fall under a keyboard category? I would have thought that only applies to the remote itself, but I guess all that would have to be happening at boot independent of the remote.

Dan
dkap is offline  
post #9 of 60 Old 10-16-2012, 09:31 AM
AVS Special Member
 
waterhead's Avatar
 
Join Date: May 2007
Posts: 1,264
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 12
With the newer in-kernel drivers, they are considered as a keyboard/mouse. That is why there is a /dev/input/event* created for the device. Did you try it using the -d option pointing it to the correct event, as I suggested?
waterhead is offline  
post #10 of 60 Old 10-16-2012, 10:27 AM - Thread Starter
Senior Member
 
dkap's Avatar
 
Join Date: Aug 2002
Location: in the dark
Posts: 200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by waterhead View Post

Did you try it using the -d option pointing it to the correct event, as I suggested?

Yeah, that didn't work either.

sudo ir-keytable -d /dev/input/event12
Couldn't find any node at /sys/class/rc/rc*.

That's been the stumbling block on everything I try.

Dan
dkap is offline  
post #11 of 60 Old 10-16-2012, 04:27 PM
AVS Special Member
 
waterhead's Avatar
 
Join Date: May 2007
Posts: 1,264
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 12
I'm guessing it isn't being properly recognized, so maybe the correct driver modules aren't loading.

Before plugging my ir receiver in, I run this command, to see what modules are loaded:
Code:
lsmod
I then insert the ir receiver, and run that command again. The modules listed at the beginning are the newest ones loaded. Here are the modules my remote loads:
Code:
rc_rc6_mce             12454  0 
ir_lirc_codec          12770  0 
lirc_dev               18720  1 ir_lirc_codec
ir_sony_decoder        12493  0 
ir_jvc_decoder         12490  0 
ir_rc6_decoder         12490  0 
ir_rc5_decoder         12490  0 
ir_nec_decoder         12490  0 
mceusb                 17579  0 
rc_core                25760  9 rc_rc6_mce,ir_lirc_codec,ir_sony_decoder,ir_jvc_decoder,ir_rc6_decoder,ir_rc5_decoder,ir_nec_decoder,mceusb
You can also then check the system messages using the "dmesg" command, the last ones being the most recent. Here is what I got:
Code:
dmesg
[  113.229296] usb 2-1.4: new full speed USB device using ehci_hcd and address 6
[  113.374044] IR NEC protocol handler initialized
[  113.375428] IR RC5(x) protocol handler initialized
[  113.386480] IR RC6 protocol handler initialized
[  113.391519] IR JVC protocol handler initialized
[  113.392896] IR Sony protocol handler initialized
[  113.394815] lirc_dev: IR Remote Control driver registered, major 250 
[  113.395796] IR LIRC bridge handler initialized
[  123.291464] generic-usb 0003:147A:E03E.0003: timeout initializing reports
[  123.291573] generic-usb 0003:147A:E03E.0003: hiddev0,hidraw2: USB HID v1.00 Device [Formosa21 eHome Infrared Transceiver] on usb-0000:00:1d.0-1.4/input1
[  123.339111] Registered IR keymap rc-rc6-mce
[  123.339205] input: Media Center Ed. eHome Infrared Remote Transceiver (147a:e03e) as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4/2-1.4:1.0/rc/rc0/input11
[  123.339235] rc0: Media Center Ed. eHome Infrared Remote Transceiver (147a:e03e) as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4/2-1.4:1.0/rc/rc0
[  123.339356] rc rc0: lirc_dev: driver ir-lirc-codec (mceusb) registered at minor = 0
[  123.339487] mceusb 2-1.4:1.0: Registered Formosa21 eHome Infrared Transceiver on usb2:6
[  123.339499] usbcore: registered new interface driver mceusb
Post what you are getting. Use "code" tags when posting this info.
waterhead is offline  
post #12 of 60 Old 10-17-2012, 12:49 PM - Thread Starter
Senior Member
 
dkap's Avatar
 
Join Date: Aug 2002
Location: in the dark
Posts: 200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Running lsmod, here are the significant looking entries prior to plugging in the IR receiver:
Code:
Module                  Size  Used by
ir_lirc_codec          12859  0 
lirc_dev               19204  1 ir_lirc_codec
ir_mce_kbd_decoder     12777  0 
ir_sony_decoder        12510  0 
ir_jvc_decoder         12507  0 
ir_rc6_decoder         12507  0 
ir_rc5_decoder         12507  0 
ir_nec_decoder         12507  0 
ir_kbd_i2c             13185  0 
rc_core                26412  8 ir_lirc_codec,ir_mce_kbd_decoder,ir_sony_decoder,ir_jvc_decoder,ir_rc6_decoder,ir_rc5_decoder,ir_nec_decoder,ir_kbd_i2

After plugging in the IR receiver, that list (and the entries that follow) looks identical. So, that would support your hunch that the receiver isn't being recognized, thus the drivers not loaded. I guess the partial functionality of the remote/receiver is due to the default drivers recognizing some of the commands?

Here's what I got for dmesg:
Code:
[104132.292611] usb 1-1.1: new low-speed USB device number 6 using ehci_hcd
[104132.397274] input: Cypress Sem Cypress USB Mouse as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.1/1-1.1:1.0/input/input13
[104132.397485] samsung 0003:0419:0001.0003: input,hiddev0,hidraw1: USB HID v1.00 Keyboard [Cypress Sem Cypress USB Mouse] on usb-0000:00:1a.0-1.1/input0

Does that give you any thoughts?

Dan
dkap is offline  
post #13 of 60 Old 10-17-2012, 01:59 PM
AVS Special Member
 
waterhead's Avatar
 
Join Date: May 2007
Posts: 1,264
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 12
Quote:
Originally Posted by dkap View Post

Does that give you any thoughts?
Well, YES!

First, those modules shouldn't have already been loaded, unless you had the IR plugged in and removed then reinserted it. When you remove it, the modules stay loaded until a reboot.

The other thing is that you are missing one significant module, the mceusb module. You could try and manually load it, and see if it creates the /sys/class/rc/ directory.
Code:
sudo modprobe mceusb

I hope it is this easy to fix!! biggrin.gif
waterhead is offline  
post #14 of 60 Old 10-18-2012, 12:16 AM - Thread Starter
Senior Member
 
dkap's Avatar
 
Join Date: Aug 2002
Location: in the dark
Posts: 200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by waterhead View Post

First, those modules shouldn't have already been loaded, unless you had the IR plugged in and removed then reinserted it. When you remove it, the modules stay loaded until a reboot.

Er, yeah, that's what I did. smile.gif I'll have to re-run the same test later after a reboot.

I ran "sudo modprobe mceusb" but got no terminal feedback, and no /sys/class/rc/ subdir was created...

Dan
dkap is offline  
post #15 of 60 Old 10-18-2012, 03:05 AM
AVS Special Member
 
waterhead's Avatar
 
Join Date: May 2007
Posts: 1,264
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 12
I see there is one other module my remote loads that yours didn't. I must have missed it yesterday. It is the "rc_rc6_mce " module, so you would want to try manually loading that one too. Sometimes the order in which a module is loaded is important, but we won't worry about that for now.
Code:
sudo modprobe mceusb
sudo modprobe rc_rc6_mce

And, I see that "ir_kbd_i2c" module that you added. For now, I would unload it, but do it first, before loading the two previous modules:
Code:
sudo modprobe -r ir_kbd_i2c

In fact, you may want to keep it from loading at boot, by removing what you added to the /etc/rc.local file.

If a module loads without a problem, there won't be any feedback in the terminal. You can check the output of dmesg for info on the newly loaded modules. Another method for tracing down troubles is to watch the /var/log/messages file. To see it update live, run this command in a separate terminal window:
Code:
tail -f /var/log/messages

I understand that this now has been disabled in Ubuntu. It is a useful tool for troubleshooting, so enable /var/log/messages by following this guide:

http://bdup.wordpress.com/2012/03/15/where-is-varlogmessages-on-ubuntu-12-04-b1-precise/

You need root privileges to edit that file. Use this command, and enter your password when asked.
Code:
gksu gedit /etc/rsyslog.d/50-default.conf

Be careful to not change anything accidentally, save the file and close it.

Also keep in mind that my remote is different than yours, so different modules may be needed. Maybe some others can chime in on what other modules their remotes are loading.
waterhead is offline  
post #16 of 60 Old 10-18-2012, 03:32 AM
AVS Special Member
 
waterhead's Avatar
 
Join Date: May 2007
Posts: 1,264
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 12
As a test, I manually loaded all my modules in the order that the system loads them (without the ir receiver plugged in). The first one , rc_core, creates the /sys/class/rc directory, but it is empty. Loading all of the other modules one-at-a-time doesn't change this. I am guessing it still is not Identifying the hardware, and further system alterations may be needed to do this. What is the output of this command? Do it before plugging in the ir receiver, and again after. I want to see how it identifies the remote.
Code:
lsusb

You won't need to reboot this time after removing or inserting it.
waterhead is offline  
post #17 of 60 Old 10-18-2012, 12:01 PM - Thread Starter
Senior Member
 
dkap's Avatar
 
Join Date: Aug 2002
Location: in the dark
Posts: 200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Catching back up here... I ran the following with no apparent effect on the /sys/class/rc/* dir:
Code:
sudo modprobe -r ir_kbd_i2c
sudo modprobe mceusb
sudo modprobe rc_rc6_mce

Here's what I see for "lsusb" prior to plugging in the IR receiver:
Code:
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 0bda:8172 Realtek Semiconductor Corp. RTL8191SU 802.11n WLAN Adapter
Bus 001 Device 004: ID 04b3:310c IBM Corp. Wheel Mouse

And here it is after:
Code:
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 0bda:8172 Realtek Semiconductor Corp. RTL8191SU 802.11n WLAN Adapter
Bus 001 Device 004: ID 04b3:310c IBM Corp. Wheel Mouse
Bus 001 Device 005: ID 0419:0001 Samsung Info. Systems America, Inc. IrDA Remote Controller / Creative Cordless Mouse

The last entry looks to be the only difference. The "dmesg" output listed it as a Cypress USB Mouse, fwiw. I guess everything shares internal parts, though.

Dan
dkap is offline  
post #18 of 60 Old 10-19-2012, 03:20 AM
AVS Special Member
 
waterhead's Avatar
 
Join Date: May 2007
Posts: 1,264
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 12
waterhead is offline  
post #19 of 60 Old 10-19-2012, 03:24 AM
AVS Special Member
 
waterhead's Avatar
 
Join Date: May 2007
Posts: 1,264
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 12
OK, LinuxTV has some setup instructions for this. I hope they work. Keep in mind these instructions could be older, before the in-kernel modules were available. Meaning that you may need to disable some modules so that LIRC can control the device.

http://linuxtv.org/wiki/index.php?title=Satelco_EasyWatch_PCI_%28DVB-C%29&redirect=no
waterhead is offline  
post #20 of 60 Old 10-19-2012, 05:06 PM - Thread Starter
Senior Member
 
dkap's Avatar
 
Join Date: Aug 2002
Location: in the dark
Posts: 200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks, that sounds promising. How would a relative Linux newbie interpret this series of instructions?
Quote:
Install LIRC 0.8.3 (or later) with the samsung device driver. A config file is already packaged under "remotes/samsung/lircd.samsung.conf". Start lircd by applying the samsung driver with this config file on the new hiddev device, e.g. "-H samsung -d /dev/hiddev0 configfile".

That seems like several steps combined into one thought.

Dan
dkap is offline  
post #21 of 60 Old 10-20-2012, 07:15 AM
AVS Special Member
 
waterhead's Avatar
 
Join Date: May 2007
Posts: 1,264
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 12
That stops short of actually giving you something that you could try. What they are trying to say is to start the lircd daemon and force it to use the samsung driver (-H) and a specific device (-d) and config file:
Code:
lircd -H samsung -d /dev/hiddev0 /usr/share/lirc/remotes/samsung/lircd.conf.samsung
You will need to tailor the command to your specific system details. Is there a /dev/hiddev* entry created for your device? Is the samsung conf file in the same directory as I listed?

Also, the lircd daemon may start automatically at boot, so you would need to stop it, and then restart it using your new options, but not sure about that. I recall the .lircd file as something that is kept in your /home directory. The "." before the the name means it is a hidden file. I just reinstalled lirc, and I didn't get that file, so I believe that once you have it working correctly, you create that file using whatever worked. Then lirc should automatically use the file in your home directory (I think).

For more info on lircd, use the man command, or use the --help option:
Code:
lircd --help
Code:
man lircd

There also is the /etc/lirc directory for your default config files. There are others in this forum that are much wiser than me, when it comes to setting up lirc. Maybe they can join in and provide you with some guidance.

EDIT: I'm not sure that the lircd command that I gave you will work. According to the list of lirc drivers, FOUND HERE, the samsung driver is the /usr/share/doc/lirc/remotes/samsung/lircd.conf.samsung file. So, listing is twice doesn't seem correct. Try it without giving it the config file option, and see if that may work.
waterhead is offline  
post #22 of 60 Old 10-20-2012, 08:37 AM - Thread Starter
Senior Member
 
dkap's Avatar
 
Join Date: Aug 2002
Location: in the dark
Posts: 200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
You will need to tailor the command to your specific system details. Is there a /dev/hiddev* entry created for your device? Is the samsung conf file in the same directory as I listed?

I don't see anything matching /dev/hiddev* (I rebooted to make sure), but the Samsung conf path/file matches what I've got. Would I just do:
Code:
lircd -H samsung -d /usr/share/lirc/remotes/samsung/lircd.conf.samsung

instead? (I do have the /usr/share/doc/lirc/remotes...) entry, too.
Quote:
Also, the lircd daemon may start automatically at boot, so you would need to stop it, and then restart it using your new options, but not sure about that.

Hopefully, that's a one-time thing to get it configured properly, not required of every boot?

I'm wondering if all this wouldn't be made [much] easier by just getting a different remote... It sounds like the receiver is as much a part of the problem, correct?

Dan
dkap is offline  
post #23 of 60 Old 10-20-2012, 08:50 AM
AVS Special Member
 
waterhead's Avatar
 
Join Date: May 2007
Posts: 1,264
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 12
Quote:
Originally Posted by dkap View Post

I don't see anything matching /dev/hiddev* (I rebooted to make sure), but the Samsung conf path/file matches what I've got.
But didn't you previously say that dmesg reported this;
Code:
samsung 0003:0419:0001.0003: input,hiddev0,hidraw1: USB HID v1.00 Keyboard [Cypress Sem Cypress USB Mouse] on usb-0000:00:1a.0-1.1/input0
Quote:
Originally Posted by dkap View Post

I'm wondering if all this wouldn't be made [much] easier by just getting a different remote... It sounds like the receiver is as much a part of the problem, correct?
Dan
That's always an option, depending upon what you need the remote to do. If you only want to control the HTPC, I have been using a Rosewill MCE remote with success.

http://www.newegg.com/Product/Product.aspx?Item=N82E16880101002

If you want a remote that can also control other devices, it doesn't look like this one will do that.
waterhead is offline  
post #24 of 60 Old 10-20-2012, 09:17 AM - Thread Starter
Senior Member
 
dkap's Avatar
 
Join Date: Aug 2002
Location: in the dark
Posts: 200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Yeah, I still see that entry reported by dmesg, but I don't see any corresponding folder or file under /dev. (There is a /dev/hidraw1, however.) Is there somewhere else I should look?

To be honest, I'm a bit distrustful of the Rosewill brand, based on reviews and perceived quality, but if you're happy with it, that's good to know. I only need it for HTPC control, so simple is find, and something that works with minimal configuration headache is ideal!

Dan
dkap is offline  
post #25 of 60 Old 10-20-2012, 09:46 AM
AVS Special Member
 
waterhead's Avatar
 
Join Date: May 2007
Posts: 1,264
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 12
Quote:
Originally Posted by dkap View Post

Yeah, I still see that entry reported by dmesg, but I don't see any corresponding folder or file under /dev. (There is a /dev/hidraw1, however.) Is there somewhere else I should look?
It seems my Rosewill is giving the same message, and I don't see a /dev/hiddev0 either. But, I did find it under /dev/usb/
Quote:
Originally Posted by dkap View Post

To be honest, I'm a bit distrustful of the Rosewill brand, based on reviews and perceived quality, but if you're happy with it, that's good to know. I only need it for HTPC control, so simple is find, and something that works with minimal configuration headache is ideal!

I never said it worked without a configuration headache!! Out-of-the-box, it works for system volume, up/down/left/right arrows, enter and to shut the PC down. I use MythTV, and wanted the center OK button to act as an enter button, and the Back button to act as an Escape button. This is what is used most in MythTV. When I remapped those, then other buttons stopped working. I ended up creating an entirely new config file for it, but am happy with how it now works. The problem with doing it this way is now it won't function properly on other things. But since I only use it for MythTV, that is not a problem.

You can still use LIRC, and then create a different config for each application. That is how I used to set up my remotes, and it seemed to work pretty good that way.
waterhead is offline  
post #26 of 60 Old 10-20-2012, 05:40 PM - Thread Starter
Senior Member
 
dkap's Avatar
 
Join Date: Aug 2002
Location: in the dark
Posts: 200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by waterhead View Post

It seems my Rosewill is giving the same message, and I don't see a /dev/hiddev0 either. But, I did find it under /dev/usb/

Sure enough, I see it there on mine, too. So, would I do something like:
Code:
lircd -H samsung -d /dev/usb/hiddev0 /usr/share/lirc/remotes/samsung/lircd.conf.samsung
Quote:
I never said it worked without a configuration headache!!

Ooh, that doesn't sound much different than what I've got now... Although, mine has the additional problem of not being properly recognized, making remapping much more difficult.

Dan
dkap is offline  
post #27 of 60 Old 10-20-2012, 06:07 PM
AVS Special Member
 
waterhead's Avatar
 
Join Date: May 2007
Posts: 1,264
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 12
Quote:
Originally Posted by dkap View Post

Sure enough, I see it there on mine, too. So, would I do something like:
Code:
lircd -H samsung -d /dev/usb/hiddev0 /usr/share/lirc/remotes/samsung/lircd.conf.samsung
It's worth a try.
waterhead is offline  
post #28 of 60 Old 10-26-2012, 09:53 AM - Thread Starter
Senior Member
 
dkap's Avatar
 
Join Date: Aug 2002
Location: in the dark
Posts: 200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I've been busy with several more pressing (i.e., not fun) projects this week. Here's what I got when I tried running
Code:
lircd -H samsung -d /dev/usb/hiddev0 /usr/share/lirc/remotes/samsung/lircd.conf.samsung

lircd: can't open or create /var/run/lirc/lircd.pid
lircd: No such file or directory

There isn't a /lirc/ directory in /var/run, so that makes sense.

However... I had installed LIRC this time from the software center, and it never gave me the option I remembered from my first try under Ubuntu (now running Mint) of specifying the type of IR receiver. I can't find anywhere to run the config now, either. So, I uninstalled it and re-installed from the command line, following the guide at:

sudo apt-get install lirc

Now I see the /var/run/lirc directory! But, would I still need to run the "lircd -H samsung..." command since that was presumably done during the LIRC setup?

Dan
dkap is offline  
post #29 of 60 Old 10-26-2012, 10:24 AM
AVS Special Member
 
waterhead's Avatar
 
Join Date: May 2007
Posts: 1,264
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 12
By specifying all of the options, you tell lirc to NOT use the default configuration. This is what you need to do until you can figure out what works.
waterhead is offline  
post #30 of 60 Old 10-26-2012, 10:35 AM - Thread Starter
Senior Member
 
dkap's Avatar
 
Join Date: Aug 2002
Location: in the dark
Posts: 200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Ok, that makes sense. Running the command still yields the permission denied error, so I added sudo to it:
Code:
sudo lircd -H samsung -d /dev/usb/hiddev0 /usr/share/lirc/remotes/samsung/lircd.conf.samsung

lircd: there seems to already be a lircd process with pid 16162
lircd: otherwise delete stale lockfile /var/run/lirc/lircd.pid

Is it safe to delete the lircd.pid file? All it contains is a single line with "16162" in it, obviously as the pid identifier. Do I have to stop LIRC first to issue the above command?

Dan
dkap is offline  
Reply HTPC - Linux Chat

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off