Xubuntu 13.04 blu-ray playback woes - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 8 Old 10-24-2013, 12:53 PM - Thread Starter
Member
 
Remoteless's Avatar
 
Join Date: Feb 2006
Location: Rockville,MD
Posts: 68
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Fresh install of 13.04 on celeron G1610 NO VIDEO CARD. Got blu-ray to play on VLC 2.0.8 twoflower sound is good, picture is terrible. Even dvd video has tearing during action scenes. I'm guessing the video driver is at fault. I'm a buntu rookie and need help. Please!
Remoteless is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 10-24-2013, 02:25 PM
AVS Special Member
 
waterhead's Avatar
 
Join Date: May 2007
Posts: 1,260
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 12
You need to use a modern nVidia graphics card. And the nVidia driver. not the built-in nouveau driver.
waterhead is offline  
post #3 of 8 Old 10-24-2013, 05:44 PM
AVS Special Member
 
Dark_Slayer's Avatar
 
Join Date: May 2012
Posts: 2,230
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 30 Post(s)
Liked: 215
Quote:
Originally Posted by Remoteless View Post

Fresh install of 13.04 on celeron G1610 NO VIDEO CARD. Got blu-ray to play on VLC 2.0.8 twoflower sound is good, picture is terrible. Even dvd video has tearing during action scenes. I'm guessing the video driver is at fault. I'm a buntu rookie and need help. Please!

Not extremely familiar with VLC, but you need to disable HW acceleration for rendering. G1610 can software render blu ray all day long no tearing, but ivy bridge hd graphics are too weak.

If you were using XBMC, the settings needed should simply be deselecting the "Enable HW Acceleration (VAAPI)" radio button


and

Ensure the deinterlace settings are auto and a non-hw-accelerated scaling method is selected


Built my in-laws an openelec box with a g1610 / h61. No video playback problems whatsoever, cpu utilization can hit about 50-60% during 40GB mkv playback with hd audio decoding . . . small price to pay
Remoteless likes this.
Dark_Slayer is online now  
post #4 of 8 Old 11-07-2013, 06:42 PM - Thread Starter
Member
 
Remoteless's Avatar
 
Join Date: Feb 2006
Location: Rockville,MD
Posts: 68
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by waterhead View Post

You need to use a modern nVidia graphics card. And the nVidia driver. not the built-in nouveau driver.
Any recommendations for video card? What if i went to a core i3 or i5 would i still need the video card?
Quote:
Originally Posted by Dark_Slayer 
Built my in-laws an openelec box with a g1610 / h61. No video playback problems whatsoever, cpu utilization can hit about 50-60% during 40GB mkv playback with hd audio decoding . . . small price to pay
I don't understand the requirements would be different for mkv, if uncompressed.
Remoteless is offline  
post #5 of 8 Old 11-10-2013, 03:53 AM
AVS Special Member
 
blackcat6's Avatar
 
Join Date: Aug 2010
Location: Charlotte
Posts: 1,059
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 20 Post(s)
Liked: 40
Quote:
Originally Posted by Remoteless View Post

Any recommendations for video card? What if i went to a core i3 or i5 would i still need the video card?
I don't understand the requirements would be different for mkv, if uncompressed.
It really doesn't take much. Even an Atom/Ion2 board will happily display 1080p content as long as you use the excellent VDPAU driver.

If you are looking for a card for a PC, then go with a GT 430 or one of it's newer equivalents. They can be found for less than $50.


(All digital video codecs are compressed.)
blackcat6 is online now  
post #6 of 8 Old 11-11-2013, 01:58 PM
AVS Special Member
 
Dark_Slayer's Avatar
 
Join Date: May 2012
Posts: 2,230
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 30 Post(s)
Liked: 215
Quote:
Originally Posted by Remoteless View Post

Any recommendations for video card? What if i went to a core i3 or i5 would i still need the video card?
I don't understand the requirements would be different for mkv, if uncompressed.

There aren't different requirements, and you don't need a video card. You do need to use playback software that lets you software decode since the integrated graphics are not up to the task of decoding and rendering.

G1610 running XBMC in linux will playback everything you throw at it except 3D and VC1 1080i (i.e. 3D movies or some 2D BBC blu-rays) with the settings above
Remoteless likes this.
Dark_Slayer is online now  
post #7 of 8 Old 12-10-2013, 01:22 PM - Thread Starter
Member
 
Remoteless's Avatar
 
Join Date: Feb 2006
Location: Rockville,MD
Posts: 68
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Dark_Slayer View Post

Not extremely familiar with VLC, but you need to disable HW acceleration for rendering. G1610 can software render blu ray all day long no tearing, but ivy bridge hd graphics are too weak.

If you were using XBMC, the settings needed should simply be deselecting the "Enable HW Acceleration (VAAPI)" radio button

and

Ensure the deinterlace settings are auto and a non-hw-accelerated scaling method is selected

Built my in-laws an openelec box with a g1610 / h61. No video playback problems whatsoever, cpu utilization can hit about 50-60% during 40GB mkv playback with hd audio decoding . . . small price to pay

Finally had some time to play with this due to the double snow storms. That was it Dark_Slayer solved 99% of the problem. Still see line in the middle third of picture during action, fire and some times at scene changes. CPU is running between high 40's and high 60's during playback.

If your using VLC under Input & Codecs deselect "Use GPU accelerated decoding" hit save then close VLC (you must restart VLC for changes to stick) cool.gif
Remoteless is offline  
post #8 of 8 Old 12-10-2013, 01:43 PM
AVS Special Member
 
Dark_Slayer's Avatar
 
Join Date: May 2012
Posts: 2,230
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 30 Post(s)
Liked: 215
Quote:
Originally Posted by Remoteless View Post

If your using VLC under Input & Codecs deselect "Use GPU accelerated decoding" hit save then close VLC (you must restart VLC for changes to stick) cool.gif

Glad you got it working. I have VLC installed on my Mint 15 notebook, so I took a look at the preferences.

Try the following as well . . . Preferences -> Video -> (deselect) Accelerated video output (Overlay)

I'd also switch deinterlace over to auto or any interlaced content will appear to stutter as well.
Dark_Slayer is online now  
Reply HTPC - Linux Chat

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off