My NUC HTPC does not respond to USB input devices. Help! - AVS Forum
HTPC - Linux Chat > My NUC HTPC does not respond to USB input devices. Help!
joel md's Avatar joel md 03:46 PM 03-17-2014
A few months ago I built myself an HTPC based on a NUC (Celeron processor) and loaded Ubuntu and XBMC on it. I controlled it with a Logitech K400 keyboard. It was working great until yesterday when the keyboard stopped working. I tried rebooting the NUC a few times, tried changing batteries in the keyboard, and tried putting the dongle in the other USB jack. Then I tried using a USB mouse from my desktop instead. Nothing is working. I cannot see a cursor on the screen. I'm running out of ideas! Is there anything else I can try? Do I need to re-install the OS?

waterhead's Avatar waterhead 10:25 PM 03-17-2014
Did you allow an update recently? Try booting into an older kernel. This can usually be done when the GRUB menu is shown for a short time during boot.

Otherwise, try a manual update to see if it fixes things.
Code:
sudo apt-get update
Code:
sudo apt-get upgrade

joel md's Avatar joel md 11:01 AM 03-18-2014
Yes, I believe there was an update of some kind that I allowed earlier that day. How do I interrupt the GRUB process? Is it a key like F2 or 'delete'? The bootloader is so quick I can't read anything on the screen before it disappears.
newlinux's Avatar newlinux 02:42 PM 03-18-2014
I think you press the right shift key or the ESC key to go the grub menu. Or alternatively you can configure your machine to always go to the menu.
joel md's Avatar joel md 07:49 PM 03-18-2014
Ok everyone, thanks for the tips. I was able to get the GRUB menu by pressing Shift on startup, and then I booted into the second newest kernel shown, which worked. I went into a terminal prompt and tried the sudo apt-get upgrade command, but when I restarted Ubuntu it went back to the keyboard not working. There must be a bad driver or something in the newest kernel. Is there a way I can delete that newest kernel? Otherwise I suppose I could modify GRUB so it prompts me at startup to choose which one to boot.
joel md's Avatar joel md 08:41 AM 03-20-2014
My previous post is now a moot issue. Yesterday Ubuntu prompted me to allow an update. It updated and created a new kernel. Then I restarted the machine while crossing my fingers. It worked! There must have been other people with the same USB driver issue to have an update released so soon after the previous one.
Up
Mobile  Desktop