Linux (Ubuntu) and SAMBA help - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 23 Old 01-04-2007, 12:45 PM - Thread Starter
Member
 
robertpolson's Avatar
 
Join Date: Oct 2006
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
#1 Please be language friendly I am a Linux noob, just installed it for the first time.

I have MediaGate MG350 HD players:

I want to make it play my network shared files. What I did so far was right click on the folder and share it using SMB - Read Only mode (I also tried none read only mode)

I can see the folders that I have shared on my mediagate player but I cannot access them.

What happens on my other windows computers when I try to access the folders - it asks me for the password and I have no idea what it is, my root password is not the correct one.

I have Ubuntu 6.10

Please help.
robertpolson is offline  
Sponsored Links
Advertisement
 
post #2 of 23 Old 01-04-2007, 01:55 PM
AVS Special Member
 
newlinux's Avatar
 
Join Date: Oct 2006
Location: Parts unknown
Posts: 1,540
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 14
I've never used the nautilus method of sharing using SMB, so I don't know what options it sets.

Look at http://ubuntuguide.org/wiki/Ubuntu_Edgy#Samba_Server

If you don't want any password you probably want to look at the Authentication=NO sections.
newlinux is online now  
post #3 of 23 Old 01-04-2007, 03:55 PM - Thread Starter
Member
 
robertpolson's Avatar
 
Join Date: Oct 2006
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I hate it that I have to make 5 posts to post a url :-(
robertpolson is offline  
post #4 of 23 Old 01-04-2007, 03:56 PM - Thread Starter
Member
 
robertpolson's Avatar
 
Join Date: Oct 2006
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Here is how my samba config looks:

http://pastebin.com/851420

At the end of the file I also added:

[public]
comment = Movies
path = /home/Movies
public = yes
writable = no


It does not work.


This guy here: #374390 - 12/15/05 04:56 PM

http://www.macworld.com/forums/ubbth...b=5&o=&fpart=1

Has it working, I tried his settings and still it does not work for me.

Any more ideas?
robertpolson is offline  
post #5 of 23 Old 01-05-2007, 06:48 AM
AVS Special Member
 
newlinux's Avatar
 
Join Date: Oct 2006
Location: Parts unknown
Posts: 1,540
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 14
The link to the smb.conf you posted doesn't follow the directions of the link I sent you to have no authentication (primarily, security=share is commented out). At this point it would probably help if you posted your entire smb.conf. This might sound too elementary but make sure you are stopping and restarting samba after you change your smb.conf for the changes to take effect. When you say the current configs don't work what do you mean? what happens when you try to access the SAMBA shares from windows? What permissions do you have set on the samba directories you are trying to share? Do you have the right workgroup set?
newlinux is online now  
post #6 of 23 Old 01-05-2007, 06:57 AM
Advanced Member
 
tbdombrosky's Avatar
 
Join Date: Oct 2002
Posts: 597
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have found that Windows sometimes caches the network sharing stuff, so it might ask you for a password when you don't need one (like let's say after you changed a config file and restarted samba). What helped me was using slightly different urls like "\\\\\\public" and "\\\\\\public". Also, try adding this line to your [public] section:

guest ok = yes

Tom
tbdombrosky is offline  
post #7 of 23 Old 01-05-2007, 09:06 AM - Thread Starter
Member
 
robertpolson's Avatar
 
Join Date: Oct 2006
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Here is how my smb.conf looks

http://pastebin.com/851988

security=share

is there


I also followed this guide here - post #2 for my question:

http://www.linuxquestions.org/questi...d.php?t=516455


Same thing happnes again, mediagate - whenever I try to access any of the folders it sees them but once I try to enter it it tries to open it and it cannot, just open a blank page and only option I have is to go back to folder list.

On windows machine it still asks me for the password. ? I though that "security = share" will make it so that it will not ask for the password.

Yes, I do restart samba after I change my smb.conf


"Do you have the right workgroup set?" does this matter? Back when I had windows, it did not matter what kind of workgorup I had for mediagate to access my windows shared files, I did had to enable Guest and "Everyone" account though.

Any more ideas ?
robertpolson is offline  
post #8 of 23 Old 01-05-2007, 09:47 AM
AVS Special Member
 
newlinux's Avatar
 
Join Date: Oct 2006
Location: Parts unknown
Posts: 1,540
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 14
I don't know about the kind of workgroup, but the name of the workgroup often matters. Most windows machine default to MSHOME, so unless you changed it in windows that should be fine. You might want to double check. You did not answer my question about the linux file permissions? How are the permissions set on the folders and files you are trying to share? You can do:

ls -l /media/Media/Movies


to see the permissions of the files.

You might want to check the permissions of the directory as well. When I have some more times I may look a little more closely. But you'll get better help on the ubuntuforums, if you haven't already asked/searched there...
newlinux is online now  
post #9 of 23 Old 01-05-2007, 10:01 AM - Thread Starter
Member
 
robertpolson's Avatar
 
Join Date: Oct 2006
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
slyfox@laptopishe:~$ ls -l /media/Media/Movies
total 1429656slyfox@laptopishe:~$ ls -l /media/Media/Movies
total 1429656
-r-x------ 1 slyfox slyfox 670 2006-11-23 15:27 desktop.ini
dr-x------ 1 slyfox slyfox 24576 2007-01-04 10:17 Documentaries
dr-x------ 1 slyfox slyfox 0 2006-06-06 19:13 Magic
dr-x------ 1 slyfox slyfox 4096 2006-12-31 14:36 Martial Arts
dr-x------ 1 slyfox slyfox 8192 2007-01-01 17:03 Movies
dr-x------ 1 slyfox slyfox 0 2007-01-01 12:36 TV
-r-x------ 2 slyfox slyfox 1463924736 2006-12-29 21:09 V_Pogone_by.tracker.BiNuRaL.Ru.avi



No idea what all this means...


Can you also tell me how do I change the file permission and directory permission ?
robertpolson is offline  
post #10 of 23 Old 01-05-2007, 10:34 AM
AVS Special Member
 
newlinux's Avatar
 
Join Date: Oct 2006
Location: Parts unknown
Posts: 1,540
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 14
You can use chmod to change permissions (man chmod). Your linux permissions look like part of your problem. only slyfox has read permissions. Using chmod a+r on your directory

try:

chmod a+r -R /media/Media/Movies

This command says to give owner, group, and others read access to the directory and all files it contains.
newlinux is online now  
post #11 of 23 Old 01-05-2007, 10:58 AM - Thread Starter
Member
 
robertpolson's Avatar
 
Join Date: Oct 2006
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Still does not work.

I guess linux is just not for me. I have to go back to Windows Vista.
robertpolson is offline  
post #12 of 23 Old 01-06-2007, 04:38 AM
AVS Special Member
 
Troubleshooter's Avatar
 
Join Date: Aug 2001
Location: Southern Cowhampshire
Posts: 1,670
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
did you run smbpasswd and create a user/passwd for smb???
Troubleshooter is offline  
post #13 of 23 Old 01-06-2007, 12:40 PM - Thread Starter
Member
 
robertpolson's Avatar
 
Join Date: Oct 2006
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Yes I did, however that will be useless as Mediagate requires access without password.

I "think" I created the users correctly - Guest is the user I created, but then I could not have that user without a password.

It is a shame.

I uninstalled Ubuntu and installed Vista. Perhpas some time later smaba will catch up to function properly without wasting all day in a txt file.

Thank you very much for you help though. I wanted open source to work, but it is too early.

Anotehr problem with Linux is that there is no Internet Explorer there, there is via wine and I tried it, but there is no way to make the fonts big enough for my 1680x1050 resolution and it is pain to look at tiny fonts.

Why explorer? Because the stupid site I need for work only supports Internet Explorer. :-(
robertpolson is offline  
post #14 of 23 Old 01-06-2007, 05:04 PM - Thread Starter
Member
 
robertpolson's Avatar
 
Join Date: Oct 2006
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
On the second thought, I really do want to switch to open source Linux.

If someone can still help to solve this problem, this would be great.
robertpolson is offline  
post #15 of 23 Old 01-06-2007, 11:18 PM - Thread Starter
Member
 
robertpolson's Avatar
 
Join Date: Oct 2006
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I did get it working but only for ext3 ubuntu folder. I cannot share fat32 flash drive or my 400 gig NTFS drive.

Any ideas?

The only way I could share my fat32 usb flash drive is if I add

force user = root which is not a good thing

If I do not add this line and share it the stadard way, windows sees the folder but cannot enter it.

This is my samba.conf that worked for ext3 folder share:

http://pastebin.com/853328

Any more ideas ?
robertpolson is offline  
post #16 of 23 Old 01-10-2007, 08:55 AM
Member
 
robselina's Avatar
 
Join Date: Dec 2006
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by robertpolson View Post

I did get it working but only for ext3 ubuntu folder. I cannot share fat32 flash drive or my 400 gig NTFS drive.

Any ideas?

The only way I could share my fat32 usb flash drive is if I add

force user = root which is not a good thing

If I do not add this line and share it the stadard way, windows sees the folder but cannot enter it.

This is my samba.conf that worked for ext3 folder share:

http://pastebin.com/853328

Any more ideas ?

How are your flash drive and NTFS drive mounted? Can users other than root browse through them? I've never had smb care about the partition format. I'll mention that linux support for NTFS is rather weak, but FAT is well supported, so if you have partitions you want to share between the two, best to format them as FAT instead of NTFS.

BTW, setting up cups (printing) and samba were the two hardest things to configure in any of the linux installs I've done, but once they work they work REALLY well. I think the print server and file server (single box) at home has been up for more than two months w/o interruption. I've completely forgotten about all the fun of rebooting windows machines because the printer crashed or I can't see the shared folder on my wife's XP machine, etc. Get past this hurdle and any other config problems will seem easy by comparison
robselina is offline  
post #17 of 23 Old 01-10-2007, 10:24 AM
AVS Special Member
 
newlinux's Avatar
 
Join Date: Oct 2006
Location: Parts unknown
Posts: 1,540
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 14
Maybe you can try force user=nobody and you should be able to use a guest account.

FAT32 has too many limitation, and requires frequent defragging. I would go with ext3 filesystems and use fs-driver on windows to read and write to them. No defragging necessary, no 4GB file size limit. Works well for me.

Unfortunately for me, the computer that is my print server is booted to XP most of the time (because that's what my wife like to use). So I have to go through the occasional (seems to be at least weekly) reboot. Meanwhile all my other boxes are linux sharing through Samba and they are all rock solid. I never reboot them. Good thing I don't need to print that often.
newlinux is online now  
post #18 of 23 Old 01-10-2007, 10:30 AM
AVS Special Member
 
newlinux's Avatar
 
Join Date: Oct 2006
Location: Parts unknown
Posts: 1,540
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 14
Also, I'm curious, what changes made the ext3 work for you?
newlinux is online now  
post #19 of 23 Old 01-10-2007, 06:28 PM - Thread Starter
Member
 
robertpolson's Avatar
 
Join Date: Oct 2006
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I will run these tests and will post back.

Meanwhile, I have no idea what to do with my external hard drive. It is a NTFS drive and should I convert it to fat32? But then you say that fat32 sucks, I do write a lot of data to my external drive so fragmentation will be a problem.

On the other hand, formatting 400 gigs external drive to a ext3 is something I am not sure about.

I will see and will post back.
robertpolson is offline  
post #20 of 23 Old 01-10-2007, 06:37 PM
Advanced Member
 
bac522's Avatar
 
Join Date: Jan 2003
Posts: 855
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 30 Post(s)
Liked: 45
http://www.webmin.com/ really makes administrating a linux server easy, especially when trying to get items like samba working.
bac522 is offline  
post #21 of 23 Old 01-10-2007, 07:30 PM
Newbie
 
flowbot's Avatar
 
Join Date: Jan 2007
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by robertpolson View Post

I did get it working but only for ext3 ubuntu folder. I cannot share fat32 flash drive or my 400 gig NTFS drive.

Any ideas?

The only way I could share my fat32 usb flash drive is if I add

force user = root which is not a good thing

If I do not add this line and share it the stadard way, windows sees the folder but cannot enter it.

This is my samba.conf that worked for ext3 folder share

Any more ideas ?

thanx dude - you're a legend. was having the exact same problem on ubuntu 6.10 with not being able to see inside the shared folders - i copied your smb.conf, and now all works fine.

ONE THING i need to know, though - is it possible to write to the MediaGate's HardDrive wirelessly from linux box? If so, would it be via Samba or NFS (or some other protocol)?

Surely this should be possible, though i know there is no NDAS access from linux ... I've tried using Gnome's Network Browser to find the MediaGate's hard drive, but no cigar ....

any help much appreciated, and thanx again for providing with info to allow to access linux box from MediaGate.
flowbot is offline  
post #22 of 23 Old 01-12-2007, 07:53 AM
Member
 
FreeFire's Avatar
 
Join Date: Aug 2005
Location: Norman, OK
Posts: 196
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I think you may still have problems with your permissions. With a directory, only giving read access won't let you access the directory, and won't let you change files. I would do a
chmod a+rwx -R /media/Media/Movies
to give everyone access to look and change the files.

Here's a reference you can read about these permissions:

http://www.samspublishing.com/librar...eqNum=227&rl=1

Hope it helps. Right now even the user slyfox can't change the directory, only root can.
FreeFire is offline  
post #23 of 23 Old 01-16-2007, 12:57 PM - Thread Starter
Member
 
robertpolson's Avatar
 
Join Date: Oct 2006
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Try to mount Mediagate and see if it works. Something like this:

//192.168.1.10/windowshare /mnt/winshare smbfs credentials=/root/.smbcredentials,dmask=777,fmask=777

dmask=777,fmask=777 gives the write permission.

Although I do not really know what they mean, they do allow to write.

I am a Linux noob.

Taken from here:

http://www.ubuntuforums.org/showthre...=337482&page=4
robertpolson is offline  
Reply HTPC - Linux Chat

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off