xpress 200 with component-out fglrx in 720p - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 9 Old 02-27-2007, 12:23 AM - Thread Starter
Member
 
voisine's Avatar
 
Join Date: Mar 2006
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have an xpress 200 integrated video board with component-out cable. It works great in text mode, it's sharp, no flicker. I'm using the fglrx drivers in X windows, but strangely with component-out I can only get it to display properly in 1080i. It's 30hz so it's a bit flickery, and the tv is native 720p so it's downscalled and looks fuzzy. When I set the resolution to other non-hdtv modes like 1280x1024, it appears to display in 1080i with black bars. When I set it to another hdtv mode like 1280x720 60hz, the display is completetly screwed up, almost like the tv is trying to display a 720p signal in 1080i or something like that. Does anyone know the trick to get fglrx to display 720p over component-out properly?
voisine is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 03-08-2007, 12:45 AM
Member
 
kofboy's Avatar
 
Join Date: Aug 2005
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
whitch moth-board do you have? ASROCK HDTV TWINS?
component-out cable connect to DVI-port or directly from moth-board ?
did component-out can be seen from boot time?
kofboy is offline  
post #3 of 9 Old 03-08-2007, 12:52 AM - Thread Starter
Member
 
voisine's Avatar
 
Join Date: Mar 2006
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Sorry, I'm a moron. Turns out the TV is not native 720p. It's got 800 somthing scanlines and only accepts 408p, 480i, and 1080i on component input. It's a 5 year old Samsung TXM-3098WHF. The motherboard is a DFI Infinity RS482.
voisine is offline  
post #4 of 9 Old 03-08-2007, 03:19 AM
Member
 
kofboy's Avatar
 
Join Date: Aug 2005
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
use radeonfb and set modeline in /etc/fb.modes. then set resolution use fbset.

i can set to 720p and watch DVD useing mplayer throuth VGA port
kofboy is offline  
post #5 of 9 Old 03-21-2007, 12:09 PM
Member
 
kofboy's Avatar
 
Join Date: Aug 2005
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
would u post your component-out config file of X11?

Thanks
kofboy is offline  
post #6 of 9 Old 03-21-2007, 01:01 PM - Thread Starter
Member
 
voisine's Avatar
 
Join Date: Mar 2006
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I was just using the default X11 config after installing ubuntu and the fglrx package. It was working in 1080i mode with no special configuration.
voisine is offline  
post #7 of 9 Old 03-27-2007, 08:28 AM
Member
 
kofboy's Avatar
 
Join Date: Aug 2005
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
then post the log /var/log/Xorg.0.log
kofboy is offline  
post #8 of 9 Old 03-27-2007, 09:53 AM - Thread Starter
Member
 
voisine's Avatar
 
Join Date: Mar 2006
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I think the relavent lines are:

(**) fglrx(0): *Mode "1920x1080": 74.2 MHz (scaled from 0.0 MHz), 33.7 kHz, 30.0 Hz (I)
(II) fglrx(0): Modeline "1920x1080" 74.17 1920 1963 2004 2200 1080 1084 1094 1125 interlace
(**) fglrx(0): *Mode "1280x720": 74.2 MHz (scaled from 0.0 MHz), 45.0 kHz, 60.0 Hz
(II) fglrx(0): Modeline "1280x720" 74.17 1280 1347 1384 1650 720 725 730 750
voisine is offline  
post #9 of 9 Old 03-28-2007, 08:12 PM
Member
 
kofboy's Avatar
 
Join Date: Aug 2005
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
maybe some part of detect monitor in the log, and EDID, DDC?
kofboy is offline  
Reply HTPC - Linux Chat

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off