Need help with my new Russound 6.4? - AVS | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!


Forum Jump: 
 
Thread Tools
post #1 of 1 Old 05-16-2001, 09:58 PM - Thread Starter
Member
 
GoBlue's Avatar
 
Join Date: Mar 2001
Location: Dallas, TX, USA
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I received my new Russound 6.4 yesterday. I excitedly installed all the in-wall volume/source/ir controllers and then went to hook everything up to the amp. On the back is a bank of silver metal rods that look like jumpers you would find on a hard drive or a computer motherboard. The directions say to remove the connectors and attach the speakers wires. I don't see any connectors to remove and have no way to attach the wire to the rods/jumpers. The back also looks different than the picture. I'm wondering if my unit is missing the speaker connectors? BTW, the connectors for the Controllers (Cat5E) also looks the same. Something missing there too?
GoBlue is offline  
Sponsored Links
Advertisement
 
Closed Thread Speakers

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off