Definitive Technology Mythos Series Thread - Page 187 - AVS Forum
Forum Jump: 
Reply
 
Thread Tools
post #5581 of 5584 Old 09-24-2014, 10:37 PM
Senior Member
 
K5/SS's Avatar
 
Join Date: Mar 2011
Location: Seattle
Posts: 226
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 40
Just realized there is an entire thread dedicated to Mythos owners. I just picked up some Mythos STS towers, Mythos 9 center and two mythos 5's for my surrounds.

I am in love with this system so far. I will probably be ordering 2 new gloss SVS SB-2000's or one SB-Ultra in a few weeks. I am sure I will have some setup questions for you experts in the near future...

Oppo BDP103, Mitsubishi WD8240, Klipsch RF-63's, Pioneer Elite SC-25, Furman Elite 15, Emotiva XPA-5, Harmony 1100, Rythmik FV15HP

K5/SS is offline  
Sponsored Links
Advertisement
 
post #5582 of 5584 Old 09-25-2014, 12:33 PM
Member
 
sm4llz's Avatar
 
Join Date: Nov 2012
Posts: 78
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Liked: 13
Congrats! I have Mythos St for my fronts and just got dual PB-2000. Love them! Depending on your room i'd dual over single.
sm4llz is online now  
post #5583 of 5584 Old 09-25-2014, 07:21 PM
Senior Member
 
K5/SS's Avatar
 
Join Date: Mar 2011
Location: Seattle
Posts: 226
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 40
I bet those PB-2000's sound great! If they were offered in gloss black, I'd probably go that direction. I am a person obsessed with symmetry so if I went with the SB-Ultra, I would probably order another once my bank account healed a little

Oppo BDP103, Mitsubishi WD8240, Klipsch RF-63's, Pioneer Elite SC-25, Furman Elite 15, Emotiva XPA-5, Harmony 1100, Rythmik FV15HP

K5/SS is offline  
post #5584 of 5584 Old Yesterday, 04:37 PM
Newbie
 
Join Date: Sep 2014
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
Unhappy ST-Ls sound "muddy" or blown?

Hi,

I just received an order from Crutchfield of two ST-Ls, (one open box and one scratch and dent). I also got some open box Gem XLs and an open box ten.

When hooking the ST-Ls up and taking my first in-home listen, one of them sounds like the mid driver is blown and the other sounds similar but less so. I have tried 3 different AV Receivers that currently drive different speakers in my home. One 8 year old Yamaha, one 3 year old Sony and a completely refurbished Sansui 4000. I have also tried three different sets of speaker cables. I even moved them to a different floor of the house to be sure I was on a different AC circuit. I get the same result each time, one sounds a bit more muddy than the other. The same cables and receivers driving the ten and Gems sound great. I have left the jumpers in place and connected the speakers using the top + and - terminals.

I am trying to think of anything I might be setting up incorrectly. Did I just "get what I paid for"? (open box/scratch n dent?).

Any insight welcome.

Thanks.
Mr_Dent is offline  
Reply Speakers

Tags
Definitive Technology Bp8 Tower Loudspeaker Single Black , Definitive Technology Mythos 6 Aluminum Stand , Definitive Technology Mythos 1 Tower Speaker , Definitive Technology Mythos St 120v Supertower Speaker Single Black , Definitive Technology Mythos Sts 120v Supertower Speaker Single Black , Definitive Technology Bp7006 120v Tower Speaker Single Right Channel Black , Definitive Technology Mythos 4 Tower Speaker Single Black , Definitive Technology Mythos 5 Tower Speaker Single Black , Definitive Technology Mythos 7 Center Speaker , Definitive Technology Mythos 3 Center Channel Speaker Single Black , Speaker Systems , Definitive Technology , Definitive Technology Mythos Xtr 50 On Wall Or Shelf Mounting Ultra Thin Loudspeaker Black
Gear in this thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off