Mythos STS speaker cabinet rattling - AVS | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!


Forum Jump: 
 
Thread Tools
post #1 of 10 Old 04-20-2010, 06:27 PM - Thread Starter
Member
 
jpenndcl's Avatar
 
Join Date: Jun 2008
Posts: 34
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I recently purchased a pair of STS and when I got them home I put the granite base on and hooked them up. I turned the base volume to 1am like the owner's manual suggested and played Billy Idol's Prodigal Blues. I walked around the back of the speaker while they were playing and heard a little rattling and squeaking noise coming from the speaker. I think the squeaking was coming from the base and tightened the screws, which seemed to help. The rattling however continued and seemed to come from the side of the tower (inside) and up near the cap of the tower. Has anyone had anything like this happen to them?
jpenndcl is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 04-20-2010, 09:30 PM
AVS Special Member
 
Snowmanick's Avatar
 
Join Date: Nov 2007
Posts: 1,637
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 65 Post(s)
Liked: 143
"near the cap of the tower"? Do you mean the top of the speaker? I haven't noticed any rattling from my STS's, and the top where the MTM is seems to actually be the most acoustically inert surface on the tower. Have you tried emailing DefTech support?

~Nick

Augustine's Law: "The last 10% of performance generates one-third of the cost and two-thirds of the problems."

"If it works the first time, it's not high end." ~ Harry Pierson
Snowmanick is offline  
post #3 of 10 Old 04-21-2010, 06:11 AM - Thread Starter
Member
 
jpenndcl's Avatar
 
Join Date: Jun 2008
Posts: 34
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Snowmanick View Post

"near the cap of the tower"? Do you mean the top of the speaker? I haven't noticed any rattling from my STS's, and the top where the MTM is seems to actually be the most acoustically inert surface on the tower. Have you tried emailing DefTech support?

Yes, the top of the speaker. It is a buzzing/rattling noise when the base fires. It sounds internal to me or like the top of the speaker is rattling where it meets the side. Also, I heard a little rattle/buzz coming from the middle of the side of the speaker that seemed to go away when I pushed in on both sides of the speaker. Anyone have this issue or know what might be causing it?
jpenndcl is offline  
post #4 of 10 Old 04-21-2010, 08:19 AM
AVS Special Member
 
Snowmanick's Avatar
 
Join Date: Nov 2007
Posts: 1,637
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 65 Post(s)
Liked: 143
Try taking the grill off and listening again. I have heard a couple stories of the grill pins rattling.

~Nick

Augustine's Law: "The last 10% of performance generates one-third of the cost and two-thirds of the problems."

"If it works the first time, it's not high end." ~ Harry Pierson
Snowmanick is offline  
post #5 of 10 Old 05-15-2010, 06:29 PM
Senior Member
 
FSUguy's Avatar
 
Join Date: Jan 2008
Location: Tampa, FL
Posts: 246
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
One of my buddies had a similar problem with his ST's, but he also heard a humming, which Def Tech the replaced the speaker.
FSUguy is offline  
post #6 of 10 Old 07-12-2010, 08:00 PM
Member
 
barry1me's Avatar
 
Join Date: May 2010
Posts: 34
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
I notice I have a slight rattle/Buzz at the top of my STSs. I will be calling Deffinitive tomorrow. Did you get your speakers fixed?
barry1me is offline  
post #7 of 10 Old 07-12-2010, 08:38 PM
AVS Special Member
 
Snowmanick's Avatar
 
Join Date: Nov 2007
Posts: 1,637
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 65 Post(s)
Liked: 143
Also verify all the screws are tightened. Vibration/transport may cause them to back out a touch. And there are a lot of screws.

~Nick

Augustine's Law: "The last 10% of performance generates one-third of the cost and two-thirds of the problems."

"If it works the first time, it's not high end." ~ Harry Pierson
Snowmanick is offline  
post #8 of 10 Old 07-12-2010, 08:45 PM
AVS Special Member
 
Espo77's Avatar
 
Join Date: Nov 2002
Location: Delmarva Peninsula, Maryland
Posts: 1,974
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 15
Quote:
Originally Posted by jpenndcl View Post

I recently purchased a pair of STS and when I got them home I put the granite base on and hooked them up. I turned the base volume to 1am like the owner's manual suggested and played Billy Idol's Prodigal Blues. I walked around the back of the speaker while they were playing and heard a little rattling and squeaking noise coming from the speaker. I think the squeaking was coming from the base and tightened the screws, which seemed to help. The rattling however continued and seemed to come from the side of the tower (inside) and up near the cap of the tower. Has anyone had anything like this happen to them?

FWIW, that song is LOADED with tons of very deep bass. Knowing this, I would have been a little more cautious at first and perhaps turned the bass down. This recording is capable of doing damage to a speaker. I hope your speaker is okay...did you keep the box and packaging?

Espo77
Espo77 is offline  
post #9 of 10 Old 08-06-2010, 10:13 AM - Thread Starter
Member
 
jpenndcl's Avatar
 
Join Date: Jun 2008
Posts: 34
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Espo77 View Post

FWIW, that song is LOADED with tons of very deep bass. Knowing this, I would have been a little more cautious at first and perhaps turned the bass down. This recording is capable of doing damage to a speaker. I hope your speaker is okay...did you keep the box and packaging?

I set them to the factory recommended settings was pretty careful turning them on because it was the first time they had been used and I am sure they have a break in period (like a new car). I did keep the packaging and ended up sending it back. Received a new set and they did not rattle.
jpenndcl is offline  
post #10 of 10 Old 08-06-2010, 02:48 PM
Senior Member
 
yosh7's Avatar
 
Join Date: Aug 2007
Posts: 405
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 55 Post(s)
Liked: 31
Quote:
Originally Posted by jpenndcl View Post

I set them to the factory recommended settings was pretty careful turning them on because it was the first time they had been used and I am sure they have a break in period (like a new car). I did keep the packaging and ended up sending it back. Received a new set and they did not rattle.

First, as a previous poster mentioned, try without the grills on. This was a problem with the ST's in the past. If its the grills, that should be an easy fix under warranty. If it still rattles with grills off, then take back to dealer to be replaced! Most all def tech dealers are excellent to work with, especially because problems like this are not frequent. I had a problem with my st binding post when I brought it home. I called the dealer and had a replacement within a few days. Also, the best person to speak with at def tech customer support is Chet. I have spoken with someone live every time I have called. Def Tech has great customer service.

The bottom line- you have awesome speakers that should be able to be played loud with tons of bass with 0 defects. If there is a problem, don't live with it - get it fixed or replaced. Good luck!
yosh7 is offline  
Sponsored Links
Advertisement
 
Reply Speakers

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off