Energy take classic..static in one speaker? - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 11 Old 11-02-2011, 08:04 PM - Thread Starter
Member
 
bahuffma's Avatar
 
Join Date: Oct 2011
Location: North Carolina
Posts: 69
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
So I just hooked up my new take classics, and one of the speakers has some static noise occasionally (when scene volume increases). I understand that there is a break in period, and have not turned them up very much at all? All I have done is run odessy setup and watch alittle tv. Could it be that it is blown??
bahuffma is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 11-02-2011, 08:18 PM
Senior Member
 
Havok305's Avatar
 
Join Date: Sep 2007
Location: Miami, FL
Posts: 294
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Try switching your L&R and see if it continues to do it.
Havok305 is offline  
post #3 of 11 Old 11-03-2011, 12:24 AM
AVS Special Member
 
Macstatic's Avatar
 
Join Date: May 2011
Location: Mesa, Arizona
Posts: 1,663
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 21
I don't think it's blown. Is it like a soft popping sound? I occasionally had that issue with one of my Take Classic speakers but it resolved itself apparently because it doesn't do it anymore and only thing I did was make sure wires were hooked up right. (but that didn't solve it right away)

For those looking into getting Energy speakers, or upgrading their current Energy setup, here are some reviews I've written that may help:http://www.tempestaudio.blogspot.com  (haven't updated in a while, but include Energy Take Classic 5.1, RC-10, CF-70, and CC-10)

Macstatic is offline  
post #4 of 11 Old 11-03-2011, 04:45 AM - Thread Starter
Member
 
bahuffma's Avatar
 
Join Date: Oct 2011
Location: North Carolina
Posts: 69
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Yeah, i will try switching the speakers when i get home this evening. The noise is more like a static buzz (a little chirpy) than a soft popping...and almost like a robotic voice when there is dialogue. Again, this only occurs at a certain volume level (which is not too high). I was able to gradually turn up the volume a little at a time, and then reach a point when it starts. It seem to start after i was switching between modes on the receiver?? Oh well, hopefully it is not blown and will go away.

Also, fyi, i am using about 25 ft of 16 ga wire (new) and a new denon 1611 avr.
bahuffma is offline  
post #5 of 11 Old 11-03-2011, 07:26 AM
AVS Special Member
 
Macstatic's Avatar
 
Join Date: May 2011
Location: Mesa, Arizona
Posts: 1,663
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 21
Call Energy and talk with them. If anything they've seen this problem before and may give you a way to swap te speaker or a part in the speaker.

For those looking into getting Energy speakers, or upgrading their current Energy setup, here are some reviews I've written that may help:http://www.tempestaudio.blogspot.com  (haven't updated in a while, but include Energy Take Classic 5.1, RC-10, CF-70, and CC-10)

Macstatic is offline  
post #6 of 11 Old 11-03-2011, 07:55 AM - Thread Starter
Member
 
bahuffma's Avatar
 
Join Date: Oct 2011
Location: North Carolina
Posts: 69
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Do you know what Energy's hours are? I want to check some things when i get home (wiring, etc.) before i call them and that won't be until 5 thirty est.
Thanks
bahuffma is offline  
post #7 of 11 Old 11-03-2011, 08:29 AM
AVS Special Member
 
Macstatic's Avatar
 
Join Date: May 2011
Location: Mesa, Arizona
Posts: 1,663
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 21
http://www.energy-speakers.com/na-en/support

That's the page that has their support phone number and e-mail. Unfortunately I can't find their hours anywhere, but I'm guessing they are open 8am-5pm EST Mon-Fri. I think they have different hours for Saturday (if any). Hopefully this helps.

Like you said you're going to do, check connections and I'd run down the entire wire to check for any defects in the wire (slits, knots, etc).

For those looking into getting Energy speakers, or upgrading their current Energy setup, here are some reviews I've written that may help:http://www.tempestaudio.blogspot.com  (haven't updated in a while, but include Energy Take Classic 5.1, RC-10, CF-70, and CC-10)

Macstatic is offline  
post #8 of 11 Old 11-03-2011, 02:19 PM - Thread Starter
Member
 
bahuffma's Avatar
 
Join Date: Oct 2011
Location: North Carolina
Posts: 69
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Ok..so after some troubleshooting (changing wire/switching left and right) i am convinced that there is an issue with the speaker. I contacted Energy and discussed the issue. One question that he had was the amplifier output of the receiver (questioning whether or not it is too powerful for the take classics). The receiver i have is a denon 1611, and from what i can tell the amplifier output is either 75W or 115W for surround speakers. I believe I was told that the denon 1611 would pair nicely with the take classics..is this the case??
Also, the guy i spoke with had me email my info. The guy seemed slightly irritated with me so i did not ask him to repeat the email address. I sent it to technicalsupport@klipsch.com. Is this right?? On the klipsch website i see an email address of support@klipsch.com (without the word technical).
Also, does anyone know the procedure Energy follows to replace damaged speakers? The guy i talked to said something along the lines that the cost of shipping back my damaged speaker, and the phone call, would cost more than replacing the speaker??Thanks
bahuffma is offline  
post #9 of 11 Old 11-03-2011, 03:02 PM
AVS Addicted Member
 
afrogt's Avatar
 
Join Date: Jul 2003
Location: SF Bay Area
Posts: 22,701
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 35 Post(s)
Liked: 346
The Denon 1611 is perfect for Take Classics. 75w per channel @ 8 ohms.

When I had a blown Take driver they just sent me a replacement and I put it in myself.

Where did you buy your Takes from?

Afro GT
afrogt is offline  
post #10 of 11 Old 11-03-2011, 03:08 PM - Thread Starter
Member
 
bahuffma's Avatar
 
Join Date: Oct 2011
Location: North Carolina
Posts: 69
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Bought them from vanns.com
bahuffma is offline  
post #11 of 11 Old 11-03-2011, 03:47 PM
AVS Special Member
 
Macstatic's Avatar
 
Join Date: May 2011
Location: Mesa, Arizona
Posts: 1,663
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 21
Quote:
Originally Posted by bahuffma View Post

Bought them from vanns.com

Cool. Vanns is an authorized dealer for Energy

For those looking into getting Energy speakers, or upgrading their current Energy setup, here are some reviews I've written that may help:http://www.tempestaudio.blogspot.com  (haven't updated in a while, but include Energy Take Classic 5.1, RC-10, CF-70, and CC-10)

Macstatic is offline  
Reply Speakers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off