Mounting MartinLogan MLT-2 speakers - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 11-11-2011, 10:48 AM - Thread Starter
Newbie
 
kmusku's Avatar
 
Join Date: Oct 2011
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi All,

I recently bought MartinLogan MLT-2 series, and I'm planning to mount these on my wall. But when I look at the back of the speakers, there are 2 holes which seems to be meant for mounting, but I don't see any threads to these holes, so that the screws fit them tightly.

Can someone please help regarding this like how to mount these speakers.

Thanks.
kmusku is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 11-12-2011, 04:47 AM
AVS Special Member
 
buzzy_'s Avatar
 
Join Date: Jan 2006
Posts: 2,461
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 46
Congratulations. Nice speakers.

Your set must have arrived without the manual. Here's a replacement:
http://www.martinlogan.com/pdf/manuals/manual_mlt2.pdf
See page 7.

They have keyhole mounts, often used on light speakers like these. You put a screw into the wall, and hang the speaker on the screw, kind of like you'd hang a picture.

It says "If model has two key holes, measure distance apart and use two screws." You can adjust the angle a little by how far out you leave the screws.

You don't need heavy duty screws, anything that will stay in the wall will do for these.
buzzy_ is offline  
post #3 of 3 Old 07-09-2013, 06:22 PM
Newbie
 
scottw311's Avatar
 
Join Date: Jul 2013
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I used a #12 machine screw in the top hole on the back of the speaker to mount to brateck sb-29 wall mounts. Holds nice and tight, no issues whatsoever.
scottw311 is offline  
Reply Speakers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off