Rti 12 prices? - AVS | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!


Forum Jump: 
 
Thread Tools
Old 01-11-2012, 04:49 AM - Thread Starter
Member
 
bkgraham33's Avatar
 
Join Date: Oct 2007
Posts: 78
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Is $680 about as good as it gets for a pair of RTI12 speakers these days?

Fry's is virtually the only place I can find them.
bkgraham33 is offline  
Sponsored Links
Advertisement
 
Old 01-11-2012, 07:03 AM
AVS Special Member
 
chashint's Avatar
 
Join Date: Oct 2008
Location: Dallas, TX
Posts: 1,713
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Liked: 46
Yes

Regards,
Charlie

chashint is offline  
Old 01-11-2012, 07:38 AM
AVS Special Member
 
gtpsuper24's Avatar
 
Join Date: Aug 2008
Location: Ohio
Posts: 2,087
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 94
Check out Polks refrub store on Ebay, I almost got ahold of a pair of RTi12s for around $540ish.
gtpsuper24 is online now  
Old 01-11-2012, 08:28 AM
Newbie
 
Cabrito24's Avatar
 
Join Date: Jan 2012
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Those speakers are great!
Cabrito24 is offline  
Old 01-11-2012, 10:19 AM
Member
 
IndyStreetRacer's Avatar
 
Join Date: Nov 2006
Location: Indiana
Posts: 100
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 11
Yes, Fry's is the only place I could find them also. The cherry finish they just ended up giving away. The price on their website last week was $49.00 each for the 12's. I tried to call and sweet talk them into price matching the black sets they still have in stock. They said the cherry were discontinued. I informed them the black were also discontinued, they would not budge from the price. I tried.
IndyStreetRacer is online now  
Old 01-11-2012, 11:16 AM - Thread Starter
Member
 
bkgraham33's Avatar
 
Join Date: Oct 2007
Posts: 78
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by IndyStreetRacer View Post

Yes, Fry's is the only place I could find them also. The cherry finish they just ended up giving away. The price on their website last week was $49.00 each for the 12's. I tried to call and sweet talk them into price matching the black sets they still have in stock. They said the cherry were discontinued. I informed them the black were also discontinued, they would not budge from the price. I tried.

I sure do wish the Fry's in my area had the RTI 8s in stock right now.... I'm just waiting..... thinking about getting the 12s if I can't find the 8s soon.
bkgraham33 is offline  
Old 01-11-2012, 11:56 AM
AVS Special Member
 
Geoff4RFC's Avatar
 
Join Date: May 2010
Location: Just down aways from Stanley
Posts: 3,871
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 106 Post(s)
Liked: 1417
Quote:
Originally Posted by IndyStreetRacer View Post

Yes, Fry's is the only place I could find them also. The cherry finish they just ended up giving away. The price on their website last week was $49.00 each for the 12's. I tried to call and sweet talk them into price matching the black sets they still have in stock. They said the cherry were discontinued. I informed them the black were also discontinued, they would not budge from the price. I tried.

49 bucks for a new RTi12???? Are you serious??

Spinning the rear tire at 150mph while at 3/4 lean angle will put wrinkles in your seat


Set up:
Integra 70.4--Oppo 103--LG50"Plasma--Emotiva: XPA-3, XPA-2 x 2--PolkAudio: RTiA9 x 4--CSiA6--FXiA6 x 4--Epik: Empire x 2--XBOX 360--Furez 10awg homemade cables
Geoff4RFC is offline  
Old 01-11-2012, 06:24 PM
AVS Special Member
 
CalgaryCowboy's Avatar
 
Join Date: Aug 2006
Location: Calgary, Canada
Posts: 1,250
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Geoff4RFC View Post

49 bucks for a new RTi12???? Are you serious??

I assume that is typo but was it $249, $149...I am watching for these my brother is in the market for speakers and lives close to serveral Fry's

My review comparisons of Energy RC-70s to Veritas V6.3 http://www.avsforum.com/avs-vb/showt...8#post21199418
CalgaryCowboy is offline  
Old 01-11-2012, 09:18 PM - Thread Starter
Member
 
bkgraham33's Avatar
 
Join Date: Oct 2007
Posts: 78
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Went ahead and picked up the 12s tonight. Mt vsx-1021 came in today also. Lots of stuff to try and figure out, that's for sure.
bkgraham33 is offline  
Old 01-11-2012, 09:57 PM
AVS Special Member
 
Geoff4RFC's Avatar
 
Join Date: May 2010
Location: Just down aways from Stanley
Posts: 3,871
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 106 Post(s)
Liked: 1417
Congrats on your 12's. My A9's showed up tonight, moved my 70's to surround and set up the 9's, did Audyssey and have been playing CD's ever since. YIKIES, the detail man. Very impressed right out of the box, even my wife said, "is it just those two speakers on right now? Wow, I'm impressed, they really fill the room". I laughed and asked her what magazines she's been reading. But what a relief, the wifey likes 'em.

Spinning the rear tire at 150mph while at 3/4 lean angle will put wrinkles in your seat


Set up:
Integra 70.4--Oppo 103--LG50"Plasma--Emotiva: XPA-3, XPA-2 x 2--PolkAudio: RTiA9 x 4--CSiA6--FXiA6 x 4--Epik: Empire x 2--XBOX 360--Furez 10awg homemade cables
Geoff4RFC is offline  
Old 01-11-2012, 10:46 PM - Thread Starter
Member
 
bkgraham33's Avatar
 
Join Date: Oct 2007
Posts: 78
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Lucky you, my girlfriend HATES them. But it's my house and she'll eventually let the hatred for these beasts go, so it's all good... i hope.

I just ordered a CSI 5 for the center channel & my BIC PL-200 should be here early next week. I'm not going to worry about surround for now.

Can I ask how you hooked your A9s up? I did a bi-amp hookup, so I hooked the top inputs of each speaker to the front left/right of the receiver and then hooked the bottom hookup on each speaker to the left/right surround outputs on the receiver. As instructed, I also removed the metal that was connecting the two connection together on the speakers. Lastly I "told" my receiver that the two front speakers were bi-amped. This seemed to help, as the speakers were VERY "bright" with just a single hookup. I've heard that term on here and now I think I finally understand what it means. Do your A9s seem bright? Have you done anything different that I didn't mention here?

Sorry for the million questions, but I'm a noob on this subject and could definitely use some validation on the direction I'm heading.

Thanks!
bkgraham33 is offline  
Old 01-11-2012, 10:50 PM
AVS Special Member
 
Geoff4RFC's Avatar
 
Join Date: May 2010
Location: Just down aways from Stanley
Posts: 3,871
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 106 Post(s)
Liked: 1417
Not a problem, ask as many questions as you need.

I've got an emotiva amp. I've left the jumpers in and have the banana plugs in the bottom terminals.

I wouldn't say bright, very detailed.

Spinning the rear tire at 150mph while at 3/4 lean angle will put wrinkles in your seat


Set up:
Integra 70.4--Oppo 103--LG50"Plasma--Emotiva: XPA-3, XPA-2 x 2--PolkAudio: RTiA9 x 4--CSiA6--FXiA6 x 4--Epik: Empire x 2--XBOX 360--Furez 10awg homemade cables
Geoff4RFC is offline  
Old 01-11-2012, 10:54 PM
AVS Special Member
 
Geoff4RFC's Avatar
 
Join Date: May 2010
Location: Just down aways from Stanley
Posts: 3,871
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 106 Post(s)
Liked: 1417
How could anyone hate those beautiful speakers???? I was considering the 12's for a long time, I think they look great and I'm sure they sound amazing.

Spinning the rear tire at 150mph while at 3/4 lean angle will put wrinkles in your seat


Set up:
Integra 70.4--Oppo 103--LG50"Plasma--Emotiva: XPA-3, XPA-2 x 2--PolkAudio: RTiA9 x 4--CSiA6--FXiA6 x 4--Epik: Empire x 2--XBOX 360--Furez 10awg homemade cables
Geoff4RFC is offline  
Old 01-12-2012, 04:22 AM - Thread Starter
Member
 
bkgraham33's Avatar
 
Join Date: Oct 2007
Posts: 78
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Geoff4RFC View Post

Not a problem, ask as many questions as you need.

I've got an emotiva amp. I've left the jumpers in and have the banana plugs in the bottom terminals.

I wouldn't say bright, very detailed.

When I say bright, I guess what I mean is more treble and less bass. In fact until I set the receiver to "large" for the front speakers, there was zero bass coming from them which sounded more unappealing with each crank of the volume knob. At high volumes it was unbearable. But I bi-amped and changed the receiver setting to large at the same time, so I'm not 100% sure which of the two things improved it for me; I suspect it was the large setting though.
bkgraham33 is offline  
Old 01-12-2012, 10:26 AM
AVS Special Member
 
Geoff4RFC's Avatar
 
Join Date: May 2010
Location: Just down aways from Stanley
Posts: 3,871
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 106 Post(s)
Liked: 1417
Quote:
Originally Posted by bkgraham33 View Post

When I say bright, I guess what I mean is more treble and less bass. In fact until I set the receiver to "large" for the front speakers, there was zero bass coming from them which sounded more unappealing with each crank of the volume knob. At high volumes it was unbearable. But I bi-amped and changed the receiver setting to large at the same time, so I'm not 100% sure which of the two things improved it for me; I suspect it was the large setting though.

I can totally relate to that. My Audyssey sets them to small @ 40hz with a sub. When I first started listening to a CD, it was a little "shrill".

I went into set up, took out the sub and put the mains to full band (or large) and the sound was much better, the higher the volume, the more bass came out.

My wife was very impressed, I tried to fool her and asked how she liked the sub in the mix. She said, "I don't think it is the sub, I think it's the speakers and I can feel them".

My wife scares the crap out of me, as much as she says she doesn't care anything for my obsession, she's pretty sharp on the whole deal

Spinning the rear tire at 150mph while at 3/4 lean angle will put wrinkles in your seat


Set up:
Integra 70.4--Oppo 103--LG50"Plasma--Emotiva: XPA-3, XPA-2 x 2--PolkAudio: RTiA9 x 4--CSiA6--FXiA6 x 4--Epik: Empire x 2--XBOX 360--Furez 10awg homemade cables
Geoff4RFC is offline  
Old 01-12-2012, 11:11 AM
AVS Special Member
 
crazyrob425's Avatar
 
Join Date: Dec 2009
Posts: 6,834
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 363 Post(s)
Liked: 272
Quote:
Originally Posted by bkgraham33 View Post

Lucky you, my girlfriend HATES them. But it's my house and she'll eventually let the hatred for these beasts go, so it's all good... i hope.

I just ordered a CSI 5 for the center channel & my BIC PL-200 should be here early next week. I'm not going to worry about surround for now.

Can I ask how you hooked your A9s up? I did a bi-amp hookup, so I hooked the top inputs of each speaker to the front left/right of the receiver and then hooked the bottom hookup on each speaker to the left/right surround outputs on the receiver. As instructed, I also removed the metal that was connecting the two connection together on the speakers. Lastly I "told" my receiver that the two front speakers were bi-amped. This seemed to help, as the speakers were VERY "bright" with just a single hookup. I've heard that term on here and now I think I finally understand what it means. Do your A9s seem bright? Have you done anything different that I didn't mention here?

Sorry for the million questions, but I'm a noob on this subject and could definitely use some validation on the direction I'm heading.

Thanks!

The very bright sound could have been a loose connection to the metal jumper if you are connected to the top input which means you were getting sound only out of tweeter.

What gauge of speaker wire you using? Have you run MCACC yet?

If you think that the RTi's are bright go listen to some Klipsch Horn tweeter speakers. you will wonder why any one would call Polk's bright.

I found the RTi's are more revealing and have more detail so they exposes badly compressed music like MP3 or other downloaded formats
crazyrob425 is offline  
Old 01-13-2012, 05:03 AM - Thread Starter
Member
 
bkgraham33's Avatar
 
Join Date: Oct 2007
Posts: 78
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by crazyrob425 View Post

The very bright sound could have been a loose connection to the metal jumper if you are connected to the top input which means you were getting sound only out of tweeter.

What gauge of speaker wire you using? Have you run MCACC yet?

If you think that the RTi's are bright go listen to some Klipsch Horn tweeter speakers. you will wonder why any one would call Polk's bright.

I found the RTi's are more revealing and have more detail so they exposes badly compressed music like MP3 or other downloaded formats

Not sure of the gauge, but it's not thin. I did run the MDACC. Initially I connected to the top inputs only, and it was super bright. But the metal connector that connects the top and bottom was still connected, if that matters.

Now I have the front speaker connections on the receiver still going to the top, and in addition the rear surround output is hooked to the bottom; metal plate removed of course. I set the receiver to bi-amp and large for the front speakers.

They're still bright, but not like before. But I don't really hear any bass until I crank it. Is there value in me switching my connections around so the front speaker output is going to the bottom set of connections of the speakers??
bkgraham33 is offline  
Old 01-13-2012, 09:33 AM
AVS Special Member
 
Geoff4RFC's Avatar
 
Join Date: May 2010
Location: Just down aways from Stanley
Posts: 3,871
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 106 Post(s)
Liked: 1417
I've tried bi-amping my 70's off of my receiver and to tell you the truth, it really didn't do anything that I could hear.

You may want to just consider not bi-amping and just do a 5.1 set up, you'll actually be sending out more power to your speakers, check out a bench test on your model receiver and it should tell you the power output with 2ch, 5ch and 7ch driven, it's always the most power in 2ch and the least amount of power in 7ch.

And when you're bi-amping, you are essentially in 7ch mode.

Even though I'm using a separate power amp for my 9's, I removed the jumpers and did this;



My speaker cable is 10awg and I'm connecting the upper terminals with 12.

Spinning the rear tire at 150mph while at 3/4 lean angle will put wrinkles in your seat


Set up:
Integra 70.4--Oppo 103--LG50"Plasma--Emotiva: XPA-3, XPA-2 x 2--PolkAudio: RTiA9 x 4--CSiA6--FXiA6 x 4--Epik: Empire x 2--XBOX 360--Furez 10awg homemade cables
Geoff4RFC is offline  
Old 01-13-2012, 11:35 AM
AVS Special Member
 
chashint's Avatar
 
Join Date: Oct 2008
Location: Dallas, TX
Posts: 1,713
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Liked: 46
Quote:
Originally Posted by crazyrob425 View Post

If you think that the RTi's are bright go listen to some Klipsch Horn tweeter speakers. you will wonder why any one would call Polk's bright.

Fry's has been giving the RTi12 speakers away off and on for over a year, I have listened to them many times trying to like them but they just don't win me over.
People call the Polk speakers bright because they are, and I would even call them harsh with some material.
If you compare Klipsch RF series to the Polk RTi12 you will find the Polk speakers lack the clarity and definition the Klipsch have.
With the RTi12's discounted to under $700 for a pair they are comparable in price to Klipsch RF-52's at MSRP.
While the RF-52's are not my favorite Klipsch tower I would still take those over the RTi12's.
I seldom criticize any product on the forum, but it does get tiresome to constantly read the negative comments about the Klipsch horn tweeter that you post at every opportunity.

Regards,
Charlie

chashint is offline  
Old 01-13-2012, 01:14 PM - Thread Starter
Member
 
bkgraham33's Avatar
 
Join Date: Oct 2007
Posts: 78
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
How can I tell if my RTI 12s (or any speaker for that matter) are damaged?

I bought them new, but as I'm still trying to figure out the bes way to hook them up, the sound isn't at its best.

Would it be obvious if there was any kind of internal damge to any of the speakers??
bkgraham33 is offline  
Old 01-13-2012, 01:36 PM
AVS Special Member
 
Geoff4RFC's Avatar
 
Join Date: May 2010
Location: Just down aways from Stanley
Posts: 3,871
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 106 Post(s)
Liked: 1417
How much power are you feeding them?

One thing you could consider is calling Polk directly and speaking with a tech rep. I've talked to these guys before and even though they're east coast (did I say that out loud?), they're real friendly and very informative. You might want to give that a shout.

Spinning the rear tire at 150mph while at 3/4 lean angle will put wrinkles in your seat


Set up:
Integra 70.4--Oppo 103--LG50"Plasma--Emotiva: XPA-3, XPA-2 x 2--PolkAudio: RTiA9 x 4--CSiA6--FXiA6 x 4--Epik: Empire x 2--XBOX 360--Furez 10awg homemade cables
Geoff4RFC is offline  
Old 01-13-2012, 01:58 PM - Thread Starter
Member
 
bkgraham33's Avatar
 
Join Date: Oct 2007
Posts: 78
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
They're just plugged directly into my Pioneer VSX-1021 (bi-amped at the moment but will probably change that tonight).
bkgraham33 is offline  
Old 01-13-2012, 02:00 PM
AVS Special Member
 
crazyrob425's Avatar
 
Join Date: Dec 2009
Posts: 6,834
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 363 Post(s)
Liked: 272
Quote:
Originally Posted by bkgraham33 View Post

They're just plugged directly into my Pioneer VSX-1021 (bi-amped at the moment but will probably change that tonight).

Try what Geoff did with the wire and hook up to the lower terminals

Again what gauge wire are you using? Telling me its not thin doesn't help cause thick to one person might be thin to another
crazyrob425 is offline  
Old 01-13-2012, 02:40 PM - Thread Starter
Member
 
bkgraham33's Avatar
 
Join Date: Oct 2007
Posts: 78
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by crazyrob425 View Post

Try what Geoff did with the wire and hook up to the lower terminals

Again what gauge wire are you using? Telling me its not thin doesn't help cause thick to one person might be thin to another

I'm honestly not sure, but I'd be willing to be it's 16 or 14 guage at the most.
bkgraham33 is offline  
Old 01-13-2012, 02:44 PM
AVS Special Member
 
Geoff4RFC's Avatar
 
Join Date: May 2010
Location: Just down aways from Stanley
Posts: 3,871
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 106 Post(s)
Liked: 1417
I think I might know the problem, I looked at your receiver and it doesn't put out very much power (relative). I looked at the back and didn't see any pre-outs so you could at least add an amp.

I don't think you're getting enough power to the speaker.

Spinning the rear tire at 150mph while at 3/4 lean angle will put wrinkles in your seat


Set up:
Integra 70.4--Oppo 103--LG50"Plasma--Emotiva: XPA-3, XPA-2 x 2--PolkAudio: RTiA9 x 4--CSiA6--FXiA6 x 4--Epik: Empire x 2--XBOX 360--Furez 10awg homemade cables
Geoff4RFC is offline  
Old 01-13-2012, 02:48 PM - Thread Starter
Member
 
bkgraham33's Avatar
 
Join Date: Oct 2007
Posts: 78
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Geoff4RFC View Post

I think I might know the problem, I looked at your receiver and it doesn't put out very much power (relative). I looked at the back and didn't see any pre-outs so you could at least add an amp.

I don't think you're getting enough power to the speaker.

And because I don't have a pre-out on the back (except for the subwoofer) an amp is not an option for me, right?
bkgraham33 is offline  
Old 01-13-2012, 02:49 PM
AVS Special Member
 
crazyrob425's Avatar
 
Join Date: Dec 2009
Posts: 6,834
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 363 Post(s)
Liked: 272
Quote:
Originally Posted by bkgraham33 View Post

I'm honestly not sure, but I'd be willing to be it's 16 or 14 guage at the most.

Alright that shouldn't be horrible and be plenty.

Make sure both terminals are screwed tight on the jumper if you are using it. Additionally you might want to run with/without the receivers EQ as people have found some receivers EQ not to do the best job. I found with my RTi4's was the terminals really needed to be screwed extra tight to touch the jumpers and I had to make sure the bare was on the jumper as well

I usually listen to music I very comfortable with and have heard many times so I know what I should be hearing when testing speakers.

Might want to hook up to the lower terminals and see if the bass improves

And yes you would need pre-outs to get an external amp.
crazyrob425 is offline  
Old 01-13-2012, 02:55 PM - Thread Starter
Member
 
bkgraham33's Avatar
 
Join Date: Oct 2007
Posts: 78
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by crazyrob425 View Post

Alright that shouldn't be horrible and be plenty.

Make sure both terminals are screwed tight on the jumper if you are using it. Additionally you might want to run with/without the receivers EQ as people have found some receivers EQ not to do the best job. I found with my RTi4's was the terminals really needed to be screwed extra tight to touch the jumpers and I had to make sure the bare was on the jumper as well

I usually listen to music I very comfortable with and have heard many times so I know what I should be hearing when testing speakers.

Might want to hook up to the lower terminals and see if the bass improves

And yes you would need pre-outs to get an external amp.

Thanks, I appreciate the input. I'll undo the bi-amp setup and try going to just the lower terminals and make sure the connections are nice & tight.
bkgraham33 is offline  
Old 01-13-2012, 02:59 PM
AVS Special Member
 
Geoff4RFC's Avatar
 
Join Date: May 2010
Location: Just down aways from Stanley
Posts: 3,871
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 106 Post(s)
Liked: 1417
Quote:
Originally Posted by bkgraham33 View Post

And because I don't have a pre-out on the back (except for the subwoofer) an amp is not an option for me, right?

Sadly, but after you try your new configuration, see what you get out of it, unbi-amp, just run a 5.1 and try just doing 2ch and see how it sounds.

Is your receiver brand new? Can you return it for something with pre-outs?

Spinning the rear tire at 150mph while at 3/4 lean angle will put wrinkles in your seat


Set up:
Integra 70.4--Oppo 103--LG50"Plasma--Emotiva: XPA-3, XPA-2 x 2--PolkAudio: RTiA9 x 4--CSiA6--FXiA6 x 4--Epik: Empire x 2--XBOX 360--Furez 10awg homemade cables
Geoff4RFC is offline  
Old 01-13-2012, 03:20 PM - Thread Starter
Member
 
bkgraham33's Avatar
 
Join Date: Oct 2007
Posts: 78
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Geoff4RFC View Post

Sadly, but after you try your new configuration, see what you get out of it, unbi-amp, just run a 5.1 and try just doing 2ch and see how it sounds.

Is your receiver brand new? Can you return it for something with pre-outs?

Just bought it from Newegg. What a pain to return though, eh?
bkgraham33 is offline  
 
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off