Problems with Polk RC6S connection - AVS | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 02-23-2012, 12:57 PM - Thread Starter
Newbie
 
igor_arruda's Avatar
 
Join Date: Feb 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi, Guys! I need some help in order to not waste my money in vain. I bought a pair of Polk RC6s speakers. I intended to use them as surround speakers of a 5.1 home theater system, with a Pioneer VSX-51 Elite receiver. But I didn't know that they were made to be used lonely, instead a pair of speakers. Now I have to figure out a way to use this speakers with my receiver. They have a pair of +/- connectors, in order to produce stereo sound each one. Do you think it is possible to connect each speaker in a single channel (left or right) of my receiver? I was thinking of using just one pair of connectors of each speakers and leave the other one idle. There will be any damage? Otherwise, do you realize any way to connect each surround terminal of my receiver (left and right) in the two pair of connectors of each speakers in order to use the full power of the speaker? Thanks a lot.
igor_arruda is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 02-24-2012, 06:00 AM - Thread Starter
Newbie
 
igor_arruda's Avatar
 
Join Date: Feb 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Anyone? I'm totaly lost about this. I've already sent an e-mail to Polk, but no answers until now.
igor_arruda is offline  
post #3 of 3 Old 07-04-2013, 07:18 PM
Newbie
 
guilherme8's Avatar
 
Join Date: Jul 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi how do you fixed this?
guilherme8 is offline  
Sponsored Links
Advertisement
 
Reply Speakers

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off