Turtle Beach X32 Headset No Game Sound - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 05-29-2012, 07:29 PM - Thread Starter
Newbie
 
relapse71's Avatar
 
Join Date: Jan 2012
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
These headsets were working fine, and now I hear no game sound. I checked the connections in the back. The receiver sometimes has a flashing blue light, sometimes no light, and never becomes solid. I can hear "beeps" when I touch the tone or effect buttons. No game volume or xbox menu volume, even when on full. Headset beeps when turned on, with blinking side light. Wont pair with receiver, and only 3 months old and great condition. Any suggestions?
relapse71 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 05-29-2012, 10:15 PM
AVS Special Member
 
crazyrob425's Avatar
 
Join Date: Dec 2009
Posts: 6,443
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 184 Post(s)
Liked: 192
Its a turtle beach... i hope you bought the extended warranty. turtle beaches break and break frequently. Reason why i don't use Turtle Beaches
crazyrob425 is offline  
post #3 of 3 Old 05-29-2012, 10:21 PM
Advanced Member
 
dunan's Avatar
 
Join Date: Sep 2009
Posts: 667
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 35 Post(s)
Liked: 13
Quote:
Originally Posted by crazyrob425 View Post

Its a turtle beach... i hope you bought the extended warranty. turtle beaches break and break frequently. Reason why i don't use Turtle Beaches

Pretty much this.

I went with a reg pair of cans and a clip on mic but that's when I pc gamed more. Not sure if that would work with a console.
dunan is offline  
Reply Speakers

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off