polk audio RT55 wire question - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 08-09-2012, 04:46 PM - Thread Starter
Senior Member
 
splatee's Avatar
 
Join Date: Jun 2003
Location: Bay Area/San Diego/now DFW area Texas
Posts: 345
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 11
Ok, i just changed my current setup of Insignia bs-2111 to polk audio rt55 fronts and back. I am a bit confused on how to wire these biggrin.gif

I went the polk audio website and found the user manual but it is a bit vague. It explains how to bi-wire and bi-amping. All i want to do is connect regular but the terminals have metal jumpers connecting the top post to the bottom but they are only tightened on the bottom set. Now shouldn't these be tightened top and bottom?





Right now the top terminals are not tightened down. The jumper is just sitting loose.

Thank you
splatee is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 08-09-2012, 05:16 PM - Thread Starter
Senior Member
 
splatee's Avatar
 
Join Date: Jun 2003
Location: Bay Area/San Diego/now DFW area Texas
Posts: 345
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 11
Ok, i figured it out....they are both tightened down. I forgot that when they were unhooked from the previouse owners system they had to loosen up the nut rolleyes.gif and i am using bannana plugs. LOL.

Going to get these hooked up and calibrated now biggrin.gif
splatee is offline  
Reply Speakers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off