Fix Axiom M60 v2 rubber foot? - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!

Forum Jump: 
Thread Tools
post #1 of 3 Old 09-01-2012, 12:15 PM - Thread Starter
Advanced Member
FuzzyReets's Avatar
Join Date: Mar 2010
Posts: 650
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 73 Post(s)
Liked: 14
Hi folks. I have a loose rubber foot on my M60 v2 speaker. I tried screwing it back in but no such luck. What's the procedure to fix? Do I have to take one of the woofers out? Is that safe? Any help greatly appreciated. Thanks.
FuzzyReets is offline  
Sponsored Links
post #2 of 3 Old 09-01-2012, 02:26 PM
AVS Addicted Member
Bill Fitzmaurice's Avatar
Join Date: Nov 2009
Location: New Hampshire
Posts: 11,997
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 2693
How is it attached? Wood screw? If so put glue a toothpick or two into the hole to tighten the fit for the screw.

Bill Fitzmaurice Loudspeaker Design

The Laws of Physics aren't swayed by opinion.
Bill Fitzmaurice is online now  
post #3 of 3 Old 09-05-2012, 05:10 PM
Brenttom's Avatar
Join Date: May 2011
Location: Canada
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Remove the woofer and check to see if the T-nut is secured to cabinet. Using some pressure, try to secure the nut back into the cabinet. If it does not bite the cabinet, remove the nut and re-insert the nut from the outside of the cabinet.

Brent Tombari | Axiom Audio Expert | | 1.866.244.8796
Follow us on Facebook!
Brenttom is offline  
Sponsored Links
Reply Speakers

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off