What to do about this? - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 09-24-2012, 08:44 AM - Thread Starter
Member
 
Jrlane's Avatar
 
Join Date: Jan 2009
Posts: 49
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have a pair of Paradigm S6 v2 and recently noticed an issue with the top woofer. It looks like the surround has started to come unglued at two points. On the picture with my thumb where i have lifted up the rubber, it looks like the glue actually never went to the edge like i think it should, this leads me to believe it might have been a manufacturing error.

So the question is, do i dare attempt to glue it back down, or should i get Paradigm involved?





Jrlane is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 09-24-2012, 10:00 AM
AVS Special Member
 
Bill Fitzmaurice's Avatar
 
Join Date: Nov 2009
Location: New Hampshire
Posts: 9,531
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 1291
Ask Paradigm. They may send you some of the glue if It's a specific formulation, or they may tell you which generic products will work.

Bill Fitzmaurice Loudspeaker Design

The Laws of Physics aren't swayed by opinion.
Bill Fitzmaurice is offline  
Reply Speakers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off