Using Old Front Speakers as L/R Surrounds - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 03-14-2013, 05:39 PM - Thread Starter
Newbie
 
Setan's Avatar
 
Join Date: Sep 2008
Location: Rochester, NY
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hello Everyone,

I'm in the process of a small upgrade to my Onkyo HT-R540 setup I bought 5 or 6 years ago. While I'm waiting for the TX-NR818 receiver to go on sale, I decided to replace a few speakers. I have a KLIPSCH RW-12D sub on its way and today I bought 2 Pioneer SP-FS52 for the fronts and a Pioneer SC-C22 as the center.

I was wondering if it would make a difference if I took the old fronts, crappy Onkyo SKF-540F speakers, and put them in place of the crappy Oknyo SKM-540S surrounds. Would there be any improvement, or would it just be pointless?

I will be buying better surrounds in the next few months, just wondering if I should make this switch in the meantime.

Any guidance is appreciated!
Setan is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 03-14-2013, 06:09 PM
AVS Special Member
 
Elihawk's Avatar
 
Join Date: Jan 2011
Location: Iowa City, Iowa
Posts: 2,454
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 50 Post(s)
Liked: 156
I would use the best speakers available for surrounds...and then replace when you can!

Set up #1: EMP e5ti, e5Ci, and SLS Q line Audio surrounds, EMP 10i10i sub
Set up #2: Def Tech SM450, CLR2002, SLS Qline surrounds and Klipsch 12wD sub
Set up #3: JBL130, JBL120C and Klipsch synergy sub
Elihawk is offline  
post #3 of 3 Old 03-14-2013, 09:32 PM
AVS Special Member
 
sdg4vfx's Avatar
 
Join Date: Sep 2008
Location: Southern CA
Posts: 1,322
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 95
+1
sdg4vfx is offline  
Reply Speakers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off